VNC To OS 12.3 Missing Login Screen

Hi, I have set up a fully functional OpenSUSE 12.3 instance in VirtualBox, also running in 12.3. Everything works fine. Except VNC to other machines on the LAN.

  1. PROBLEM DESCRIPTION: Whereas all other headless machines on the LAN can be accessed from TightVNC, the new machine inside VB fails.

  2. HOW OTHER MACHINE LOGINS BEHAVE: In each case the full KDM (using KDE) login screen comes up right away, asking for username and password. However, for the new machine, the full KDE login screen does NOT come up – only the small VNC dialogue asking for password. And despite putting (I think) the password in Krfb, that password doesn’t work either.

  3. COPYING ALL SETTINGS: I have closely inspected all settings in machines that work (networking, firewall, VNC Remote, Krfb etc.) and copied those settings exactly, but this didn’t help.

  4. ALL OTHER NETWORKING FUNCTIONS WORK: Browsing to the web, or browsing on the LAN (there are two virtual NICs) all work fine. My sense is that this is not a VirtualBox problem?

  5. NETWORK SERVICES LIVE: Via XINETD, VNC1 is configured default (as is the machines that work).

  6. ULTRAVNC has been updated to latest version.

  7. CONNECTION HAPPENING: When I try to connect, a dialogue in the target machine flashes by as “connecting”, then “disconnected” . . .

So, basically, I’d like to see the full login screen come up, just like with the other machines – not just the little password prompt. And as I’ve had a lot of success with OpenSUSE for a few years entirely via YAST, I’d prefer to know if the problem can be solved via the GUI (although I have edited a configuration file or two from time to time). What I want to do seems pretty standard.

Any great advice? Thanks for insights!


Hmmm, trying to think how to get any insights here. Here’s additional info: If I go into the VNC GUI configuration dialogue, where you have to turn on VNC and open the ports, it always says “ports closed”. I can then open the port – and it will say port open. BUT, if I go out of the dialogue and back in again, then it again says “ports closed”. So somehow the firewall port is staying closed. On all other machines the appropriate interface is open for the appropriate VNC services – and stays that way.

Any insight appreciated. Thanks.

Or if you have some questions to research, that’s good too…

I think this information might have something to do with this issue:

New: Remote Administration Component In Yast2 Does Not Open Firewall Ports When Selected - - ArchiveOrange

**New: Remote Administration Component In Yast2 Does Not Open Firewall Ports When Selected
From: bugzilla_noreply — February-13-13 4:13:02 PM

From the first post: “After adding the permitted services manually, the VNC server asks the user for a password which does not appear to be the system’s root password, nor the password for the current user. This appears to be new behaviour for 12.3, and it would be helpful to know if this is by design. Additionally, other bugs pertaining to network/firewall behaviour are recorded here:”

Part of the answer to the original question relates to the “full login screen” versus a “password only”. I realize now that the full login (with the possibility of choosing a login user) is for a “one-time” session. This is what is desired – the password-only login therefore implies that the problem is also related to the fact that the VNC is only allowing a the creation of a persistent session. On all other machines the default login is the one-time only with full login screen. This is what I’d like to fix.

Give the research shared in previous notes, probably this query should not be limited to “login screen missing” – that seems to be only an artifact of the other issues.

Based on previous items, my next step is to install 12.2 OpenSUSE and see if that works. 12.3 has some nice features, but all my 12.2 systems seem to work fine.


Looks like no one replied.

I have, a very similar issue.

I have both a 12.2 and a 12.3 machine running. I can VNC to the 12.2 machine and I get the KDM login screen (version 4.8.5-2.18.1) where I enter my username and password and it works great!

But in 12.3, when I get the login screen KDM (version 4.10.5-1.111.1) and after I select the user from the provided list, there is no place to enter the password. (works fine from normal attached keyboard). VNC apparently cannot (does not) handle the newer KDM fancy graphics.

I do not know how to roll back to the earlier version of KDM or if that is possible or a solution.

Or, if there is a fix so that version 4.10.5-1.111.1 will properly display through VNC.

Have fun,

I don’t think changing KDE will help. I have the same problem and I am using Gnome.
Upgraded Opensuse to 12.3 from 12.1 and could no longer use Remote management.
I have Opensuse running inside VirtualBox.
At first lost the GUI login which was replaced with a Tight VNC login box. Then found in a similar thread It is also in the manual) how to change back the config to undo the changes the upgrade did. In etc/xinetd.d/vnc add to server argument, ‘securitytypes none’. I was then presented with gui login screen again (Gnome). I am presented the screen to choose a user and then get the screen with the user name, but never get a screen with a password box.
This only happens on a VNC connection, if I access the console, then it looks the same but get password screen and login OK. Sounds exactly the same as your problem.

I don’t know if anyone still cares. But I was having this issue and it turned out to be apparmor was the problem. I just disabled it ‘appamor’ and vnc works as it should.