VNC server on leap 42.2 problems

Hi,

I did a fresh install of open leap 42.2 on my intel nuc (had 12.1 before) and tried to enable the vnc remote server. Client is a windows 8.1 machine with either tightvnc or ultravnc (both have same faulty behaviour). I followed the instructions on https://en.opensuse.org/VNC and I can successfully connect to it. Problem now is, no menues pop up when right clicking with the mouse. Also moving the windows leaves traces of the windows so you manually have to refresh in the client. I have kde and kde5 plasma as desktop. On the other hand, just trying x11vnc from command line and reconnecting doesn’t show any of those problems. So i suppose the included vnc server is either misconfigured or a bit buggy. Anyone has same problems?

Last I experienced, SDDM does not support VNC. Try changing your Display Manager, go in Yast, install KDM, then switch to it, see if that helps.

But, I use Xfce with LightDM on the Server end, and I use VNCServer and VNCViewer, no problems.

Tried that already, same symptoms. Will try to finger more around in it, thx for reply

Okay. Good luck. Keep us posted.:wink:

Seems there is also a bug in the Yast2 Remote Administration setup. After enabling it, the services are restartet and system crashes to runlevel 2

Reviewing the page you’re using as a guide,
It’s out of date. It was originally written in 2010, with only a couple very minor edits late last year.
There are parts that are still relevant, but would need to be weeded out from what isn’t.

You should instead follow the openSUSE community docs
https://doc.opensuse.org/documentation/leap/reference/html/book.opensuse.reference/cha.vnc.html

As for your graphics problems,
I haven’t seen that for a long time but when I did experience it, it was due to a very limited/bad network connection and/or a problem on the client side. I can’t remember when it was ever a server-side issue(But of course that’s only my experience).

So,

  1. Install, start and manage your VNC server using YaST, not how described in your guide.
  2. Test the quality of your network connection.
  3. Modify the graphics parameters on the Server. to decrease load(eg fewer colors, lower resolution) You will need to create a custom configuration according to the instructions at the following link. Note that one of the major changes from years ago to today is that you should not pass graphics parameters in the client connection, it’s all managed on the server.
    https://doc.opensuse.org/documentation/leap/reference/html/book.opensuse.reference/cha.vnc.html#sec.vnc.one-time.config
  4. Re-install or use a different VNC client. All VNC clients <should> share a common core, but…

TSU

Okay, I have seen that on a machine running KDE & SDDM, every time I tried to set up Remote Administration in Yast.

I have not run into that with Xfce & LightDM.

Although I don’t think it should result in a crash, if you are using KDE, the Display Manager should be changed from SDDM to LightDM.

TSU

Well, it’s a mess. Tried the Remote Adminsitration with a different window manager, I also get a login screen, but that’s it. It logs in and falls back to login screen. I now changed all to gnome and did a x11vnc xinetd script and that seems to work.
Btw libvnc from xorg doesn’t work either when you change the /etc/x11/xorg.conf.d/10-libvnc script. Could bite my ass I upgraded >:(.
Also tried tumbleweed inbetween, is even worse lol (crashes X and stuff).

Forgot to mention that the libvnc method works fine in a VM running in virtualbox. Seems it is a problem of the intel graphics maybe (tested also various x driver options).

Just try x2go

IMO it’s highly unlikely that your VNC problems have anything to do with your hardware.
The reason why VNC works in your virtual machine isn’t because of the hardware difference, it’s almost certainly because your vm is “clean” without the modifications you’ve made.

You appear to have muddled your machine with improper configurations.
Can you remember what you’ve been doing and undo what you’ve done?

Recommend the following…

  1. Update your machine, run the following in an elevated console
zypper up
  1. Force re-install vnc. By “force re-installing,” you will be replacing any configuration files with the default which will wipe out any changes you’ve made to them. Generally speaking, there is only you might make changes, and that would be to
/etc/xinetd.d/vnc

The documentation for this is at
https://doc.opensuse.org/documentation/leap/reference/html/book.opensuse.reference/cha.vnc.html#sec.vnc.one-time.config

To “force re-install” vnc, execute the following from an elevated console

zypper in -f libXvnc1 tigervnc vncmanager vncmanager-controller vncmanager-greeter xorg-x11-Xvnc xinetd
  1. After re-installing your packages, re-open the YaST Remote Administration module to inspect your settings, primarily to verify your services are set to “Allow Remote Administration with Session Management” and to open the necessary firewall ports. Save your settings which should start/restart your Server services.

  2. If you’re running the KDE/Plasma Desktop, you can verify if you wish that you’re using the LightDM Display Manager (You can inpsect using the YaST /etc/sysconfig editor module). The above steps to re-install VNC should not have touched your Display Manager settings. As described earlier in the Forum thread, you cannot use the default KDE/Plasma Display Manager which is SDDM.

Do not do anything else server-side for now.
You should not launch vnc server from a command line, ever. The default configuration deploys vnc server already as a service, and is configured <only> using the file described above.

Now,
You can test your connections from a remote client, from the client side you <should not pass any options other than the port>, ie port 5801 for the vncviewer application, and 5901 for the vnc web browser applet.

HTH,
TSU

Well I am not so sure, the NUC uses i915 driver and there were already some issues with plasma and MESA.

You appear to have muddled your machine with improper configurations.
Can you remember what you’ve been doing and undo what you’ve done?

If there are any improper configurations, then they come from the base distributions. I didn’t change a single line of configs. I am using SuSE since almost 20 years so I think I know what i am talking about.

  • I just installed the standard distro of Leap 42.2 on my Intel NUC DC53427HYE (http://ark.intel.com/products/74483/Intel-NUC-Kit-DC53427HYE), 16GB RAM and an Intel m.2 ssd. After finishing installing I just tried to enable in graphical Yast2 VNC remote administration - crashed to runlevel 2. see other posts that verify it. DM was KDE and plasma.

  • I reinstalled the whole bunch again and then changed /etc/X11/xorg.conf.d/10-libvnc in that way that i only removed the comment signs, again with KDE and Plasma, vnc client connects but no updates after windows moving, pressing right mouse etc.

  • Again new install (because not to have a screwed config), use Yast2 to change Default windowmanager to gdm and Displaymanager to gnome (or vice versa). Tried again libvnc, same behaviour. Changed the file back and made a xinetd entry for x11vnc, which finally works now.

The vm i mentioned is a standard install in virtual box (latest version), same as on the NUC, and I just removed again comment signs in /etc/X11/xorg.conf.d/10-libvnc . And there it works. So I would suppose the only difference is in the machine setup.

You should do the following with a default openSUSE 42.2/KDE Plasma install…

  • Don’t do anything to any xorg files when setting up initially. When things are working, <then> you can try modifying. In any case the file you say you modified should only require the User to enter Username/Password to connect.
  • Configure your Display Manager to be lightdm. Do not use SDDM.
  • Leave your Window Manager as plasma5 (It’s the default).
    Do not custom modify the DM or WM further until things are verified working properly.

Now, open the YaST Remote Administration module
Select the radio button “Allow remote administration with session management” and check the box to “open port in firewall.”
Select “OK” which will install an xorg server and vnc manager packages if it’s being run for the first time. When complete, your VNC server server services should be restarted and running.

Now,
You should be able to remote in from another machine using a VNC client (you should only connect to IP address or hostname plus pprt 5801, nothing else)
You can also test connecting using a web browser (You need to have java extensions installed) on port 5901.

I don’t know where before you were experiencing some kind of crashing (server? client? at what stage in either case?)
But the above instructions should work.

I’m trying to imagine any reason why your xorg configuration edit might alter anything, and I can’t think of a thing. Also, I guess I’m still suspecting that you’re trying to pass parameters in the vnc client (you shouldn’t).

TSU