vnc issue [ all typing on remote screen remains in caps lock ]


I am trying to connect to opensuse 12.2 64 bit OS remotely using vnc viewer.
Whatever I type in remote machine’s terminal is getting displayed in caps.
I ensured that CAPs lock is off on both the keybaord.
Both keyboards are USB.
Any additional setting to be done?
on both OS, keybaord setting is US.


I had problems with the [ALT] key. When I switch window on my computer I used [ALT]+[TAB] and then the remote computer didn’t receive the release of [ALT] key. Try press [ALT] and [SHIFT] and [CTRL] key (not at the same time) and see if that release the [CAPS-LOCK] (even if it may not bee [CAPS-LOCK])
[edit] press and release when vnc window is active or selected or what it’s calles