vnc for multiuser system

I’m going to be giving another person remote access (from Windows) to my openSuSE 11.1 x86_64 system for a remote logon. I’ve been digging through several forums’ references to vnc, which seems to be the simplest protocol to give KDE access on a remote logon. (I’d like also to do it via ssh)

Trouble is, I’m getting quite confused by all the different approaches to doing this. (there’s basically one main approach to doing this on windows) I found x11vnc as a promising approach, but I’m not sure if this gives true remote logons or just access to existing sessions. Does anyone know of a simple DIY for non-sys-expert-types like me?


Getting very close to figuring this out:

  1. Turn on YaST/NetworkServices/RemoteAdministration
  2. Install Putty on the windows (client)
  3. Set up Putty according to these docs, except: make an additional tunnel to the ones in the docs like this:

Source port 5901

  1. Hit “Open” and you’ll get a openSuSE command-line logon,
  2. Log in as yourself
  3. Start UltraVNC and connect to
    At this point you’ll get the graphical logon to openSuSE. I’m still working on details, like how to change the screen resolution. Some of the documentation seems to say that by connecting to 5902, 5903, etc., you automatically get higher resolutions - but it has not worked for me.

Just install the NX windows client and the NX server/node/client on the
linux machine. Select KDE on the windows client setup, job is done :slight_smile:

If you have changed (which I recommend if the windows client is
coming from the internet) the ssh port, you just need to modify NX as

You can download the files from

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 15 days 19:46, 2 users, load average: 0.65, 0.59, 0.30
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

Wow - thanks, Malcom! I don’t remember exactly if I’d seen these before, but they sure look to be worth a try. The windows-to-windows rdp seems highly functional but the linux tightVNC and rdesktop servers though fast are missing some desktop integration functionality.

Also tunneling over ssh can be faster as well. As in any access type
service, just remember it is better to change the default ports, just keeps the hackers thinking :wink:

There is also FreeNX, but sometimes people have issues with it, more
than the original.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 1 day 23:36, 2 users, load average: 0.18, 0.09, 0.07
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

I just downloaded the .rpms, installed under OpenSuSE 11.1, and then installed the windows client on XP, and presto a really nice, well integrated connection (shares the windows clipboard, etc.). I couldn’t figure out how to cross-mount shares and it would be nice if the windows client could drag’n’drop file transfers.

I noticed that both tightVNC and UltraVNC windows clients are “touchy” - they crashed a lot unless I selected lower color depths and lower connection speeds. The LAN is very fast where I work, so it’s not that… But the NX client has perfect color and a very fast screen redraw. Thank you very much for the heads-up on that one!!

Great news :slight_smile: I’ve used winscp for transferring files from windows
machines -> linux/solaris machines. You can also activate the sound as
well in the configuration if required. Only one service to worry about
securing rather that this port and that port using vnc ports :slight_smile:

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 Milestone 6 (i586) Kernel 2.6.31-rc6-3-desktop
up 3:46, 2 users, load average: 0.18, 0.08, 0.01
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

I didn’t want to mess with the ports - it’s sitting on a corporate LAN (behind a lot of firewall stuff) behind its own router, so I have the suse firewall off. It’s pretty stealth, though the router does respond to pings from the LAN. I just forwarded port 22 to the openSuSE box. We have been shut-down a time or three by runaway viruses so the lan folks are getting intense. Still won’t make subdomains, tho.

Unless I can figure out the cross-mounting (or drag and drop) thing, I will likely use FileZilla to do sftp at the same time as nomachine is running. No sound subsystem on these CPU-monsters, though I would like to be able to print to the Windows printers (when using windows client to connect to NX). The printer drivers on my openSuSE box just aren’t there.

Also, it looks like there’s an issue with “shadow sessions” - when I log on through NX as “patti” to my desktop that I’m already logged on to locally - I can’t use firefox or thunderbird remotely because they’re “already running” (locally) so I can’t use them remotely. There’s probably a way to redirect or select running applications remotely, but it’s not obvious…

My bad - shadow sessions work fine - I just needed to find the right drop-down menu to start one. The one nice thing that UltraVNC has that NX doesn’t is screen autoscaling. I have Xinerama enabled on my host, but NX can’t display it properly. So I just log in as myself but not a shadow session and make sure I don’t leave firefox running when I’m not sitting at a logged-in session (that way it’ll be available to all sessions). For some reason you can only have one instance of FireFox or Thunderbird running.

Thanks for the tip.

I tried NoMachine NX package on my openSuSE 11.1 64bits, it’s quite nice and easy to use and install.

I immediately uninstalled all my other vnc, rdp or nomad packages I have previously used because they gave me such a headache, with no session lasting more that 5-6 minutes before disconnecting.

No such thing with this NX client and server.

Ahmed Samir