VMWare workstation 6 problem

I have just upgraded kernel and kernel-source to Linux x86_64 from opensuse updates (using opensuse 11.0) and I cannot get vmware to run after running vmware-config.pl

It seems like the vmware-config.pl only goes 75% of the way, and then ends.

Has anyone else had this problem?

You have to reinstall vmware after a kernel upgrade

In the past, I have only run vmware-config.pl after the upgrade and it has always worked.

However, I’ll try it your way

You could also try this as su
mv /usr/lib/vmware/modules/binary /usr/lib/vmware/modules/binary.old

then run as su “vmware” and it will recompile

Can you copy and paste the output of vmware-config.pl, i.e. the part where it’s going wrong?

Well I got the problem solved - and it was due to me not knowing how to handle the command line screen. I should have typed Q to get a less screen. This is something I will study and practice.
So when I ran vmware-config.pl, It went into a network setup subroutine - and I didn’t realise that I had to jump out of it to the less screen. Thank goodness for the boffins!
Previously, this did not happen when the kernel was upgraded.

The nice thing is that even though I uninstalled vmware and then put it back - all my previous setup was still intact - good ol’ linux

Well that should have occurred to had to do it in the past :stuck_out_tongue:
Glad you got it sorted