VMWare Workstation 10 and VMWare Tools Issues

Hi there,

I’m a newbie to the Linux world; I’m using VMWare Workstation 10 and I have sucessfully installed OpenSuse 13.1 as a guest OS.

My Host OS is Windows 7 64 bit.

I followed the steps to Manually install VMWare Tools in a Linus VM and it worked OK and I can see/access my Shared folders in windows.
This is the link to the steps:

My problem is that after installing other packages -through YAST - to OpenSuse, I lose the ability to see my shared folder under hgfs again and
the only way to resolve this is by re-installing the VMWare tools yet again from scratch.

Is there a way to fix this such that I don’t need to re-install VMWare tools everytime I install a package through YAST?

Any help will be appreciated.


You shouldn’t have needed to install the VMWare Tools, as openSUSE comes with open-vm-tools that should be installed by default.
Did you uninstall them before? You should.

It is normal that you have to reinstall kernel modules after a kernel update when you installed them manually.

I would suggest to just uninstall the VMWare Tools again, and reinstall open-vm-tools in YaST->Software Management (right-click on the package and select “Update Unconditionally”)

From the package description:

Open Virtual Machine Tools (open-vm-tools) are the open sourceimplementation of VMware Tools. They are a set of guest operating
system virtualization components that enhance performance and user
experience of virtual machines. As virtualization technology rapidly
becomes mainstream, each virtualization solution provider implements
their own set of tools and utilities to supplement the guest virtual
machine. However, most of the implementations are proprietary and are
tied to a specific virtualization platform.
With the Open Virtual Machine Tools project, we are hoping to solve
this and other related problems. The tools are currently composed of
kernel modules for Linux and user-space programs for all VMware
supported Unix-like guest operating systems. They provide several
useful functions like:

  • File transfer between a host and guest
  • Improved memory management and network performance under
  • General mechanisms and protocols for communication between host and
    guests and from guest to guest

Hi there,

Thanks for the response wolfi323. I’ve now installed/re-installed open-vm-tools.

Question: after installing open-vm-tools, how do I access my share folder - do I just look under /mnt/ folder or do I need to do something else?

Thanks and regards,

open-vm-tools should work exactly the same as the VMWare Tools, since they are in fact the same just re-released under an Open Source License.

I never used them myself, so I’m not completely sure, but you would either mount shared folders with “mount” or add them to /etc/fstab I guess.

Apparently running “vmware-hgfsclient” should list all your shares.
And by adding the following to /etc/fstab they should show up under /mnt/hgfs/ automatically:

.host:/ /mnt/hgfs vmhgfs defaults 0 0

(You would have to create the directory /mnt/hgfs yourself though I think)

See also here:

I don’t have a working VMWare installation at the moment so I can’t try. (I’m using VirtualBox mostly… :wink: )
If I manage to compile the VMWare kernel modules on 3.11.10 (it’s always a hassle to hunt down a patch for newer kernels), I may have a look though.

So…I’ve added the below line verbatim to my /etc/fstab:

.host:/ /mnt/hgfs vmhgfs defaults 0 0

The problem is OpenSuse won’t start up; all I get is the OpenSuse loading screen - the one with the chameleon.

Is there a way to startup in a “safe-mode” manner and revert/[correct - if need be] the changes to my /etc/fstab ?:slight_smile:

Thanks and regards,

Sorry, I just copy/pasted that from the VMWare manual.
Have you tried to press ESC or Ctrl+Alt+F1 when it’s stuck at the splash screen?

Is there a way to startup in a “safe-mode” manner and revert/[correct - if need be] the changes to my /etc/fstab ?:slight_smile:

Actually you should get to “emergency mode” in such a case, but there may be a bug that prevents that in certain circumstances. (one such bug has been fixed recently AFAIK, but there’s no update yet for openSUSE 13.1)

In any case, to get to a minimal repair system, just add “init=/bin/sh” to the boot options:
Press ‘e’ at the boot menu, search for a line starting with “linux” and append “init=/bin/sh” at the end. Then press ‘F10’ to boot.
You should get to a text mode prompt then where you can edit your fstab. (this also comes in handy should you forget your root password… :wink: )

As for mounting shares in VMWare I cannot help you more at the moment.
I’ll try to get VMWare running and test this, but I’m not sure yet how long that will be…

Maybe someone else has a hint in the meantime?

The Ctrl+Atl+F1 or Esc doesn’t work - as it immediately takes me to the loading screen. Surely, there has to be a way in OpenSuse to boot to the command prompt from VMWare workstation or VirtualBox.

Anyway, you’ve been great with the help wolfi323.

Thanks and regards,

Yes, as I said:

Press ‘e’ at the boot menu, search for a line starting with “linux” and append “init=/bin/sh” at the end. Then press ‘F10’ to boot.

You should get to a text mode prompt then where you can edit your fstab. (this also comes in handy should you forget your root password… )

Hey guys…

  • Setup your VMware Shares on the Host in the Guest Config > Options
  • Note that when you clone a VM, although the shared folders may be enabled, they will be disabled on first boot (simply re-enable in the Guest config)
  • <Do Not> enable your shared directories in fstab. It’s unnecessary and has unpredictable consequences. Instead, by simply doing the above, systemd invokes and mounts the shared directories as part of mount.target (although I haven’t traced the entire way implemented, I know that it starts with mount.target for a fact) If Shared Directories is supported with your installed version of VMware Tools, configuring shared directories and enabling/disabling can be a runtime modification (don’t have to reboot the Guest).
  • You should never need to invoke vm-tools from the command line. Watch your boot, you will see it enabled then and it will continue to do it’s good stuff without your interaction.

If you setup VMware Tools correctly, all of the above should “just work”
If you run into any fundamental problem (eg shares <really> not working), then the simplest fix is to just re-run the perl script re-installing VMware tools, <accepting all the defaults>. And afterwards, everything should be working again. Always make sure that the version of Tools is consistent with the Host version. This should be the case if you install from the OSS repos. If you install from a VMware package, then just make sure you point to the Tools ISO image that’s part of the downloaded package (don’t go looking for an ISO from somewhere else).

HTH, and all above strongly recommended over the things I see in this thread,


I’m not even getting a prompt to put in my password - so hitting the e or even the Esc key only shows a brief message about “systemctl default” and then instantly switches back to the boot screen.

I do have a backup of my VM which I can use, but I sure would like to know how to overcome this and be able to enter my password and make changes.

Kind regards,

You have to press ‘e’ at the boot menu, i.e. the screen where you can select which operating system to boot. (openSUSE, Advanced Options, …)

wolfi323 - you’re a star! Your last post did it. I’m now successfully logged back into my Opensuse and it’s working as a charm. Many thanks - my friend!

I must say, if I hadn’t communicated with you guys, I would never have worked out that I’ll have to press the e key at the boot menue and add init=/bin/sh. Just wished the linux/suse community had more of these troubleshooting tips available to new comers.

Kindest regards,

Another comment…

Just because you think the screen may be frozen on bootup, it might not be.

Just wait.
If necessary, over 2 minutes (look at your watch).
I’ve found time waiting varies possibly based on Desktop used (maybe other factors as well).

I’ve posted to bugzilla a bug I’ve found that applies at least to all VMware Guests and likely a good many other virtualization technologies as well.
The issue is that there is a long well-known issue about distros (not just openSUSE) thinking they’re finding SMBus hardware but then not finding… essentially hanging for a long time as it goes through its detection and config process during boot.

You have to wait until it times out. I’ve tried the publicly posted way how to blacklist SMBus without success.

Have you double-checked what I posted, that your situation may be simply resolved by re-inspecting the status (enabled/disabled) of your Shared Folders in your Guest properties, that everything else you’re currently doing may not address your issue properly? There are certain situations where shared folders are disabled on their own and you need to manually re-enable.



Thanks for the response. Yes, I removed VMWare tools from my fstab and just re-ran the perl script. It is all working fine now.

Thanks and regards,