VMware install fails w/ kernel Linux 2.6.31 on 11.2 factory

Just a quick note about installing VMware Workstation 6.5.2 on openSuSE 11.2. Now keep in mind VMware Workstation on openSuSE 11.2 isn’t supported (even 11.1 only has beta support).

After installing with either .rpm or bundle, VMware will fail during first startup (while compiling the needed kernel modules).

Error will look something like:
/tmp/vmware-root-4279300094/modules/vmmon-only/linux/driver.c:2007: error: too many arguments to function ‘smp_call_function’
make[4]: *** [/tmp/vmware-root-4279300094/modules/vmmon-only/linux/driver.o] Error 1
make[3]: *** [module/tmp/vmware-root-4279300094/modules/vmmon-only] Error 2
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory /usr/src/linux-2.6.31-rc6-3-obj/i386/pae' make: *** [vmmon.ko] Error 2 make: Leaving directory /tmp/vmware-root-4279300094/modules/vmmon-only’

The problem is with the VMware compiler script, and an “un-official” patch can be found in this thread at the vmware forum, along with more info if needed:
patch for Workstation 6.5.2 on Linux 2.6.31 kernel

If you just wanna take my word for it… after your ‘failed’ install, just download these two files to the same directory:

Then run the .sh script (you might have to make the script executable… I used “chmod 777 vmware-6.5.2-newkernmods.sh”) and your set.

This should work for both 32 and 64 bit architectures, and I also believe it says it should work for VMware Server.


A new version of VMware Workstation 6.5.3 (Build 185404) has been released and it doesn’t require any patch for the modules to compile correctly.

I have only tested the .bundle 32 Bit Install

I have also experienced issues with mouse and keyboard mappings issues, but if I stick to mainly console ‘activites’ inside the guest OS, it is fine.

If it starts affecting your host keyboard, reset your mappings by entering ‘setxkbmap’ at your console.

Another forum thread mentions the error with focus grabbing not working correctly inside VMware guest.


it doesn’t show a solution but I will update if I see a fix.


Thanks to your patch I got VMware server 2.0.0 32bit rpm to run on openSUSE 11.2. Had to do slight modifications to the patch (md5 sums and exclude vmblocks related stuff). :slight_smile:

There are still lots of warnings and an optional part does not compile, though.

Unfortunately I have that focus grabbing problem too. That means: still not usable :frowning:

And it seems I’m not allowed to post attachments to share it :frowning:

Ahh… sounds like you’ve had a lot of fun. So I hope your situation is actually different then the thread title.

  1. We now have the release of openSuSE 11.2!!! :slight_smile: (very bueno)

  2. The release of VMware Workstation 7 (also mucho goodness)
    It does require a different license then for 6.x, but it also supports openSuSE 11.X! And as such installation is easier than ever and I have not had any issues at all. Here is a trial activation code, I can’t remember if it is for 30 days or until Nov 30… either way, just a way to try it out.

Even with the activation code you’d still need to find a place to download it… so it may just be easier to go to Vmware’s website. here is the link to sign up for a free 30 day trial of VMware Workstation 7.0

If neither of those take care of it for you, I have heard running a vm in ‘Unity’ or ‘full screen’ modes help take care of the focus/grabbing.

Let me know if you find something else out.


Now that the VMware modules compile under opensuse 11.2 with the help of the patch, I have also solved my mousegrab problem. This post showed me how:

vmware server2.02 workaround for karmic 9.10

Jules98 describes two solutions, I chose #1:

load startup wrapper in vi:

vi $(find ~ -name 'VMwareVMRC@vmware.com')/plugins/lib/wrapper-gtk24.sh

and add those three lines after the first empty line:

# Fix "mouse grab" bug

At last, now my XP VM runs fine :smiley:

Since I had upgraded to VMware Server 2.02 and to the newest VMware guest hardware and the newest VMware tools, this could also be required.


P.S: would have been more fun if it worked ootb :frowning:
But then - it was analyzable and fixable - thats why I like linux so much :slight_smile:

Thanks for your work on this…