VMWare 6 on Suse 11 - No Sound in Win XP Guest

I am having a problem getting sound working in an XP guest in VMWare 6 on Suse 11. When the VM starts, there is an error message:

Failed to open sound device /dev/dsp: Device or resource busy
Failed to connect virtual device sound.

Sound works fine in Suse. Nothing is accessing the sound (and I made sure that kmix was not running also). Even on a fresh boot, I get the same results. I have an open question to VMWare support on this but nothing as of yet. I heard that kde (I’m running kde4) usually grabs exclusive use of the sound device but I’ve not seen anyway to stop this.

Has anyone run into this problem and solved it?:confused:

Sound is working ok here? I do have the setting set to auto rather then to /dev/dsp.
Which VMWare are you using (server, workstation) and what version?

Could have something to to with setting the correct rights… You could try rerunning the vmware-config from the console to see if that fixes things…

I’m using VMWare 6 workstation - sound is set to automatic. I tried rerunning the config and same issue.

What desktop are you using?

GNOME :slight_smile: Could be the sound manager in KDE is holding the card for ransom…

Is it version VMWare version 6.0.4 or a previous version with the any-any patch? Other that that I’m running the here on a 32 bit laptop.

It’s the newest version. My guess is that, since you are running Gnome and having no issues, it is probably like I thought and you seem to concur - it is KDE.

That was it. Installed Gnome and booted into it. No sound problems under Gnome - the Windows XP VM has sound.

I really rather use KDE but for now I suppose for when I need to use VMWare I’ll have to run a Gnome session instead of KDE. If anyone knows of a fix under KDE please post it!

There have been some posts on this… As my main environment is GNOME can’t help you there other than pointing to these posts:

Help me fix my sound? - openSUSE Forums (look at the tips in post #3)

VMware Communities: Failure to open sound /dev/dsp problem …

Good luck!

Thanks - I found knotify running … killed it and I now have sound in the VM under KDE.

Is it version VMWare version 6.0.4 or a previous version with the any-any patch?

Yes, I am use the 6.0.4 with any-any patch. No sound!

Is there a way to get the sound?:frowning:

Hi I had the same problem (no sound in guest XP on SuSE), selecting the correct “driver + controller” in VMVirtualMachin (I use Oracle VM 4.1.6) solved the issue, follow the steps below to resolve this issue:

Launch VM VirtualBox (don’t start/boot WinXP yet) -> in menus click on “Machine” -> “Settings” -> “Audio” -> (make sure “Enable Audio” is checked) now select the following:

“Host Audio Driver” = OSS Audio Driver.
“Audio Controller” = ICH AC97.

And that’s it, boot your guest OS, audio should work fine.


This thread is nearly four years old. I imagine the OP has moved on by now.