VLC SuSE 11.1 5.1 surround problem

I have the following problem with Vlc player. When I try to switch from mono or stereo to 4 channels or 5.1 surround audio on any movie with (or without) 6 channels audio - AC3,DVM the audio disappears and it is not possible to switch back to stereo or mono,the video continuous,but it is not possible to quit the Vlc player - the only possibility is with killing X server and logging back. I tried vlc players from Packman as well as VLC repo, but there no difference.

I had the same problem in SuSE 11.0 , but have never had such problem in SuSE 10.2 or SuSE 10.3.

The same movies in SuSE 11.1 play fine in smplayer in 5.1 surrounding mode and could be switched back and forward to stereo mode.

Any ideas how to fix that?

I remember years ago I had a problem with vlc, in that it would not shut down easily. I was always able to kill the application from a konsole.

But killing the X server is rather, … well, … rather drastic. :slight_smile:

Did you try running “ps -A” and get the PID# of vlc, and then try, first as a regular user:
kill -9 PID#
where PID# is the PID # of vlc
and if that does not work, try:
su -c 'kill -9 PID#'enter root password when prompted for a password. Again note PID# is the PID # of vlc.

Alternatively, if using KDE, you may be able to press <ctrl><esc> and then kill vlc (if still running) via that GUI.

That might cure the symptom, but not get rid of the cause. I don’t have a 5.1 system yet (I might buy one this weekend) so I can’t offer any more help than that.


True. olegue - ignore my post above.

… although, reading the 3rd time … these words have me puzzled …

That reads like the only way to shutdown vlc was to kill the X server.

Surely that is not correct? Does not the "kill -9 … " shut down vlc ?

Agreed, it won’t solve the problem of the surround sound .

Which one do you gona get for speakers Creative?

Probably a 5.1 set that is not expensive, and is not going to blast the neighbours out … (my wife and I live in a relatively small apartment). I’m thinking of the Logitech X-540, and tomorrow I just may just purchase them

After shipping, there is not much to be saved by ordering via mail order, so I’ll likely pick the speakers up from our local PC shop (which is within walking distance): Zimmermann Electronic GmbH - Logitech X-540

I now have a 5.1 surround system, and it works fine with vlc.

One idea is you could try changing ".cache/vlc " to “.cache/vlc-bak” and you could also try changing “.config/vlc” to “.config/vlc-bak” and also change “.local/share/vlc” to “.local/share/vlc-bak” and see if starting your vlc configuration over helps.

Note by that appoach, you can always restore things back to the way they were, if it makes things worse.

I will get the G51 5.1 surround system next week and all there toys I cant like MSI X58 the top of the line waitlol! Ill bring up in Soapbox we can chat ;).


The G51 reads like a nice system. I read about it here:
Logitech G51 Surround Sound Speaker System Review - Overclockers Club

The ability to change skins on the speakers is kind of neat. And the classic logitech feature of a control center (and not forcing one to crawl on the floor by the subwoofer to adjust settings) is nice.

Thnx but one dude put logitech subwoofer THX Z-560 in front of Garbage door,may I`m lucky if is still working,I let you know ;).


I managed not to freeze the system when tried to switch the vlc audio to 5.1 , and even sometimes i can go back normal in stereo or at least I can quit the vlc normally.
It happened when i made fresh installation of only gnome, updated it and then installed nvidia drivers . Installed applications I need and at the end I installed kde 3.5 and after that kde4.x.
I do not know what happens wrong when install gnome together with kde in suse 11.1, may be it something connected with kde 4.x libraries .
Qt applications refresh badly in compiz. (visual artefacts)

I ended up purchasing the Logitech X-540 5.1 surround system. Its fairly basic, but more than adequate for my wife and my very small apartment.

I ended up documenting my experiences here: Exploring surround sound in Linux - openSUSE Forums

I tried out the Logitech X-540 on two different PCs (it worked on both). I initially tested it on my ancient athlon-1100 (on an MSI KT3 Ultra motherboard). And then later I connected it to my new Intel Core i7 Asus P6T Deluxe V2 motherboard, where it also works (albeit I have not spent the time to figure out all the quirks yet). Both PCs are running openSUSE-11.1 with KDE-3.5.10.

One both PCs with surround sound, vlc plays fine.

Do you think that using 5.1 in one application blocks the possibilities to use any other sound application is a good decision in linux.
I tried vlc and smpalyer in windows in 5.1 and they do not block possibilities to play some song for example in other application , both use one sound card and sounds from one and the same speakers.

In suse if I play something in 5.1 I can not use the sound abilities of other applications- for example if I watch a move I have to stop it to be able to respont of a skype call.

Very inconvenient.

I’ve never observed that behaviour with my 5.1. system on openSUSE-11.1 with KDE-3.5.10, but then again, I do not use skype.

And how it is possible you have working 5.1 vlc in case I suppose you use the same suse 11.1 origin instalation as I do, and same repo as I do - VLC or PACKMAN.
On your system you have also drivers loaded and working as in mine .
Up to here there are no differences - but the result is you have functionality that I have not, the worse thing is I can not find out why.
I have no conflict libraries or any notice that something is wrong.

I think it is a good idea for the people who create sotware to make some sort of control of functionality of the application, obviously the debug mode is not enough or simple monitoring systems, the applications work in the field of living operating system, not all alone.

As I see linux is very sensitive and reacts individually :)))

Well it does not matter which application is used in 5.1 mode, all the other sound using applications stop work (try with amarok). Start some movie in 5.1 and after that start amarok - it does not work, or any other sound application - the message is that sound card is occupied :))
And the opposite - have working sound player for example and start a move in 5.1 it won’t start until the first application keep working :))))

OK, what ever you say. I believe you when you say it does not work for you. It works for me.

I’m currently playing a 5.1 surround track with vlc and with amarok playing at the same time as I type this. I don’t know why someone would want to do it, but it works on my PC.

As for Skype, … I don’t use it.