vlc plays video but no sound

HI everyone, First of all opensuse 11 is simply the best and it’s a wonderful experience working with it and this is my first post in this forum…
I recently downloaded vlc from its site n my repository is from videolan website. whenever i play a movie or even mp3 file for that matter there is no sound but i do see a video. Plz solve my problem.And also i am unable to configure net n browse net as a normal user but as root i can do it… what should i do to browse net as noemal user?

Do you have any sound at all? Please copy and paste the following into a gnome-terminal / konsole and advise if it gives you any sound:
speaker-test -Dplug:front -c2 -l5 -twav

If you have no sound try working your way through the audio troubleshooting guide here:
SDB:AudioTroubleshooting - openSUSE

Note, each time you have to test your sound, use the above sound test.

If you have speaker-test sound but your media players give no sound, then this could be because your rpm with your codecs ( libffmpeg0 ) is not compatible with your vlc version.

My recommendation is you remove videolan from your repositories, and add only OSS, NON-OSS, Update and Packman. Just those 4. No others. There is guidance how to do that here:
Repositories/11.0 - openSUSE-Community

Again, add only OSS, NON-OSS, Update and Packman and remove all others.

Then replace your videolan vlc and libffmpeg0 with the Packman packaged libffmpeg0 and vlc. While you are at it I also recommend you install smplayer, libxine1 (you may need to remove xine-lib first), xine-ui, w32codec-all, and libquicktime0.

Good luck.

Dear oldcpu,
When i did so as per your advice, i encountered an error message saying "subprocess failed. ERROR:RPM failed:…failed dependencies… vlc cant b installed
and a couple of ‘needs’ like this
libavc1394.co.0 is needed by vlc 0.9.1-0 pm2.i586
libadc1394_control.so.12 is needed…
.and finally libzvbi.so.0
(could not copy paste de whole thing). Please guide me

If your repositories are set up properly, with only the 4 repos that I mentioned (OSS, NON-OSS, Update and Packman) per this URL here:
Repositories/11.0 - openSUSE-Community
then that error message should not occur IF the server is up. There is the possibility that the server is down. … and there is also the possibility that you have an internet connectivity problem, or that you access the internet via a proxy, … and I can’t help wrt that (if that is the case) as I know nothing about that.

Again, wrt your repos, add only OSS, NON-OSS, Update and Packman and remove all others.

ya i had other reos but i disabled them all. Now i even deleted them all. But inspite of that i get the same error message:( I dont have proxy servers or any kind of such problems. Please advice and help

You need the 4 repos that I mention below. If you delete those nothing will install.

With those 4, and only those 4 setup (oss, non-oss, update and packman) please try again. Just those 4. If you get a dependency message, please copy and paste the entire error message to general pastebin - simplified internet collaboration or to some other paste bin site, and paste here the URL to the message.

dear old cpu,
I managed to uninstall vlc then installd it from install oftware options in opnsuse11. it installed but not opening up. And one more thing i didnt delete those 4 repos. I had additionals like opensese debug, dvd repos which i deleted.

Also note that if you have special desktop effects enabled (ie 3D, “the cube” ) , that could impact your capability to play video. If you do have special desktop effects enabled, try changing the video output module in vlc from ‘auto’ or ‘xv’ (xvideo) to “x11”.

Also, to check what you have installed, please post here output of copy and pasting the following into a gnome-terminal / konsole :

rpm -q vlc libffmpeg0 libxine1 xine-ui smplayer MPlayer libquicktime0 w32codec-all

I’m actually having a similar problem with VLC. I’ve updated and done all the usual stuff already but it still seems to not work.

I found this thread which does offer advice on the subject but again, I tried that and it still didn’t work.

Start VLC, click settings, Sound. Check the box for advanced options down to the right. Under the option output, choose ALSA, save & restart VLC.

No sound in vlc in openSUSE 11.0 - LinuxQuestions.org

Any ideas?

Can you provide us the details as to EXACTLY what rpms you have installed for vlc? Specifically, copy and paste into a gnome-terminal / konsole:rpm -q libffmpeg0 vlcand post here the output.

Also, IMHO you should install smplayer and MPlayer (where smplayer is a front end to mplayer). IMHO smplayer is currently the best video player available for Linux.


This is what I’ve got so far. I have MPlayer but not the other.

Scrap that. I just got SMPlayerand it’s working like a treat.

I note those rpms are all videolan packaged applications. I typically recommend the packman packaged versions instead. …

BUT … having typed that, I have read a couple users complain the packman vlc version plays video in a choppy manner (of course such users NEVER provide codec details … >:( … ) , and a few nights ago, when I did a quality check on a video_ts directory (custom home made) I experienced some choppiness as well (on the packman packaged version). My observation was:

  • packman packaged vlc had choppiness with video_ts directory of custom created dvd
  • I then tried playing the raw vob file (within the video_ts directory) with the packman vlc and I experienced choppiness, and then
  • I tried playing the raw mpeg file (used to create the vob) with the packman packaged vlc and I experienced choppiness, and then
  • I used the same vlc to play the raw avi file (h264 format) used to create the mpeg, and I experienced no choppiness. Played fine!

I then tried smplayer and xine on the vob and mpeg file. They played it with no problems. So IMHO the Packman vlc may have a problem with mpeg? I know this is recent because I did not see this a couple of months back. There have been updates to both packman vlc and packman libffmpeg0, so I need to roll back these versions, until I can find out what version started causing the problem. Once I do that, I can send an email to the packager with the details.

The problem is the above will take a couple hours of exclusive undisturbed time, and I may not have that time.

Agree. I REALLY like smplayer.

package libxine1 is not installed
package smplayer is not installed
package libquicktime0 is not installed

and for vlc i get


but one thing. now i am able to start vlc but the images appear more blue green tinted. sound often crashes

Ok, thanks.

Your libffmpeg0- (packaged by videolan) is not compatible with your vlc-0.9.1-0.pm.2 (packaged by packman). I recommend you try replacing the videolan libffmpeg0 with a packman packaged libffmpeg0 (although I confess I am a bit worried about choppiness).

To mitigate that risk (by providing a better player as a backup), I recommend you install the packman packaged smplayer. IMHO it is a better player than vlc.
SMPlayer - General Info
… again, smplayer is in the packman repositories, so if you setup your repos per my recommendations, you should be able to install it with:
su -c ‘zypper install smplayer’

On my openSUSE-10.3 32-bit PC, I rolled back my packman version of vlc from vlc-0.9.1-0.pm.2.i586 29.08.2008 to vlc-0.8.6i-0.pm.2.i586 29.07.2008 and the choppiness went away. This appears to be a problem with the new 0.9.1 vlc. Not sure if it is packager induced. I’ll send an email to the packager.

Maybe a bit late but I solved it in both 11.1 and 11.2 by

Start VLC, click tool, Preferences. Check the box for advanced options down to the left. Under the option audio, output module, choose ALSA, then click ALSA and change the default to your soundcard.
Done :slight_smile: