VLC no longer plays video with h264 encoding?

opensuse v12.2
VLC media player - 2.0.4 Twoflower
Nvidia gt 470, nouveau driver

I received a MOV video file from a friend. When I tried to play it with VLC, I got this:

No suitable decoder module:
VLC does not support the audio or video format "h264". Unfortunately there is no way for you to fix this.

Using VLC with the -vv option, this anomaly showed in the listing:

[0x7f000cc06788] main decoder debug: looking for decoder module: 32 candidates
[0x7f000cc06788] main decoder warning: cannot load module `/usr/lib64/vlc/plugins/codec/libavcodec_plugin.so' (/usr/lib64/libavcodec.so.54: symbol av_image_get_buffer_size, version LIBAVUTIL_51 not defined in file libavutil.so.51 with link time reference)
[0x7f000cc06788] main decoder error: corrupt module: /usr/lib64/vlc/plugins/codec/libavcodec_plugin.so
[0x7f000cc06788] main decoder debug: no decoder module matching "any" could be loaded
[0x7f000cc06788] main decoder debug: TIMER module_need() : 11.961 ms - Total 11.961 ms / 1 intvls (Avg 11.961 ms)
[0x7f000cc06788] main decoder error: no suitable decoder module for fourcc `h264'. VLC probably does not support this sound or video format.

Has anyone else seen this problem? Have a solution?

Are you using vlc from packman? If not remove the vlc and packages from the repository you have used and install the packman version.

Packman is one of the repositories in the Online Configuration. How do I tell in which repository VLC resides?

Okay. I removed all the VLC installations, disabled VideoLAN on the list of repositories, and re-installed all of those VLC modules.

No change. No video for h264.

I just installed vlc from packman. I was able to play a video that vlc reports as "h264 - mpeg-4 avc (part 10) (avc1). You might need libavcodec and etc from packman as well. I usually ‘switch to’ packman when I install from it.

I can find which repos a software is in using YaST(GTK version) as shown below.
http://i.imgur.com/WaJMRl.png](Imgur: The magic of the Internet)
or
using zypper

$zypper se -i -s gnome-mplayer
Loading repository data...
Reading installed packages...

S | Name          | Type    | Version   | Arch   | Repository        
--+---------------+---------+-----------+--------+-------------------
i | gnome-mplayer | package | 1.0.7-1.3 | x86_64 | Packman Repository


notes:- se = search;-i= installed versions;s=display more details

To resolve code related issue you may try these One-Click links
Codecs pack for KDE Codecs pack for GNOME DVD Codecs

Thank you.

Going to <http://opensuse-community.org/codecs-gnome.ymp> and upgrading the packages indicated has resolved the problem.

you are welcome

Thank U so much. This is the solution I have been looking for days and days…

Cheers,
Boyan.

You are welcome. Welcome to openSUSE .
You might also be interested in
https://forums.opensuse.org/blogs/jdmcdaniel3/mmcheck-version-2-45-check-your-multimedia-16-steps-bash-script-file-36/
https://forums.opensuse.org/content/127-multimedia-restricted-formats-installation-guide-12-2.html

An alternative is the install following package from packman to get h264 support:
vlc-codecs “This Package enhances the functionality of the VLC VideoLAN Client with Codecs that are not available in a stock openSUSE distribution.”

Cheers

Michael