VLC is unable to open the MRL

Hi ppl just switched to openesuse and kde enviroment few days ago, and now I’m snooping around etc.
Anyway I’m having this problem, I’m running a file server at home for my video, data, music and so on. I’ve used ubuntu untill now (server is also running ubuntu), and I’ve used vlc to watch the files directly from the server, I never had any problems with it until now (in ubuntu gnome). I navigated with nautilus to a location on the server double clicked and the video opend in my local vlc. Now I’m getting the tittle error, using opensuse 11.2 kde 4 and dolphin. Also I’m told to check the log…
While back I installed dolphin in my gnome on ubuntu, and i remember I got the same error when i tred to open the file on a server and tried to play it in vlc tru dolphin.
Is this a known issue?
Could this be related to dolphin/kde?
Where is the vlc log file in opensuse 11.2?
Where can I find some workarounds or something?

First make sure you have followed this:
Multi-media and Restricted Format Installation Guide - openSUSE Forums

Try opening the file by navigating to it from the File - Open, in vlc menu.

Box popus up saying: You can open only local files

How are you connecting to your server? Have you set that up (mostly that’s done server side) Eg: ssh?

Much more info is needed. How do the machines connect? What is being used in the *buntu - *buntu connection for file sharing? What did you do on openSUSE to configure the connection to the *buntu server?

This is where my problem with the *buntu family is: I’ve seen many *buntu network configs where people could not tell me what they used to share files etc. Strangely enough some were samba, some were NFS based, point is the users could not tell what they used.

I can setup a server and network in a couple of hours using openSUSE. Yast gives me everything needed to set it up, make it GUI controlable for local small admin jobs. The *buntus lack that => hello terminal, oops, better phone Knurpht :wink:

Ok I’m happay so many ppl willing to help :smiley:
First to point out: NO (system)changes have been made on the server since it was siwtched online, so I’m sure the problem is not on the server side, files can be accesed from two more computers woithout change.
The only change is on the current laptop running opensuse.
So…ssh connection to server is working fine I can acces the server tru terminal. Server is shared with samba and all shares are accesable from all the other computers. My guess is that the problem is in dolphin, to be honset Im not sure how to acces network with it. I tried like i did in ubuntu. Navigatet to network>samba shares>workgroup but i couldnt authenticate myself to acces workgroup(dont know how is that possible). So I added network folder with settings MS windows network drive with servers local ip and mount /. From there I can acces everthing on it with 2 setbacks one being the topic and other that I have to retype user and pass every time i restart my computer and try to acces the server.
What else do you neeed?

I don’t use Samba

I just type in the address bar of dolphin: Eg;

Once in I drag the xxxx folder to Dolphin’s Places

I don’t use samba to connect TO the server, i used it to share drives and places on the server. As I said i have no problem connceting and browsing the server only playing(streamnig) files from it with vlc.

I used your way, and everything works normal except vlc streaming

Please post ouput of:

zypper lr -d
rpm -qa | grep vlc

zypper lr -d
#  | Alias                                                                   | Name                                                                    | Enabled | Refresh | Priority | Type   | URI                                                                                       | Service                              
1  | KDE:KDE4:Community                                                      | KDE:KDE4:Community                                                      | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.2/             |                                      
2  | Packman Repository                                                      | Packman Repository                                                      | Yes     | Yes     |   99     | rpm-md | http://packman.mirrors.skynet.be/pub/packman/suse/11.2                                    |                                      
3  | X11:XGL                                                                 | X11:XGL                                                                 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/XGL/openSUSE_11.2/                         |                                      
4  | home:computersalat:KMP:Update                                           | home:computersalat:KMP:Update                                           | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/computersalat:/KMP:/Update/openSUSE_11.2/ |                                      
5  | http://download.opensuse.org/repositories/home:/Lazy_Kent/openSUSE_11.2 | http://download.opensuse.org/repositories/home:/Lazy_Kent/openSUSE_11.2 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Lazy_Kent/openSUSE_11.2                   |
6  | http://download.opensuse.org/repositories/home:/aljex/openSUSE_11.2     | http://download.opensuse.org/repositories/home:/aljex/openSUSE_11.2     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/aljex/openSUSE_11.2                       |
7  | http://packman.iu-bremen.de/suse/11.2                                   | http://packman.iu-bremen.de/suse/11.2                                   | Yes     | Yes     |   99     | rpm-md | http://packman.iu-bremen.de/suse/11.2                                                     |
8  | repo-debug                                                              | openSUSE-11.2-Debug                                                     | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.2/repo/oss/                            |
9  | repo-non-oss                                                            | openSUSE-11.2-Non-Oss                                                   | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/non-oss/                              |
10 | repo-oss                                                                | openSUSE-11.2-Oss                                                       | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/oss/                                  |
11 | repo-source                                                             | openSUSE-11.2-Source                                                    | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.2/repo/oss/                           |
12 | repo-update                                                             | openSUSE-11.2-Update                                                    | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.2


rpm -qa | grep vlc

I dont know if i will be of any help now, but i had a similar issue and fixed it by simply right clicking on a folder in dolphin, open properties, then click the share tab, click configure file sharing, i have simple sharing enabled, check to see if you samba folder shows up in the shared folders below, if not add it, then make sure both samba and nfs are both enabled, if not click on the change button and enable sharing with linuix and windows. Hope this helps if you still need it

This might help others with the same problem.

Sometimes it is almost too simple.

Have you checked your firewall settings?

Often that is the problem with the MRL error.

I did a short video about the problem here:
VLC is unable to open the mrl