VLC does not support the audio or video format "mp4v"

After I installed OpenSuse 12.2, my video playback stopped working.

I added additional repositories, vlc and packman. And installed vlc player as usual. I got this error message:

VLC does not support the audio or video format “mp4v”. Unfortunately there is no way for you to fix this.

So I looked around on forums, and I found that vlc sometimes clashes with the packman repositories. So I deleted everything from the vlc repos and changed it to packman. Same result.

Any ideas?

So if we can assume this is a mpeg-4 file, vlc should be able to view it. None the less, it does not sound like you followed our Multimedia Guide which you can find here:


Further, you can check your Multimedia Setup with this:

MMCHECK - Version 2.45 - Check Your Multimedia in 16 Steps - Bash Script File - Blogs - openSUSE Forums

Basically, mixing repositories causes you to use files with the same name but compiled against different binary files which often results in codecs that do not work. Packman is the one repository we recommended for Multimedia support and in general, it should not be mixed up with the VideoLan repository. Since I have never done this, its hard to say what it takes to fix it. And that assumes the problem is just not a defective video file. If I could, I surely would confirm the file or files in question can be used on another PC if you have no other success in setting up your PC Multimedia per our suggestions here. In the end, doing a reload may be required if you believe the video files are all good and did work before you created this mess. Its OK though, this is how one learns and its possible to reload openSUSE without blowing away your /home partition.

Thank You,

I made an identical mistake a long time back (SUSE10.2) I’m pretty sure the fix is the same.

  1. If you haven’t already remove the Videolan repos
  2. Open Yast remove VLC once more
  3. One more time change things over to the Packman repo(This will assure that you have the right formats)after that
  4. re-install VLC if all has gone well you’ll now have the Packman version
    Then try that .mpv4 if it fails again let us know if it succeeds please let us know.

Absolutely remove VideoLan repo
Then do this: https://dl.dropbox.com/u/10573557/Switcher%20Pics/11.4_packman_switch.png

Thanks for the reply. Yast crashed a few times when changing the repos from vlc to packman. So I decided to do a complete reinstall of 12.2. Fixed now by not installing the vlc repos!

Happy to hear you are fixed up then and perhaps a little wiser on repos. Its why we have such articles for you to read as a new user. Anyway, all is well that ends well.

Thank You,

Thanks, I’ve installed every version since 9.1 and never considered this issue.

As a long time openSUSE user, you might want to check out the many bash scripts I have written. You can get them all from this one blog if you wish.

openSUSE 12.2 Bash Script Download Bonanza! with Bash Script Loader - Blogs - openSUSE Forums

Thank You for using openSUSE,

Dragging up this old thread because I have some new info for others that may still be having this problem.

I followed all the right steps when installing 12.3 and adding multimedia, switching system to packman repos etc… and still no mpg playback after months of updates. I really do not need it very often but today I decide to fix it.

Solution, I searched for vlc in Yast2 software management and low and behold the vlc-codecs were not even installed by default. Obviously we need those to be installed for things to work, checked the package to be installed and now have all video working.

Well there have been several threads of late concerning the relatively recent separation of the vlc codecs from the main package into an additional vlc-codecs package. At the time of this thread, they would have been installed within vlc.

The separation is to protect openSUSE when it brings vlc into the next release of the distribution, so don’t expect vlc-codecs to be installed by default then either. :slight_smile:

vlc-codecs was added to the 12.3 multimedia guide on 11 March

Well, actually “vlc-codecs” contains “Supplements: vlc-noX”, so it should be installed automatically if “vlc-noX” is installed.

The problem lies with Packman.
They use a debian version of createrepo, which doesn’t support this, AFAIK.
There is a thread about this on the Packman mailinglist if you are interested:
[packman] Packman repo metadata is incomplete](http://lists.links2linux.de/pipermail/packman/2011-November/010441.html)
[packman] Packman repo metadata is incomplete](http://lists.links2linux.de/pipermail/packman/2012-April/010844.html)

If you add the VideoLAN repo to your system, “vlc-codecs” **does **get installed automatically.

Well, I hope this will get fixed on Packman sometime soon…

Well, actually Packman and Videolan repos are not part of the openSUSE default installation.

Of course. But “vlc-codecs” would be installed automatically by the update applet (or YaST/zypper) after you add the Packman or VideoLAN repo.

Of course. The separation is to protect openSUSE when it brings vlc into the next release of the distribution, so don’t expect vlc-codecs to be installed by default then either.

I know that openSUSE won’t offer vlc-codecs.

But if you add the VideoLAN repo “vlc-codecs” will automatically get installed if you install “vlc”. It will automatically get installed when you run “zypper inr”. It will be installed automatically when you install any other software with YaST/zypper.
It already works this way. I just tried.

It would also work this way with the Packman repo if they would fix their repo metadata…

Yes, this was the expected behavior but apparently some problem is present according to your other post. As stated in my first post I had followed all the “multimedia one click” as documented and suggested on these forums. This still did not get the job done and the problem is corrected by installing the vlc-codecs.
This machine has been using apper almost exclusively and an occasional zypper up just to check that everything was working and the codecs never got installed.

Oh good, that’s not the impression I got with all the ifs and buts that followed. It’s not worth complicating what is an old somewhat out of date thread, especially when the multimedia guides are now updated. To avoid users getting in a mess with both videolan and packman repos enabled, the advice there has been to stick with Packman. :slight_smile:

What ifs and buts are you talking about?
And I don’t argue against that advise. I was just saying that if Packman would fix their repo, nobody would need to install “vlc-codecs” manually, just adding Packman would be enough.

But the guide would still be necessary of course because of gstreamer.:wink: