VLC crashing when playing mp4

I have LEAP 15.1 installed with no error, but when i opened VLC it does not reproduce mp4 videos, it crashes and closes.
I did install vlc-codecs and update VLC from VLC repositories. Same problem, VLC closes and cannot play mp4.

Any help on this?

My PC:
CPU: AMD Ryzen 5 3700X
Video: Radeon 580
Drive: SAMSUNG m.2 EVO 970
OS: opensuse Leap 15.1

Hello aqnd welcome to these forums.

You seem to be new here, so you may have missed a few things. No problem. We wil try to help you, but we like to know you starting point better.

  • Did you notice we have a Multimedia sub-forum?
  • Did you see the sticky threads there with titles like: Multimedia Guide for openSUSE Leap 15.1?
  • Did you do what is advised there (mainly add the Packman repo and switch packages to it)?

When you didn’t please do so first and then come back when you still have problems.
When you, did, then please say so explicitly, so others know what your starting point with respect to multimedia is.

(And yes, this, being a multimedia question, would have better been in that sub-forums, do you want me to move it there?)

If you still have a problem after adding the Packman repo and updating your system as @hcvv describes,
You should try to open your media file using the command line (typically by executing the application binary followed by the name of your media file as one command).
If the file refuses to open, you should see some kind of error message.
You can then troubleshoot on your own or if you are unable to interpret the error, post the error exactly as you see it here and someone will point you in the right direction.


I tried the sticky on Multimedia and does not work.
I opened some videos using CLI and looked for solutions on www , but no change. Suggestions were that VLC settings used OpenGL. Tried that same error.
I therefore copy the CLI response , it is in spanish sorry:

VLC media player Vetinari (revision
No protocol specified
No protocol specified
[000055fc69121180] main libvlc: Ejecutar vlc con la interfaz predeterminada. Use «cvlc» para usar vlc sin interfaz.
No protocol specified
No protocol specified
No protocol specified
No protocol specified
No protocol specified
libva info: VA-API version 1.3.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/radeonsi_drv_video.so
libva info: Found init function __vaDriverInit_1_3
mesa: for the   --simplifycfg-sink-common option: may only occur zero or one times!
mesa: for the   --global-isel-abort option: may only occur zero or one times!
libva info: va_openDriver() returns 0
[00007f8648001f60] glconv_vaapi_x11 gl error: vaDeriveImage: operation failed
[00007f864c08e390] main video output error: video output creation failed
[00007f866cd42f70] main decoder error: failed to create video output
No protocol specified
No protocol specified
ac: Unknown GPU, using 0 for raster_config
Violación de segmento (`core' generado)

This question is about Multimedia, not Applications.

What drivers are you using - Mesa 3D or AMDGPU-PRO?


For Mesa 3D install packages to support GPU accelerated video decoding - search for “libva”, “vaapi”, “va-api”, “vdpau”.
Maybe you will need to update Mesa 3D to the current build.

Or disable hardware acceleration.