VLC and TS files/format

Hi guys,

just downloaded, I guess for the first time a .ts file which I am unable to play via latest 1.1.8 VLC player, which I read is supposed to handle it. First of all the .ts was not recognised (openSUSE 11.4 KDE 4.6.1 x86_64 all) as any associated file with program, so I used open with -> VLC. It opens the file and sticks to 1st frame and nothing happens.

Below is the info on media (5.6GB):


Format: TS
Video Codec: H.264
Video: H.264-AVC, 9455 Kbps (average), 16:9, 1920x1080, 25 fps
Audio: MP2, 128 Kbps, 48.0 KHz, 2 channels, Russian

BTW, tried on my notebook Ubuntu 10.10 x86_64 with VLC 1.1.7 and am getting the same result.

Installed mplayer (smplayer) and it played nicely, had to turn on deinterlancing as the media is 1080i codded.

Then tried playing another smaller 53MB TS file and it plays OK:


So, what is the problem? If needed I can try the same file on VLC under Windows.

FYI: I have posted this on VLC forum as well, but perhaps someone here knows. If I will get something from VLC forum, will post here, hopefully the solution.

I can not undesrstand your problem. You want the ts codec for your openSUSE. Right?

Maybe you look for that http://surfpack.com/codecs/opensuse/
You can also use kaffeine for that.

The VLC forum is likely the best place to post to get an answer. You could also try asking on doom9: Linux, Mac OS X, & Co - Doom9’s Forum

opensuse-community codec packs are all installed. As I said above, I was able to play it via mplayer (smplayer gui), so all good, but VLC is not playing it. As per Kaffeine, it plays only audio track, not even the first frame of video.

BTW, here is a discussion link on VLC:
The VideoLAN Forums • View topic - VLC and TS files/format

Lets see, but if you have comments, do post here so I can answer them as they arise.