vista drive

suse 11 is not showing my vista drive when i go to my computer it shows my external ntfs drives but not vista, why?

What do you mean by ‘not showing’? SUSE should detect your drives anyway but, if you have not mounted your Vista drive, it won’t show you its contents.

Or is that not the problem?

suse has detected my drive? when i run kwik disk it shows the drive when i click it in kwik disk i get this

“umount: only root can unmount /dev/disk/by-id/scsi-SATA_Hitachi_HTS5425080417BB3F00WDDD1VZG-part2 from /”

but the drive does not show up in my computer


PLease post back here the output you get in a console when you issue this command:

sudo /sbin/fdisk -l

and also this command:

sudo mount

EDIT: Oh and I forgot, where is the vista partition? Is it the first partition on the first internal drive?

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x19c719c6

Device Boot Start End Blocks Id System
/dev/sda1 * 1 15665 125829081 7 HPFS/NTFS
/dev/sda2 15666 28900 106309632 83 Linux
/dev/sda3 28901 30401 12056782+ 7 HPFS/NTFS
Note: sector size is 4096 (not 512)

Disk /dev/sdc: 3892 MB, 3892056064 bytes
38 heads, 42 sectors/track, 595 cylinders
Units = cylinders of 1596 * 4096 = 6537216 bytes
Disk identifier: 0x20202020

Device Boot Start End Blocks Id System
/dev/sdc1 1 596 3800580 b W95 FAT32

thats what i get when i run “sudo /sbin/fdisk -l”

the vista partition is on the same hard drive as suse on my laptop


and when you run the other command?

sudo mount gives me this

/dev/sda2 on / type ext3 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
securityfs on /sys/kernel/security type securityfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)


OK you’ve got two NTFS drives, one at sda1 (the beginning of the drive) and one at sda3 (the end of the drive). You have a Suse installation on the second position, sda2, in the mid of the drive. That’s pretty nifty footwork. It would be hard to locate partitions like that. You have managed to install Suse without a swap partition (same as windows’ virtual memory) which is also pretty nifty footwork.

You can’t see a drive unless it’s mounted. When it’s mounted the files appear in the directory where you mounted it.

So if you want to make sda1 visible, mount it like this:
Create a directory /windows then a directory in /windows called C. You will have a directory /windows/C. Then open for editing the file system table called fstab (it’s a text file at /etc/fstab). Open it with this console command if you are using KDE:

kdesu kwrite /etc/fstab

or for Gnome use this:

gnomesu gedit /etc/fstab

At the bottom, insert this text:

/dev/sda1 /windows/C ntfs-3g defaults 0 0

Make sure hte last line in the file is a blank line. Save and exit. Then execute this command in a console:

sudo mount -a

Now the contents of the partition sda1 should appear in directory /windows/C (and perhaps in My Computer after the next boot, I can’t remember).

If you want to make sda3 visible, do that all again (or concurrently) but make a directory for sda3 at /windows/D and ue similar codes but change the nomenclature like this: use sda3 instead of sda1 and use /windows/D instead of /windows/C in the codes I gave you.