Vista and Hibernation

I have installed 11.0 on my wife’s laptop which had vista installed first.
Installation went ok. Vista’s partition was resized and 11.0 was installed. I told grub to boot from mbr in the installation.

My problem is eventhough I can boot both os’s I cannot hibernate either. I read several posts here and some things on the net but can’t figure out a working solution. So… help :slight_smile:

Here’s my list of the partition setup as I remember it (in vista now):
sda1 vista primary partition
sda2 OpenSUSE Extended partition
sda4 swap
sda5 /
sda6 /home

Thanks for the help in advance.

This is a feature not a bug!

The reason hibernation is disabled is because the OSes can’t guarantee control of boot process, they fear you would hibernate Vista, boot up Linux and then go and restart Vista and it’d hopefully crash but perhaps corrupt it’s filesystems. Or vice-versa.

Vista can see that it’s boot manager has been overwritten.

If you want it to work there are work rounds of sorts.

Install GRUB into /boot directories partition and use generic boot code.
Use the ‘makeactive’ option on Vista’s entry in GRUB menu.lst.
When Vista is not hibernated, you can set the /boot dir’s partition active and boot via GRUB, using an fdisk.

I’m not sure if this is covered in the Vista Multi-boot sticky, I contributed extra info on 2 disk setup, and there’s been discussion in December on this topic.

Thanks for the reply. I had a look at the tread you mentioned but couldn’t find anything that worked. It was mentions about the makeactive option so I tried that. This worked.

So install, tell grub to boot from mbr, after installation go to Yast - System - Boot loader, select ‘Other’, Edit Configuration file, select to edit /boot/grub/menu.lst, find the vista entry and add ‘makeactive’ (I put mine between the two lines already there), click ok twice, reboot.

This is what I did and it worked for me :slight_smile:

now to get my wife to actually use it! rotfl!