hi, i installed virtualbox and it works as root but not my user. says permissions denied.

i added my user to the group vboxusers but it still is a no go.

works fine as root

i followed the guide here

Tutorial : VirtualBox on openSUSE 11.1 Part 1 | Spirit of Change

any ideas?

Check here
VirtualBox Installation - openSUSE

If using OSE you might want to add this repo and update
Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.1

You should not be runnin as root!

Try rebooting.

Did you reboot your system after adding user to vboxusers group?

Logging out and back in again is sufficient.

Remove /tmp/.vbox-*-ipc/ and retry running it as your ordinary

Take a look to another article : Solved : VirtualBox Permission Problem with Normal User | Spirit of Change

awesome, it worked out great. thanks for your help.

oh one more thing:

i have lots of virtualbox virtual machines on my hard drive from a previous installation.

any way i can import those into my current virtual box installation?

In your home directory you have a hidden directory .VirtualBox,
all your machines are contained in there. Take a look at that
directory and I’m sure you’ll understand how to manage that.
I’m old and lazy and have only one virtual machine so I always
keep a couple of copys of that directory on an external hard
drive, different instances. That way I can restore them on a
new installation, and also roll back to a previos instance should
something nasty happen to my XP-machine. Back up the XP-machine
you already have and feel free to experiment.

Select create New machine and then point it to the VDI file of the machine from your old files. Ideally you want to have already put the old VDI files in your current VDI location. Which as has been mentioned is by default it your hidden folders under your username.