Virtualbox: Videos (youtube) run only in slow motion

Hi there,

I have got the problem, that videos in my Windows 7 64bit guest run only in slow motion - sound accordingly.

My Virtualbox guest params are:

Chipset: ICh9

Windows 7-64 pro
Base memory 7044 MB
Processors: 3
Execution Cap: 90%
Acceleration: VT-x/AMD-V, Nested Paging, PAE/NX

Video Memory: 256 MB
Screens : 2
Acceleration: 2D Video, 3D
Video Capture: disabled

Ram: 16 GB
OS Disk: 250 GB SSD
Data Disk fast: 500 GB
Data Disk slow: 1.0 TB
Processor: AMD FX 6300-six core @3500

Any ideas what could be the problem ?

TIA, Joe

3D acceleration is still experimental and doesn’t really work with some setups: switch it off.
I don’t know about 2D video accel, but maybe it’s not working either; anyway you appear to have enough OOMPH to play videos even without HW acceleration.
Having 2 displays enabled might also play a role.

Start with a basic setup (1 display, no accel) and then add options one at a time…

Agree with Bruno about approach,

But I’ve seen some less-than-excited performance ICH9 systems, in general AMD processors perform less capably than Intel counterparts released at same time, and you didn’t mention what GPU you’re running which might suggest you’re running integrated graphics with shared resources.

Experiment with settings (I agree with start with all options turned off, and add one at a time).


I’ve experienced 3D acceleration issues in VirtualBox, to be sure. I’ve come to understand that KDE5’s utilization of OpenGL is far more extensive and advanced than in previous iterations (IIRC QtQuick is the primary driver, and the OpenGL 1.3 backend in KWin is gone). It is safe to say that KDE5 overwhelms the VirtualBox GL extension.

In instances like this I like to point out that “paid” VMs are generally more refined in total. I use VMware Workstation 12 and can tell you with certainty that it does not quarrel with 3D acceleration in the context of KDE5. My speculation is that VMware WS12 has a more robust GL extension than VB. You might want to give WS12 a try.

Oh yes, stupid me, have forgotten the hosts graphics system:

ATI Radeon HD 6800 1GB

Will try to disable the 3D feature and then, as next step, the 2 screens.
Thanks for these suggestions. Will report whether those changes have an impact.

Thanks, Joe

Ok tried both options:

Switched 3D accel. off and … did not change.
Switched 3D accel. on again and switched to 1 screen onyl … no change
Switched both off …
Even switched off the Video accel and … the video & sound was as slow as before.

Looks like the Video accel. does not work. But it did before, I remeber that Iwas able to watch youtube videos some month ago. I usually use the browser in the host system, but sometimes I use it also in a guest system.

As I also have a n OS13.1 guest (Pulse Audio driver) , I tried playing youtube videos in this guest as well and it’s working. No problem at all !

So it must be related to the Win 7 64 guest (Alsa driver !?).

Thus I changed for Win from Pulse Audio to Alsa driver … but still no change.

Any ideas ?


What video driver??

Direct Rendering
3D Accelarator Unknown
Vendor ATI Technologies Inc.
Renderer AMD Radeon HD 6800 Series
OpenGl/ES 4.5.13416 Compatibility Profile Context 13.251
Kernel Modul Unknown
X Server information
Name of Display :0
Vendor String The x.Org Foundation
Vendor Release No 11,403,901
Version No 11.0

Got this information out of KInfocentre and there is much much more, but unfortunately the Export Button is greyed out and copy / Paste is also not working … strange.
Thus I hope this info is enough. If not feel free to ask.


Did you install the proprietary AMD driver?

Hi, frankly said, I installed the system ~2 years ago and I do not remember whether I used the original AMD driver or not. If it would be Windows I would know where I could find this information in teh OS, but in OpenSuse /Linux I have no idea where I could retrieve this information.
Looking at the list of repos used I found AMD/ATI-FGLRX, thus I assume that I do use the AMD drivers. But as said I am not sure …

TIA for any hints, Joe

Yast-Softwae Management -search for fglrx see if it is installed. Just because you have the repository does not mean the package is installed

Did you install the guest additions in Virtualbox. that contain better drivers for the VM

Hi there,

| fglrx64_amdcccle_SUSE131 - fglrx amdcccle package


| fglrx64_core_SUSE131 - fglrx core package


| fglrx64_graphics_SUSE131 - fglrx graphics package


| fglrx64_opencl_SUSE131 - fglrx opencl package


fglrx64_xpic_SUSE131 - X Window display driver for the AMD graphics accelerators

are installed and in the VirtualBox the GuestAdditions are also installed.

Yast also showed the 32bit fglrx drivers, which are, of course, not installed.

TIA, Joe


any ideas ,suggestions ?

Would it make sense to file a bug report ?


I would also like to mention that there exists a free version of VMware WS, the VMware Player. It allows you to create virtual machines and manage them. I’m not sure if its inferior to the VMware WS performance-wise, but from my personal experience it offers superior emulation than VirtualBox.

Thanks for your reply.

The point is that I could play videos and music with earlier versions of the virtual box around a year ago. As I usually use the players in OpenSuse I was not immediately aware that it was no longer working.

So very likely they must have “disimproved” in the last year the virtual box software.
I hope this is not a way to soon introduce a “special super-duper” plug-in “which offers more functionality” but which we have to pay Oracle for …


I don’t think that anything necessarily been “disimproved” but there have been a lot of changes in the past months and year and support for some hardware may have changed.

Are you running VBox 4.3 or 5.0? Maybe changing to the other (typically they can can be installed side by side although I haven’t tried that on openSUSE).



I am using now Version 5.0.10_SUSE r104061

and I have “good” news: New VB updates and no more slow videos … now each time I try to open a video in the browser a fatal blue screen of death of the windows client appears on the screen.:frowning:

The VB has been disimproved definitely in this point and I could even now see that the entire client UI interface reacts much slower than ever, I start to think that I should roll-back to a former version of the Virtual box.


Recommend you post on the Virtualbox forums where you’ll get plenty of attention. Although VBox has these issues from time to time, the VBox Dev community seems earnest in addressing these issues ASAP.