Virtualbox problems

Hey All,

Im trying to install Virtualbox so that i can then go onto install ETKA (Volkswagen Parts catologue) i know it doesnt work with WINE as it uses a hardlock drive but been told Virtualbox will work

So i went to the Virtualbox website and downloaded the latest OpenSUSE 11.2 .rpm and installed it and then i have added myself to the vboxusers group

So i open virtualbox and start creating a new WindowsXP Session and i press start and i get:

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. Users of Ubuntu, Fedora or Mandriva should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

Anybody got any ideas how to fix this? ive tried doing Sudo /etc/init.d/vboxdrv setup

but it didnt work


What is the output of:
sudo /etc/init.d/vboxdrv setup
sudo /etc/init.d/vboxdrv restart

I had a problem with the Suse RPMs from the BuildService because they
installed the host AND guest kernel module and they conflict with each

sudo /etc/init.d/vboxdrv setup

Stopping VirtualBox kernel module                                                                                                 done
Recompiling VirtualBox kernel module                                                                                              failed
  (Look at /var/log/vbox-install.log to find out what went wrong)

The Log contains:

Makefile:159: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.  Stop.

sudo /etc/init.d/vboxdrv restart

topping VirtualBox kernel module                                                                                                 done
Starting VirtualBox kernel module                                                                                                 failed
  (modprobe vboxdrv failed. Please use 'dmesg' to find out why)

dmesg gives probably about 200 lines of text

On Mon, 19 Jul 2010 20:16:02 +0000, AndrewjBarratt wrote:

> Error: unable to find the sources of your current Linux kernel.

You need to install the kernel sources - kernel-sources should provide it.


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at

Hi I am using OpenSUSE 11.4, KDE 4.6. kernel version (pae)

I download the kernel source and run the command
sudo /etc/init.d/vboxdrv setup
and it runs fine but then I can’t run oracle VirtualBox command on konsole. Now I receive the message
Failed to open the X11 display!

Any idea to solve this.

What do you mean by “on konsole” ? You can not start virtualbox (actually a symlink to VBox) outside of X and you can not start it inside X if you don’t have access to the X display (owned by another user). Though you can run vboxmanage in console to perform other tasks - but not start a virtual machine on the local host, because it needs an X display to run.

Ok, may be I don’t tell the complete story, after run
/etc/init.d/vboxdrv setup
I try to launch Virtual box in the kde kicker, but I wait and nothing happen then I think, let’s try in konsole to see what is the output of the program. then I receive
Failed to open the X11 display!

I would say that the owner of the terminal (konsole) is not te owner of the display. You probably started a root konsole. Make sure you start a ‘normal’ konsole, then type:


ans see what kind of error message you get.

You can also type the following in the konsole:


It should not answer ‘root’.

And check if you are member of the vboxusers group with the command:


You should see ‘vboxusers’ in the list.

I’m still having trouble getting /etc/init.d/vboxdrv setup to run. I still get the same error even after reinstalling required kernel-headers. I am running OpenSUSE 12.1 as host and Windows 7 as guest OS. Here’s what is in my /var/log/vbox-install.log file:

cat /var/log/vbox-install.log
    Uninstalling modules from DKMS
      removing old DKMS module vboxhost version  4.1.8

    Deleting module version: 4.1.8
    completely from the DKMS tree.
    Attempting to install using DKMS

    Creating symlink /var/lib/dkms/vboxhost/4.1.8/source -&gt;

    DKMS: add Completed.
    You can use the --kernelsourcedir option to tell DKMS where it's located.
    Failed to install using DKMS, attempting to install without                                                                                                                         
    Makefile:175: Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=&lt;directory&gt; and run Make again.                 
    make KBUILD_VERBOSE=1 SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 CONFIG_MODULE_SIG= -C /usr/src/linux modules                                                                         
    test -e include/generated/autoconf.h -a -e include/config/auto.conf || (                \                                                                                           
    echo;                                                           \                                                                                                                   
    echo "  ERROR: Kernel configuration is invalid.";               \                                                                                                                   
    echo "         include/generated/autoconf.h or include/config/auto.conf are missing.";\                                                                                             
    echo "         Run 'make oldconfig && make prepare' on kernel src to fix it.";  \                                                                                                   
    echo;                                                           \                                                                                                                   

      ERROR: Kernel configuration is invalid.
             include/generated/autoconf.h or include/config/auto.conf are missing.
             Run 'make oldconfig && make prepare' on kernel src to fix it.

    mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*

      WARNING: Symbol version dump /usr/src/linux-3.2.1-3/Module.symvers
               is missing; modules will have no dependencies and modversions.

    make -f scripts/ obj=/tmp/vbox.0
    /tmp/vbox.0/Makefile:175: Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=&lt;directory&gt; and run Make again.
      gcc -Wp,-MD,/tmp/vbox.0/linux/.SUPDrv-linux.o.d  -nostdinc -isystem /usr/lib/gcc/i586-suse-linux/4.6/include -I/usr/src/linux-3.2.1-3/arch/x86/include -Iarch/x86/include/generated -Iinclude  -include /usr/src/linux-3.2.1-3/include/linux/kconfig.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -fno-delete-null-pointer-checks -O2 -m64 -mno-red-zone -mcmodel=kernel -maccumulate-outgoing-args -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -fomit-frame-pointer -DCC_HAVE_ASM_GOTO -include /tmp/vbox.0/include/VBox/SUPDrvMangling.h -I/usr/src/linux/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxdrv/ -I/tmp/vbox.0/vboxdrv/include -I/tmp/vbox.0/vboxdrv/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DRT_WITH_VBOX -DVBOX_WITH_HARDENING -DCONFIG_VBOXDRV_AS_MISC -DRT_ARCH_X86 -DVBOX_WITH_64_BITS_GUESTS  -DMODULE  -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(SUPDrv_linux)"  -D"KBUILD_MODNAME=KBUILD_STR(vboxdrv)" -c -o /tmp/vbox.0/linux/SUPDrv-linux.o /tmp/vbox.0/linux/SUPDrv-linux.c
    /tmp/vbox.0/linux/SUPDrv-linux.c:1:0: error: code model ‘kernel’ not supported in the 32 bit mode
    /tmp/vbox.0/linux/SUPDrv-linux.c:1:0: sorry, unimplemented: 64-bit mode not compiled in
    make[2]: *** [/tmp/vbox.0/linux/SUPDrv-linux.o] Error 1
    make[1]: *** [_module_/tmp/vbox.0] Error 2
    make: *** [vboxdrv] Error 2

Here is output from rpm -qa | grep kernel


Please help.

Figured out the problem after posting this. Downgraded my kernel version to 3.1.9. I’m off to find a cold drink now.