Virtualbox on TW unable to enumerate USB devices

Today I installed Virtualbox from zypper to try a Windows 10 machine.
Everything went normal in zypper with no errors. On the first start of Vbox I had to add my user to the group “vboxusers”, rebooted, and then I could start it with no issues, except that I cannot load USB drives… the error message says that I have to be in the vboxusers to list USB devices, which it does make sense to me.

Screenshot_20240331_152616

My current group membership:

vzz1x2@baikonur:~> groups
vzz1x2 vboxsf vboxguest vboxusers

So… What is going on? where

~/.config/VirtualBox/VBoxSVC.log has the following error:

00:00:01.457512 nspr-3 WARNING [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={e54f6256-97a7-4947-8a78-10c013ddf4b8} aComponent={HostWrap} aText={VirtualBox is not currently allowed to access USB devices. You can change this by adding your user to the ‘vboxusers’ group. Please see the user manual for a more detailed explanation}, preserve=true aResultDetail=0

I was looking also at other threads like:

But Im in the latest snapshot so that issue shouldnt exist anymore for me.

Any ideas or suggestions on where I can troubleshoot would be highly appreciated!

Thanks in advance!

This bugreport here:
https://bugzilla.suse.com/show_bug.cgi?id=1222186

Thanks so much. I concentrated too much on the other one and I didnt see this one.
Lets wait then.

This is a known kernel 6.8 related issue and is in Leap 15.6 and Slowroll and other Linux like Mint Linux and any kernel that has the CVE’s that 6.8 fixed, retrofitted to it like 15.6 has.
Apparently some CVE fix broke how Oracle fetches the USB info and is no longer able to access it. It probably is a new field required in the call that changed. Pieces of code in the kernel is above my pay grade and I have to wait for someone to figure out what changed and how to make it work again.

The latest Virtualbox rollout did fix the date and time shown in Shared Folders in Tumbleweed and we have fixed the Virtualbox hang in 15.6 but it has not made it thru QA yet. I tested it 4 days ago and have my 15.6 Host running Virtualbox Guests successfully.

Right now only Leap 15.5 has the USB working correctly.

Thanks Larry. I tried to search for a related bug in virtualbox.org but I couldn’t find anything that would tell me that Oracle is working on it. Do you have one?

I’m on openSUSE Tumbleweed 20240329 with virtualbox 7.0.14-6.1 and the problem with the date and time shown in Shared Folders still exists on my system ?!

I was looking at my test on Leap not Tumbleweed - It is not fixed yet. I have too many VirtualBox machines and guest combo.
Sorry about that.

If you install the remove the Opensuse VirtualBox guest additions and install the Oracle VirtualBox Guest additions from the Devices > Insert Guest Additions menu, the date and time will show correctly after you reboot. You do need kernel-source and gcc in your Tumbleweed guest to install it. You also have to turn off secure boot for the Oracle code to work in reboot or sign it yourself and add that signature to your UEFI BIOS signature (a rather long process).
Something in our code to make VirtualBox work in OBS (how OpenSUSE signs and updates its repos with new code) is causing the error. Will be looking to see what got glitched. We have to fix it to build for Leap 15.5, 15.6, and Tumbleweed (Slowroll gets Tumbleweed so we don’t test build for Slowroll). I think we need to delete all the fixes for 15.3 and 15.4 that are in our OBS build code and see what happens.

Following the changes described in:

https://bugzilla.suse.com/show_bug.cgi?id=1222186#c3

I can list and assign USB devices to my machines again. The thing is that as the comment suggest, permissions are wrong again after reboot so I had to run a :

/usr/lib/virtualbox/vboxdrv.sh restart

and everything went good again.

I did finally figure out that the minor numbers in the mknod for VirtualBox USB were wrong

If you follow the above bugzilla - you can get my code that works.

The fix in Comment 14 (https://bugzilla.suse.com/show_bug.cgi?id=1222186#c14), without any other modifications, worked for me.

@larryr I also tried you fix but it didn’t work for me.

I had to take the extra steps described in comments 23 and 24:

https://bugzilla.suse.com/show_bug.cgi?id=1222186#c23

but now have two functional scanners under the Windows 7 VM in VirtualBox.

No, this did not work for me (see this post).

BTW:
I think it is not a good idea and not very helpful too to spread a topic across two threads. Especially not when the second thread (i.e. this one) does actually deal with a completely different topic.

I would prefer if we could handle the date/time-problem separately in the original thread or in the bug report I created.

The fix for the USB is in today’s Tumbleweed release - a reboot is suggested to purge the old VirtualBox from memory.

1 Like