virtualbox issue?

I had installed the Virtualbox when i finished installing the opensuse11.0.At the first,the Virtualbox can work.Once i install the driver of the graphics card that need to upgrade the kernel,the Virtualbox didn’t work,and show:

VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Re-setup the kernel module by executing ‘/etc/init.d/vboxdrv setup’ as root.
VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).

Result Code:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}

I had tried to removed the Virtualbox and re-installed it.When I had done this,the system can’t start the X Windows.
What can I do?Thanks~~

by the way,I had tried to Re-setup the kernel module by executing ‘/etc/init.d/vboxdrv setup’ as root,and the terminal show that:
Stopping VirtualBox kernel module done
Recompiling VirtualBox kernel module, NOT. It has been packaged. done
Starting VirtualBox kernel module failed
(Kernel module not found)

read here
VirtualBox Installation - openSUSE

use this repo too - unless you are using the download direct from Sun
Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.0

What’s the SUN?I am new for the opensuse11.0.Tell me more,thanks

It is free for private use, has usb support, though I never need that, I just use the shared folders in the open source ver

but here is a link :

thanks,the virtualbox works!but i have to type /etc/init.d/vboxdrv setup first when start the virtualbox.what can i do?

YaST -> System > System Services (runlevel)-> vboxdrv and select the enable button and finish.