VirtualBox interface scaling


I have a problem with virtualbox, when I open it the interface itself is huge ]( This problem appeared today, it was working fine for me yesterday. I have tried to reinstall it but no luck. I did update the packages today this feels quite odd. All the icons and menus are scaled up, when I run a vm then that’s also scaled up and many things are pixelated. At the same time the menus are not very responsive. The image is from a full hd screen.

VirtualBox version:

Oracle VM VirtualBox Manager 5.1.10_SUSE
Graphical User Interface Version 5.1.10_SUSE r112026 

> uname -a
Linux host 4.8.12-1-default #1 SMP PREEMPT Fri Dec 2 09:44:55 UTC 2016 (f8adb5a) x86_64 x86_64 x86_64 GNU/Linux

I would appreciate any help.

Based on the image you posted, are you saying that the Virtualbox app is being displayed full screen?

If so,
That’s not a Virtualbox problem, it’s a windowing configuration.
Some tries…
Depending on the Desktop you’re running there should be the usual Minimize-Intermediate-Fullscreen icons to the left or right corners of the window “chrome” (That’s the bar running across the top of the window).
If you’re missing those icons or can’t see them, then try rt-clicking on the chrome and selecting an option that might be helpful to re-size.

I’d also suspect that your screen resolution has something to do with your problems.
If you are working logged in locally to the machine, then reset your screen resolution to defaults if you changed it before.
If you are logging in remotely, to view your Desktop, then try another screen resolution. How this would be done would depend on the remote Desktop app.

In general, updating your system can solve misc problems as well, on your HostOS, run in an elevated console

zypper up


My problem isn’t that the program runs in full screen, but that all the elements in the interface are scaled up. I add another picture here. The scale displayed here is 100% and the size of the virtual monitor set to 640x480 but it’s over 1200x900. You can also notice that the menu items have bigger padding and they are more spacious. Also the elements in the window shown in the picture are much bigger than they should be.

What I’m saying is that the virtual box interface itself runs on scale for some reason. I have no problem resizing or moving the window around.

I’m logged in locally to my computer. This happens both from root and user accounts.

There are no new packages to install with “up”.

IIRC the last patch added to VB enabled support for HiDPI screen. Looks like this patch may have issues. You need to report it in bugzilla.

Thanks for the info, I installed the previous version of virtualbox-qt and now it’s working correctly.

I will submit it in bugzilla.