Virtualbox floppy disk problem

Right now, I have openSuse 11.1 installed and working well enough to use happily, however, there is one nagging problem I don’t know how to tackle.

I’m in OS X 10.6.1 running VirtualBox 3.0.8 and the previously mentioned version of openSuse.

When it boots up and I login, there’s a floppy disk showing on the desktop. I’ve tried to mount and unmount it, but no dice, the only error I get is a window which contains no text, the picture of a red circle…error thing, and a button that says “close” next to an X.

What’s really strange is that VirtualBox doesn’t have any floppy disk images mounted, so whatever linux is doing, it might be doing on its own.

What’s even more strange is that I tried installing xubuntu the other day, and it did the same thing…the same way under the same circumstances, but xubuntu let me see the floppy disk’s properties, where it reported that the floppy disk had about 15GB free. I sense something is slightly off.

where should I look to make this insane phantom floppy disk go away?


also, I don’t see how it’d effect disk mounting, but my window manager in both cases was Xfce 4 - if that explains anything useful

Have you searched these forums for similar problem: Virtualbox; and OS X?

Yep, i’ve googled around on other forums too and some other things contain the same words, but not quite what i’m looking for.

No takers?

My apologies, I neglected to say welcome to the forum. Not an easy problem to start with on your first post. :slight_smile:

I briefly tried google, it picked up some floppy problems including yours above, but nothing obvious with your symptoms on the first page. You may have better luck. :slight_smile:

PS: Hadn’t seen your reply. Will keep trying but don’t have solution.

I recall there’s some place in linux/unix where mounted devices are…noted.

it’s something like /etc or /dev, but I forget which

I figured in there, I’d see the phantom floppy and I could “sudo rm” at it until it went away

but that seems like too simple of a plan to work

also, thanks for the welcome

Check /mnt and /media to see if anything there. Also look in /etc/fstab where permanent mounts are specified.

/mnt and /media were completely empty

I checked fstab, here’s what I found:

That looks ok, and very similar to mine. Same on the blank dirs.

What desktop on 11.1 vm are you running, KDE or Gnome?

Any other devices plugged in that may be incorrectly picked up by the vm?

Oops, I didn’t look carefully at the pic but now I just saw the icewm, and I missed the Xfce at the end of your original post. Sorry, but that maybe why little response so far. :\

Yeah, I’m pretty confused, I think VirtualBox might just be insane; when I installed xubuntu for the first time, VirtualBox was CONVINCED I had two cd-rom drives. Did I have two virtual drives mounted? nope. Did I even let VirtualBox know that I had ANY disk images anywhere on my system? nope.

Then I deleted that VM, reinstalled with the same config, and I got one cd-rom that was rightfully disconnected and one phantom floppy drive. That’s…similar to progress I guess.

Barking my way…ALL the way up the crazy-tree here…I wonder if it’s possible that when you install VirtualBox’s package in linux…maybe something about that process causes the floppy to appear? A broken, very broken and sad script?

is there a way to uninstall and reinstall it?

another observation :

openSuse can’t mount anything Virtualbox passes to it

not the guest OS additions, not anything else.

I had to get the guest additions through YaST2 via the internet.

Perhaps the problem is a dirty VM config file?

You are running VBox under OS X and openSUSE as a vm, are you not? If so, I don’t understand your comment about linux. Uninstall and reinstall what?

uninstall and reinstall the VirtualBox guest OS software package, like how VMware uses “VMware Tools” to help the guest OS work inside the host OS.

however, I’ve now found that the problem is not VirtualBox specific.

I tried installing openSuse 11.1, same software, same config, only it was through VMware Fusion and the only difference was that VMware was mind-numbingly slow incomparison to VirtualBox, but in the end, the Xfce desktop still couldn’t mount or unmount volumes, and it still had the phantom floppy disk problem.

that seems to narrow it down to a problem with Xfce, which doesn’t make a lot of sense, why would the good people at openSuse package a desktop/window manager that didn’t work with their software?

I’ll be trying to install openSuse 11.1 through both VirtualBox and VMware Fusion tonight with Gnome/KDE desktops to see if the mounting problem persists to those as well.

maybe there’s just some insane way to mount volumes in Xfce that is done by pressing something other than the big “Mount” button when you right click on a device

I’d think…given that when you right click on a device in Xfce, the options it gives you are pretty much “Properties, Mount, and UnMount” that those would do the trick, but so far, no luck with any of those.

I may actually slaughter someone if Xfce comes with menu options that aren’t bound to functions like that.

could it be that Xfce needs to be recompiled from source under openSuse 11.1? that would be…amazing, because it comes packaged as an install option with no warning, but I really wouldn’t be that shocked if that turned out to be true.

Thoughts? Thanks for your help and time so far

First, well done on narrowing the problem down to the guest OS with Xfce when running it “virtual”. That’s about all you can claim at that stage.

I understand your comments regarding Xfce, but unfortunately thats a DE I haven’t explored. Not every DE will run perfectly in VBox, and I suspect less-used ones from openSUSE may not through lack of exposure. There are fans of Xfce and a search of the forum will pick 'em up with their experiences.

Installing openSuse 11.1 through VirtualBox with Gnome/KDE desktops should not give same problems, as I have done both.

There has been recent interest in another lighter DE, a LXDE live-cd here by user anubisg1[/QUOTE]; the standard distro release install of LXDE may have issues; you could PM him before attempting it in VBox or again search the forum.

it’s weird that something as high level as the window manager could have a compatibility problem that spans different VM systems.

It was kinda sad, but you’re right, KDE worked “fine” or as fine as KDE does, now that i’ve gotten used to the lightening fast speed of Xfce, KDE feels like linux with beer-goggles on.

and to be fair, I didn’t even want Xfce for any merit of Xfce’s. I only wanted it because Xfce isn’t KDE or Gnome…it was just the current small and fast option that looked like it’d be the easiest to deal with.

Ideally, I’d like to have some of the features of a modern DM/WM, like auto-mounting, mounting…at all, and context menus, then use IceWM for everything else.

When I was tinkering with Xfce, I killed the OS X dock wannabe Panel at the bottom, and ran IceWM --replace over it, so I kinda blended the two to make one super slim, mind-blowingly responsive interface. It was fast enough I A: forgot I was using linux(not a jab at linux, it’s just not the fastest thing on earth) and B: forgot I was running it in a virtual machine.

(I’m sure people have their reasons to love Gnome/KDE - those are both just outside of my performance budget and they both do a lot of stuff I don’t ever need, or at least I assume they do with the amounts of RAM they allocate and the extra minute that KDE adds to my boot time)

Ultimately, I plan on installing openSuse on my macbook via rEFIt, so it’ll be hardware-native…ish, at least it won’t be a virtual machine, maybe my Xfce/IceWM blend will work under those circumstances, and be EVEN FASTER.

I’m gounna look into the slim DM you linked me to and see how that plays out in VirtualBox/VMwareF

who knows, maybe the issues will just dissipate after the openSuse 11.2 release

Thanks again for all your help.

I’ll get back with results on your link

You are welcome. Even though we didn’t fix it, the thread will help someone else avoid trouble or provide a home for further results.

It may seem weird, but sometimes openSUSE developers implement by expedience instead of taking the broader view. Of course the same comment could be made about devs more generally. Also to get a lighter DE some direct interfacing methods may be unavoidable.

Given your “performance budget”, you may be interested in the second post by* oldcpu* in this thread here.

Do post back here with any results, and enjoy the forum. :slight_smile: