Virtualbox doesnt load virtual machine

today I made an “zypper dup” and now Virtualbox doesn’t work anymore.
When I try to start the Win7 machine the following error occurs:

Für die virtuelle Maschine Win7 konnte keine neue Sitzung eröffnet werden.

The virtual machine ‘Win7’ has terminated unexpectedly during startup with exit code 1 (0x1).

Fehlercode:NS_ERROR_FAILURE (0x80004005)
Interface:IMachine {85cd948e-a71f-4289-281e-0ca7ad48cd89}

Any ideas?



this buggs me also, cause it looks like I’ve the same issue. When I started to look around I realized that vboxdrv service failed to start.

systemctl start vboxdrv.service
Job for vboxdrv.service failed because the control process exited with error code.
See "systemctl status vboxdrv.service" and "journalctl -xe" for details.


systemctl | grep vbox
● **vbox**drv.service              loaded failed failed    VirtualBox Linux kernel module


journalctl -xe

Oct 24 22:22:19[3932]: Starting VirtualBox services.
Oct 24 22:22:19[3937]: Starting VirtualBox services.
Oct 24 22:22:19[3932]: Sources for building host modules are not present,
Oct 24 22:22:19[3932]: Use 'sudo zypper install virtualbox-host-source kernel_devel' to install them. Quitting ..
Oct 24 22:22:19[3932]: failed: modprobe vboxdrv failed. Please use 'dmesg' to find out why.
Oct 24 22:22:19[3949]: failed: modprobe vboxdrv failed. Please use 'dmesg' to find out why.
Oct 24 22:22:19  systemd[1]: vboxdrv.service: Control process exited, code=exited status=1
Oct 24 22:22:19  systemd[1]: vboxdrv.service: Failed with result 'exit-code'.
Oct 24 22:22:19  systemd[1]: Failed to start VirtualBox Linux kernel module.
-- Subject: Unit vboxdrv.service has failed

even modprobe can’t load it

modprobe vboxdrv
modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/4.18.15-1-default

So it looks like the (prebuild) kernel-module from VirtualBox doesn’t support the new kernel.
Now I tried to build the module from source…

install package for building the module

zypper in virtualbox-host-source

conveniently theres now a script to run for building it

Building kernel modules...
Kernel modules built correctly. They will now be installed.
insmod /lib/modules/4.18.15-1-default/misc/vboxdrv.ko 
insmod /lib/modules/4.18.15-1-default/misc/vboxnetflt.ko 
insmod /lib/modules/4.18.15-1-default/misc/vboxnetadp.ko 
insmod /lib/modules/4.18.15-1-default/misc/vboxpci.ko 
Kernel modules are installed and loaded.

And this did the trick for me, it really looks like the prebuild modules are broken.

The 2 days before the broken upgrade I also had issues with the audio in the VM, this is now also solved (maybe thanks to the selfbuild module)
Or could be something different, maybe someone else can confirm this

best regards, antares

this may be a temp solution cause they will repair the prebuild modules - then we can uninstall the selfbuild modules

Works perferct!

Thank you so much,

You are welcome, glad that i could help.
If anyone else has a good idea on how to change between prebuild and selfbuild modules easy (that the 2 packages won’t collide on next kernelupgrade, except uninstall one), please let us know. If not this thread could be marked as solved.

best, Antares

We don’t mark threads as solved ( solved for one person, may not be solved for the next ) but thanks for taking the time to register here and step in.

I didn’t notice anywhere in your post that you unchecked the virtualbox host hernel modules package.
Only in this case and because you didn’t seem to uninstall or at least unlist the package, I would expect that the next time you update your system would install the pre-built modules if the version is newer than what you built from source.

You’ll know for sure the next time you see a kernel upgrade…
Every time a new kernel is installed, either new pre-built modules need to also be installed with it or you’d have to build your own.


thx for the info, I wasn’t very familiary with the custom here. :wink:

Yes that make sense, I wasn’t sure which module is loaded if both are valid for the kernelversion, cause the vboxdrv service wrote in the logs that it tired to build the module from source but didnt find it, which is now installed.
Prebuild and source package aren’t excludeing each other so maybe there’s a logic to decide which module is loaded.
My guess would be that the service looks for the prebuild first and if not present tires to build one if sources are installed. Maybe I can verify that next upgrade…

Just checked and this has been fixed now with the 5.2.18 version of Virtualbox which I have just installed OK on Tumbleweed from the normal repositories. Tested and now booting Windows 7 just fine.