virtualbox acting weird with usb!

I’ve installed the proprietary virtualbox on opensuse11.1 x64 KDE4.2
It’s nearly perfect but:
Some of my usb devices are captured and some ain’t
I’ve tried to manually unmount them to allow virtualbox to be “first” with no success. Sometimes my usb ext HD can be captured but most of the time it can’t
my scanner is automaticaly captured without problem
The usb capture device options doesn’t change anything

any clue ?

I don’t think it’s a hardware thing, it’s the same pb with my laptop and workstation with all my usb devices.

I’ve already tried every hack I was able to googled without success (using the smb link works for a HD drive but not for a camera or webcam)

pb solved by reading the thread
VirtualBox USB grey - Page 3 - openSUSE Forums


Your welcome, and to use solution 2 (discussed on page 3). However, if you read further on you would find it somewhat deprecated. This led to Solution 3 where for each device that doesn’t work, rules are added to the 10- rules file. That may be tedious for some people, but has the disadvantage of getting overwritten at every Virtualbox upgrade. This led to Solution 4 (my post on Page 8 covers it). It is easy to implement, copies the openSUSE default 50- rules file, and only requires commenting-out one line there. I prefer this solution, and it was tested by several people on various devices in thread. If you haven’t already, and you have time, do read the later parts of the thread, for more devices being tested. :slight_smile: