VirtualBox 7.0.10 is in testing

Oracle released VirtualBox 7.0.10 yesterday 7/18/23.

I have successfully compiled and installed it for Tumbleweed in OBS.

Good news - Oracle fixed the ibt issue for newer cpus’. You will not need ibt=no for 7.0.10.

I am still testing it and we are trying to get it ready for kernel 6.5.0.

It should appear in Tumbleweed first and then for Leap.

There is a lot to test and compile for all flavors of OpenSUSE.

If there are no testing issues - we hope to release it tomorrow 7/20/23.

Be patient - I do not control the OpenSUSE release flow - I have to allow it to go thru like any developer

3 Likes

Thank you very much for your excellent work !!!

We released it to Factory today.

OBS has broken 15.5 kernel build section - hopefully they will fix it soon - It worked fine yesterday and is broken today.

All other parts have compiled successfully in OBS and now go thru QA.

Everything I can test - USB, cut, paste, resize all worked as expected. Sorry, but the 7.0.10 windows 11 guest addition still freezes after a few hours - I have gone back to 6.1.40 which runs fine.

All 15.4, 15.5 and Tumbleweed are now waiting for QA to test and release it to all.

For those that want to see what it takes and the status go here:

hi Larryr

After todays update on tumbleweed the windows VB I have would start but when the desktop should appear all stayed black, an ACPI shutdown did a nice shutdown, so it was running fine it seems.

Did a roll back and installed just the Virtualbox update 7.0.10 and the mandatory kernel update to see if it was this or any of the other updates today, sadly it would behave the same.

Then cursed to myself that I probably forgot the extension pack but sadly that did not make a difference either.

So again rolled back, booted up the VB, uninstalled the guest addon 7.0.8
Closed the VM
Installed 7.0.10 again (and the kernel and the extension pack)
Booted up and got my desktop (small size as no addon installed)
Installed addon, right away got a black desktop again, pressed enter a few times (as I suspected the addon install would prompt for a reboot and indeed the VB rebooted, but saldy back to a black desktop.

So for now rolled back and locked VB 7.0.10, which sadly also locks the Kernel

Regards, Xil

Virtualbox 7.0.10 is working here on Leap 15.5 for about a week without Problems.

I use my own OBS, but virtualbox is branched from the Virtualization Repo.

So thanks for your work.

If you select TPM for a Windows machine and the TPM data is not valid - the Windows machine will not load in 7.0.10.
Unselect TPM and see if you Windows machine loads. If so the TPM data is bad, I don’t know how to tell windows to reinstall the TPM data.

Well you can forget my whole story.

  • new day so tried again, install 7.0.10
  • set video to off the one none-supported formats VBoxVGA, it booted fine
  • then set it back to VBoxSVGA en booted fine

so am miffed but it works :slight_smile:

Why is 7.0.10 available in Leap 15.4 but not in 15.5 repositories?

Yesterday I perform Leap upgrade from 15.4 to 15.5 and I’m surprised that I have to downgrade Virtualbox version.
Virtualbox updates used to be available in standard main or update repositories.

Regards.

VirtualBox 7.0.10 for 15.5 is in the Queue for QA then if it passes QA it is released to the masses - There is little to do for 15.4 but security fixes so it goes thru QA faster than 15.5 which has a lot of other apps in development in the queues - Tumbleweed gets 1st Priority as I see it as it does not need SUSE blessings as it is independent from SUSE development. 15.4 and 15.5 have to have SUSE blessings (What I think is the reason for the long Queues).

My opinion - not fact but observation. Larry and I did release 7.0.10 3 days after Oracle released it. Then it was reject by the build system - we found the reason (new require statement had to be added that was not needed 2 weeks earlier) it successfully built in day 5 and it was finally release to Tumbleweed in day 7.

If you are impatient for 7.0.10 and do not care about secure boot - the Oracle/VirtualBox leap version for 7.0.10 works fine. It is not signed so it will not work in a secure system - you do have to have to install the source code for the kernels for it to work in OpenSUSE.

1 Like

Thanks. I appreciate that explanation.

It just got released for 15.5 in the last hour.

Hi, i recently upgraded my laptop from Leap 15.4 to 15.5 and now run with virtualbox-7.0.10-lp155.2.5.1.x86_64 .
Also i installed the new guest-additions on my virtual machines.

I have trouble assigning USB devices to my virtual machines. E.g. trying to assign a USB stick to a guest it seems to detach the device from the host, then something fails and re-attaches it to the host again.
In the devices menu the USB stick doesn’t get checked and the device is still accessible on the host instead of the guest.

Your question is not directly related to the subject of this topic.

Please start a new thread for a new question with a good title that tells you potential helpers about what the problem is. That is the way to draw the attention of those that may be able to help you.

1 Like