VirtualBox 6.0.4_SUSE r128164 - Win 7 "the BIOS in this system is not fully ACPI compliant"

Since an zypper DUP a couple of days ago, my one WIndows 7 VirtualBox VM refuses to boot with the error

The BIOS in this system is not fully ACPI compliant

Other linux based VMs appear to work as normal

Arch linux users seem to be having the same problem as per this thread
zypper info virtualbox tells me:

Information for package virtualbox:
Repository     : openSUSE-Tumbleweed-Oss  
Name           : virtualbox               
Version        : 6.0.4-3.3                
Arch           : x86_64                   
Vendor         : openSUSE                 
Installed Size : 38.6 MiB                 
Installed      : Yes                      
Status         : up-to-date               
Source package : virtualbox-6.0.4-3.3.src 

I apologise for using Win 7 - :wink: - but I have an Arturia Spark LE and SPARK 2.0 software, and I was wanting to do some drum song / pattern writing today, and couldn’t do so.

(I think I had issues last time I tried this software with Wine - maybe it’s time I tried again?)

I haven’t tried to fix this yet by reverting to an earlier version of VirtualBox…


Although the following Virtualbox forum thread is not the same problem because those posters have a problem with Virtualbox 6.0.6 and were able to resolve by rolling back to version 6.0.4 (your problem appears to be with 6.0.4), do the screenshots and behavior appear to be the same otherwise?

The following Virtualbox documentation appears interesting,
I wonder if you could skip to the last lines in the section and run that command to extract information from your system, then insert in your Guest configuration. Or, I suspect because these settings are entirely related only to EFI(FAIK all Windows 7/8/10 installs default to setting up EFI), if your Windows VM were to be configured to disable booting from EFI and instead boot “legacy MBR” if that could solve your problem… But that might be difficult to modify in a Guest that won’t boot in the first place so might more likely apply to a new install.

Keep in mind that Virtualbox 6 is a massive change implementing lots of new architecture and was launched very, very recently.
If you’re running Virtualbox 5, Virtualbox is still supporting an update path that does not upgrade to Virtualbox 6.


Did you read this thread? It points to another thread where user reports that VB built with ACPICA 20190215 works ans VB built with later ACPICA fails. ACPICA was updated in factory couple of weeks ago and current VB is built against acpica-20190405-1.1.

OTOH thread you link to also says that VB 6.0.6 works.

At this point you should open openSUSE bug report against VB and point to both threads so it can be investigated. May be VB just needs updated.

Yes, I did some more digging after posting this topic, and read the Arch and VirtualBox threads in more detail …

I’m just off to post a bug report

And in reply to tsu2 - yes the screenshots and behaviour identical as to what is described in the first post on 

except as you both have pointed out I’m having issues with 6.0.4, and Arch is having problems with 6.0.6

bug report posted 

It appears this was previously reported in Bug No 1132941.

Yes, looks like it was posted in the 25 minutes or so I took whilst writing mine, as it wasn’t there when I started writing it…

I’ve marked that one as “confirmed”, marked mine as a duplicate, and added what the arch bug tracker said was the fix


“iasl from acpica 20190329-1 miscompiles ACPI tables of VirtualBox. Building with older acpica fixes the issue”

Bug is reported as confirmed and Larry Finger states:

“The upstream acpica project is aware of the problem ( and is working on the issue as of 3 days ago.”


Mine is doing this as well…

Is there anything simple I can do, like downgrade a specific package? I don’t really want to compile a test version of acpica and then compile VBox, etc… I need this for work, but not quite that badly.

Oracle do have their own VirtualBox repo, although it’s not set up to work with Tumbleweed, but you can modify the repo file to make it work

name=VirtualBox for openSUSE 42.3 x86_64

It is set up to work with Leap, so I looked at the URL path and modifed the baseurl line above manually


I get a dependency issue

sudo zypper in VirtualBox-6.0
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides needed by VirtualBox-6.0-6.0.6_130049_openSUSE132-1.x86_64
 Solution 1: do not install VirtualBox-6.0-6.0.6_130049_openSUSE132-1.x86_64
 Solution 2: break VirtualBox-6.0-6.0.6_130049_openSUSE132-1.x86_64 by ignoring some of its dependencies

And at this point I haven’t had time to fix that. And of course this may break other things.

When I have time this evening, I may investigate further - but my Windows 7 vm is not mission critical. but I am doing actual development work on various debian based VBox VMs that are currently working, and I need to work, so I’m reluctant to potentially break them

I’d prefer a OpenSUSE Tumbleweed solution that allows me to revert to the VirtualBox 6.0.4-3.1 that was working (with a Win 7 VM) a week or so ago

On 4/23/19 8:36 AM, iDominic42 wrote:
> wicked1;2900519 Wrote:
>> Mine is doing this as well…
>> Is there anything simple I can do, like downgrade a specific package?
> Oracle do have their own VirtualBox repo, although it’s not set up to
> work with Tumbleweed, but you can modify the repo file to make it work

I’ve been using Oracle’s VB on tumbleweed for a few years and not
experienced any issues yet.

unix since 1986
S.u.S.E.-openSUSE since 1998

An interim solution has been posted in the Bug 1132941 by Larry Finger .

Thanks, yes, I’d seen that.

It looks as though he has built a virtualbox 6.0.6 rpm package - which is what the Arch linux users were having problems with - and is referenced as having the same problem in the bug report

Whereas the current package in OpenSuse Tumbleweed that has the bug is 6.0.4-3.3

(I’m pretty sure 6.0.4-3.1 was working as I was using my Win7 VM sometime early last week)

I might post to the bug tracker that it’s 6.0.4 that is broken in Tumbleweed. But I appreciate his work to compile and fix it.

This is not meant to come over as a criticism, certainly given the mistakes I’ve made during this thread and the bug tracker!

Also thanks to kensch who posted that he has used Oracle’s VirtualBox Repo.

I’ll have a look at both these solutions this evening and hopefully post some results…

Now, if only I could get Arturia and Line6 / Yamaha to provide software that doesn’t require Windows or OSX…

You do not need VirtualBox to run Windows VM on Linux host. Do not have OS X experience.

Yes, true.

I have used virtualisation with Xen since about 2006, and more recently used ganeti, and also virsh / virt-manager - just not on my laptop, which is where I started using VirtualBox

I should probably convert to using Virtual Machine Manager on my laptop, it’s just I haven’t got round to it yet

Noticed a separate link for openSUSE “current” vs “old” openSUSE on Virtualbox recently but didn’t look into that deeply…

If this is a brand new install or even an Virtualbox upgrade from an existing Virtualbox…

You should know that you are not required to upgrade to VB6 for the time being… Virtualbox is still supporting VB5 fully and just released some patches and a new VB5 version…

If you need a working VBox, I highly recommend installing VB5 for now, wait until the bugs are worked out before installing or upgrading to VB6.


Hi Ken

Thanks, I’ve finally got round to using the official Oracle VirtualBox repoe, after doing a bit of research into the dependency issue I got when I tried to install from it the first time,

which was

Problem: nothing provides needed by VirtualBox-6.0-6.0.6_130049_openSUSE132-1.x86_64

There were threads on the VirtualBox forums suggesting that simply creating links in /usr/lib64 would fix problems

so I did:

cd /usr/lib64/
sudo ln -s
sudo ln -s
sudo ln -s
sudo ln -s
sudo ln -s
sudo ln -s
sudo ln -s
sudo ln -s
sudo ln -s
sudo ln -s

which is possibly a bit of overkill, as it was only complaining about

After that, I removed all the Tumbleweed Virtualbox (6.0.4) packages I had installed and did a

sudo zypper install VirtualBox-6.0

NB if you don’t remove the OpenSUSE virtualbox 6.0.4 packages you will get file conflicts at this point, so best to do it before

I still got the error about but told it to install anyway

and 6.0.6 installed, and appears to be working fully

Information for package VirtualBox-6.0:
Repository     : VirtualBox for openSUSE 42.3 x86_64          
Name           : VirtualBox-6.0                               
Version        : 6.0.6_130049_openSUSE132-1                   
Arch           : x86_64                                       
Vendor         : Oracle Corporation                           
Installed Size : 235.9 MiB                                    
Installed      : Yes                                          
Status         : up-to-date                                   
Source package : VirtualBox-6.0-6.0.6_130049_openSUSE132-1.src
Summary        : Oracle VM VirtualBox                         

And my Win7 VM is working again.

Obviously you may also need to update the Guest extensions package inside your VMs, and I also added the 6.0.6 Extension Pack in VirtualBox itself

For those of you also stuck, you can add the Oracle repo in Tumbleweed by following the instructions on

You will need to modify the repo file as I mentioned in an earlier post on this thread as Tumbleweed itself is not supported



I tried following LarryFinger’s instructions on the bug tracker to add his personal repo using Yast2, but I kept getting errors with the repo - almost certainly my fault - so decided to go ahead with looking at the official Oracle virtualbox repos

Someone has posted that they got Larry’s instructions to work

see 1132941 – TW 20190418 VirtualBox: Windows 7 Guest BSOD with "The BIOS in this system is not fully ACPI compliant"

for all the hard work that Larry has been doing, which I appreciate but could not get his repo to work for me

@iDominic42]( ,
What repo are you configuring?

On the Linux Downloads page you referenced, I see different links for LEAP 15 vs earlier (that’s something new I mentioned above) and each links to an RPM, not a repo.

Regardless of how you’re configuring any repo, you might be installing a RPM for older openSUSE although IIRC at least for installing VBox 5 the RPM was named as though it was originally built for 13.1 (but worked in all versions of openSUSE including 15).

In any case,
Without more info it’s likely that no modification of BaseURL or RPM name should be necessary unless they don’t point to a valid location. They’re only labels so likely have no effect on functionality.

And, in the past I’ve found the GPG key configurations unnecessary… I either use our convenient “auto accept” command line options or “ignore” as last resort. Downloading, installing and applying key files for validation is something other distros have to do, we have more convenient options in openSUSE.


What I did was use the instructions at the end of Linux_Downloads – Oracle VM VirtualBox in the “RPM-based Linux distributions” section

There is a link to import the opensuse repo file at the bottom of that page

which at this point in time is giving me all sorts of SSL errors and an unauthorized request page, not the .repo

However if you do (without the https)


you get

name=VirtualBox for openSUSE $releasever - $basearch

So if you copy that to (for example)


and run sudo zypper ref I get:

Retrieving repository 'VirtualBox for openSUSE 20190423 - x86_64' metadata ......................[error]
Repository 'VirtualBox for openSUSE 20190423 - x86_64' is invalid.
[virtualbox-fail|] Valid metadata not found at specified URL
Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository 'VirtualBox for openSUSE 20190423 - x86_64' because of the above error.
Some of the repositories have not been refreshed because of an error.

$releasever obviously equates to openSUSE 20190423 for which there is not a Oracle VirtualBox release

So I browsed the url in baseurl after taking the variables out and made a guess, and chose 42.3

I’m possibly doing some of this wrong, but it worked for me


and if I did do something wrong, I was doing that in about the 20mins whilst drinking a cup of tea in the morning before heading off to work

So I got SSL errors trying to download a repo file, curled it, and still got a javascript filled page telling me unauthorised, replaced the https with http and curled it,

copied it to a .repo file in /etc/zypp/repos.d

tried a sudo zypper ref

and then modded the repo file so it gave a me an answer.

A quick hack or two, but one that added a working repo