Virtualbox 4.0.4 and USB devices

Hi. I installed the latest version of Oracle Virtualbox 4.0.4 OSE on my OpenSUSE 11.4 64 bit with GNOME and Packman plus Tumbleweed system. I also installed the Virtualbox Guest Tools 4.0.4-14-1. I have a SanDisk Cruzer 16.00 GB USB 2.0 flash stick drive. I formatted it as FAT unencrypted. I put in my Microsoft Word and Powerpoint along with Excel files on it. I plugged my SanDisk Cruzer into the USB 2 port and OpenSUSE immediately recognized it and mounted it. However, I have a Microsoft Windows 7 32 bit virtual machine that will not see my SanDisk Cruzer.

What do I need to do to solve this problem?

What information do you need to help you?

Thank you.

Is the OSE version supporting USB devices?

I checked the Oracle Virtualbox website and it says that the OSE supports USB devices only if I install the extension pack. When I checked the package list in Install / Remove Software, I did not see the extension pack listed. I went to the Oracle Virtualbox website directly to download and install the extension pack directly, but it is not working.

What should I do to solve this problem?

It sounds like you have everything you need installed. See if the steps in this pic help:

I do not see the Enable USB 2.0 (EHCI) Controller option which consequently means that I still cannot access my USB devices under my Windows 7 virtual machine.

How do I solve this problem?

What version of Virtual Box?

You need the one from this repo:
Index of /virtualbox/rpm/opensuse/11.4/

The Extension Packs needs to be installed in the Host not The Guest. Download it in openSUSE and click (or double-click) to install.
See here for more info: Chapter 3. Configuring virtual machines

I am using the repository that you mentioned now. I installed virtualbox-4.0. I downloaded and I installed the extension pack from the Oracle Virtualbox website. I need to reboot my laptop now to see if everything will work. I think that it is going to work. I will report back later.

One more tip. You need to add yourself to the vboxusers group.

I ran into a problem. Virtualbox-4.0.4 does not work anymore. I am using Linux kernel 2.6.38-18.1-desktop. When I try to run my Windows 7 virtual machine, it gives me two error messages:

  1. Failed to open a session for the virtual machine Windows7. The virtual machine has terminated unexpectedly during startup with exit code 1.

  2. The Virtualbox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv . Please reinstall the kernel module by executing

‘/etc/init.d/vboxdrv setup’

as root. Users of Ubuntu, Fedora, or Mandriva should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles vboxdrv kernel module if necessary.

What do I need to do to solve this problem?

Open a terminal and become su -


/etc/init.d/vboxdrv setup

When I do try the /etc/init.d/vboxdrv setup as SU, I get this error message:

wellywu@linux-21rs:~> sudo /etc/ini.d/vboxdrv setup
root’s password:
sudo: /etc/ini.d/vboxdrv: command not found
wellywu@linux-21rs:~> sudo /etc/init.d/vboxdrv setup
Stopping VirtualBox kernel modules done
Uninstalling old VirtualBox DKMS kernel modules done
Trying to register the VirtualBox kernel modules using DKMS
Error! Your kernel source for kernel 2.6.38-18-desktop cannot be found at
/lib/modules/2.6.38-18-desktop/build or /lib/modules/2.6.38-18-desktop/source.
(Failed, trying without DKMS)
Recompiling VirtualBox kernel modules failed
(Look at /var/log/vbox-install.log to find out what went wrong)

Here is my /var/log/vbox-install.log file contents:

Uninstalling modules from DKMS
removing old DKMS module vboxhost version 4.0.4

Deleting module version: 4.0.4
completely from the DKMS tree.

Attempting to install using DKMS

Creating symlink /var/lib/dkms/vboxhost/4.0.4/source ->

DKMS: add Completed.
You can use the --kernelsourcedir option to tell DKMS where it’s located.
Failed to install using DKMS, attempting to install without
Makefile:167: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again. Stop.

For the record, I did install DKMS. It is version dkms-

I found this help article: Vbox driver problem on opensuse 11.4 (View topic) •

Probably something to do with you using Tumbleweed. And it maybe doesn’t have the kernel-source to match the kernel

Honestly, you are so far out of your depth it isn’t even funny.
You simply shouldn’t be moving away from the default stable release, you just don’t have the experience yet.

I got it to work perfectly. I simply followed the guide located here at Vbox driver problem on opensuse 11.4 (View topic) • and I reinstalled Virtualbox-4.0. Then, I visited the Oracle Virtualbox website and I installed the extension pack using the Oracle VM Virtualbox. I ran Virtualbox and I got no errors. I ran my Microsoft Windows 7 Professional 32 bit virtual machine and it worked perfectly. I plugged in my SanDisk Cruzer 16.00 GB USB 2.0 stick drive and Windows Explorer found it and I was able to load up my Microsoft Word, Excel, and Powerpoint files perfectly within Microsoft Office 2010 Professional Plus 32 bit.

I am a newbie when it comes to OpenSUSE, but I am determined to make things work with your help.

Thank you.

So, here’s how I solved the problem earlier:

  1. sudo zypper update

  2. sudo zypper install gcc make automake autoconf kernel-source kernel-syms

  3. Remove Virtualbox-4.0 and guest-tools

  4. Install Virtualbox-4.0 and guest-tools

  5. Install Extensions Pack

  6. Run Oracle Virtualbox

  7. Run my Microsoft Windows 7 Professional 32 bit virtual machine

  8. Plug in my SanDisk Cruzer USB 2.0 stick drive

  9. Load up my Microsoft documents.

  10. Problem solved thanks to the people here and at Virtualbox.

That’s good news

I just use Libre Office on any M$ stuff people throw at me, seems to work fine.

LibreOffice has so much potential to take on Microsoft Office. It is the best free and open source office productivity suite available. I am happy that OpenSUSE 11.4 includes it.

However, Microsoft Office 2010 Professional Plus is the gold standard. I need it to earn my degree from NJIT along with Windows 7.

This is why I worked so hard to resolve this problem with Oracle Virtualbox. Now, I can use it in conjunction with any USB device including my SanDisk Cruzer 16.00 GB flash stick drive and everything works perfectly. I bought a digital textbook for my course in Principles of Operating Systems which I am taking during this spring 2011 semester. It uses the Cafescribe MyScribe program which is only available for Microsoft Windows and Apple Macintosh. I tried to run it using WINE, but MyScribe does not work with it.

My next step is to reboot my notebook PC and make sure that everything works once again.

On 04/05/2011 12:06 PM, wellywu wrote:
> When I do try the /etc/init.d/vboxdrv setup as SU, I get this error
> message:
> wellywu@linux-21rs:~> sudo /etc/ini.d/vboxdrv setup
> root’s password:
> sudo: /etc/ini.d/vboxdrv: command not found

You have a typo. It’s init.d, not ini.d

Kevin Miller
Juneau, Alaska
“In the history of the world, no one has ever washed a rented car.”

  • Lawrence Summers

Thank you for pointing that out.

The problem is resolved. I rebooted my laptop and Virtualbox works along with support for USB devices.