Virt-manager: Cannot Browse Local

I am tumbleweed, after finishing zypper update and rebooted.

I downloaded and ISO file and started virt-manager trying to install by booting the ISO file.

Steps:

  1. Start virt-manager
  2. enter admin password
  3. choose new virtual machine
  4. choose Local ISO, then forward
  5. At Choose ISO, select browse
  6. Then choose Browse Local

Expecting a file dialog box open for me to select which ISO file to use. But there is no new windows opened.

1 Like

I can not help you with your problem, but I saw this:

You should not use zypper up with Tumbleweed. You should only use

zypper dup

Thank you for the reminder.

Since I switched to Tumbleweed, whenever I do “sudo zypper update”, from time to time, “zypper dup” is triggered automatically.

From now on, I will only do “zypper dup”.

I have the same problem. This is the error I get when I look at virt-manager --debug.
Traceback (most recent call last):
File “/usr/share/virt-manager/virtManager/storagebrowse.py”, line 162, in _browse_clicked
return self._browse_local()
^^^^^^^^^^^^^^^^^^^^
File “/usr/share/virt-manager/virtManager/storagebrowse.py”, line 187, in _browse_local
filename = self.err.browse_local(
^^^^^^^^^^^^^^^^^^^^^^
TypeError: vmmErrorDialog.browse_local() got an unexpected keyword argument ‘choose_label’

You should not run virt-manager with sudo. Your user should be a member of the libvirt group and that is all. Then run virt-manager as your user.

Having the same issue. It used to work fine but I recently reinstalled and just stopped working, I thought I wouldn’t find a fix.
Not ideal and not sure if it breaks anything but I worked around it by replacing this line (number 191) in /usr/share/virt-manager/virtManager/storagebrowse.py:

        choose_label=data.choose_label)

With:

        )
2 Likes

Don’t. On a next update it will be overwriten. Never edit stuff that is owned by packages.

It is set as you said and the problem still persists.

What are you referring to? Did you reboot?

Yes I restarted. I made it a member of the libvirt group. I also made the necessary config edits. It does not ask for a password when logging in. So everything is fine but browsing files are not working. I’m sorry if I misunderstood your message. I think you just gave general information. I thought it was related to solving the problem.

Ah, you cannot browse the host from inside the VM? I’m off now, but will check tomorrow

1 Like

This worked for me. I backed up the original file. Thanks :tada:

Hi! just wanted to chime in here - I am having the same issue. I spent an entire day trying to resolve this issue, even did a fresh install of TW, and it did not resolve.

I am about to try the workaround mentioned above, but I wanted to make sure its known that this is apparently somewhat widespread.

I have heard great things about openSUSE, but I have to admit issues like this are making me nervous to switch to it entirely - I can imagine for someone non-technical, this would be a (frustrating) deal breaker.

Update…I’m not sure if something is broken with the package. I wasn’t even able to see virt manager in the app menu even though Yast, Zypper, and Discover showed it installed. Trying to launch from Discover led to a generic message that the app couldn’t be opened with no error code or additional information. I was able to open it with the Create VM option in Yast, unfortunately out of frustration I didn’t try the fix listed above before what happened next…

I did a fresh TW install again, installed with Yast, and had the exact same behavior as above, except this time nothing happens when I try to open from Yast.

TL;DR - fresh install, KVM server and tools installed via Yast, virt manager not listed in applications and will not launch from Discover or Yast. Not even able to test if the fix for Browse Files not opening works.

At this point I’ve given up. I will continue to use TW for now because other than this, it’s been great, but really hoping this is fixed in an update if more folks start to have the behavior.

EDIT: I am on KDE Plasma

@nzcurtis was the libvirtd service running? I’ve never worried about local browse, I pop all my images in /var/lib/libvirt/images… and my user is in the libvirt group.

On the first install, yes libvirtd service was running for sure and I added myself to libvirt group. I was able to open virt-manager, connect to KVM/QEMU. The only issue was Browse Local.

Second install, it was running, and i was in the group, but I couldn’t see virt-manager in apps and had to launch from Yast. Browse Local still did not work.

Third install, I didn’t even check if libvirtd was running since I didn’t see virt-manager in apps again…didn’t think it was worth continuing with the rest of the steps at that point.

I will try to install one more time and rollback if needed - would like to try dropping the images into the path you mentioned above to avoid needing the Browse Local function.

Thank you

I wanna add that you can still browse files even if the Browse Local button is not working. Just press the Add Pool button (looks like a plus) in the bottom left corner, give the pool any name, set type to dir and then type the path under Target Path. I used my Downloads folder for example.

@horse I appreciate it, I’ll try that

I installed the aarch64 version of TW GNOME on my MacBook and while virt manager appeared as an app again, still had the issue with Browse Local. Tried with Cinnamon too, no dice. I thought maybe it was a KDE issue since I seem to have different issues with KDE depending on the distro but I guess in this case it was unrelated.

Did you install the package virt-manager in the first place?

Thank you very much!

My browse local works with your suggested change.