Videos playing with jerky movement in Leap 15.6 browser?

I have noticed a recurring issue with videos playing in IG and Twitter where the movement is jerky or stop action . . . . I’m running nouveau . . . . I’ve lost track of whether Leap has changed vendors or if Packman is in charge, but this problem seems to be exclusive to Leap 15.6, it is not occurring in my TW install, or in any of my other OSs . . . .

It’s not a total show-stopper, just something that is “unsmooth” . . . .

Anything to try out?

Can you provide sample links?
What browser?
What Desktop?
X11 or Wayland?
I have all versions for Firefox plus Waterfox and not having video issues.
What hardware and driver are you running?

Operating System: openSUSE Leap 15.6
KDE Plasma Version: 5.27.11
KDE Frameworks Version: 5.115.0
Qt Version: 5.15.12
Kernel Version: 6.4.0-150600.12-default (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 PRO 6850HS with Radeon Graphics
Memory: 62.1 GiB of RAM
Graphics Processor: AMD Radeon Graphics
Manufacturer: HP
Product Name: HP EliteBook 865 16 inch G9 Notebook PC

What browser are you using??

This is the most important question…

I’m booted in another system for today, but graphics:

Graphics:
  Device-1: NVIDIA GK110 [GeForce GTX 780] vendor: eVga.com. driver: nouveau v: kernel arch: Kepler
    pcie: speed: 2.5 GT/s lanes: 16 ports: active: DVI-I-1 empty: DP-1,DVI-D-1,HDMI-A-1
    bus-ID: 05:00.0 chip-ID: 10de:1004 class-ID: 0300 temp: 41.0 C
  Display: x11 server: X.Org v: 1.21.1.7 with: Xwayland v: 22.1.9 driver: X: loaded: modesetting
    unloaded: fbdev,vesa dri: nouveau gpu: nouveau display-ID: :0 screens: 1

Browser is Firefox, across all 7 systems I’m running on the machine, possibly XFCE, X11 . . . . I’m using XFCE on another install, only Leap has this herky-jerky effect with videos . . . .

Are you using the stock Firefox that came with the OS? If so, remove it and replace it with the flatpak version. I also had the same issue of choppy playback while using XFCE and an Nvidia card, across multiple installs. For some reason Opensuse’s version that comes with the OS refuses to playback imbedded videos properly, no matter what tweaks you try, or what codecs you install.

Replace with flatpak and then try. Report back with the results.

1 Like

Hmm . . . yes, it would be the stock Firefox. Which is interesting in that in TW (MATE) with the stocker Firefox, all is well . . . possibly in another install with XFCE . . . .

Anyway, easy enough to run a “sudo zypper rm firefox” to remove it, but then how am I getting to install the flatpak version of it??

I have another machine that runs Pop_OS and that has flatpak, but there I just run “sudo update flatpak” ??? (something like that) and it pulls in all of the “flatpaks” that it has and updates them. But, as far as “installing from flatpak” . . . not sure how that goes???

Here is how you install flathub on TW(Leap should be the same):

sudo zypper install flatpak

Flathub repo:

flatpak remote-add --if-not-exists flathub https://dl.flathub.org/repo/flathub.flatpakrepo

Then sudo flatpak + plus name of whatever you want to install as usual. Hope it works well for you.

I’m not sure why the stock firefox is like this on OpenSuse. Couldn’t really find a straight answer. The stock Chromium from the factory repo also had similar problem as it refused to play Youtube videos at all.

1 Like

@Android_Gynous Best to only add the repo as your user and install flatpaks as your user…

1 Like

@malcolmlewis

Alrighty, thanks for the post . . . so I get that Leap 15.6 might not have flatpak installed, so that has to be installed . . . and then what?? Added to the repos so that it can be updated??

What is your suggested command to add the flatpak repo ???

@non_space I use the --user option to add as my user;

flatpak --user remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

So it will put the user flatpaks in ~/.var directory, not sure what Desktop Environment you plan to use, if Plasma I assume Discover should work and also has Faltseal integrated(?), have a read here about Flatseal and usage etc GitHub - tchx84/Flatseal: Manage Flatpak permissions

1 Like

Gents:

Followed the commands to install flatpak, I could see that went OK, then moving on to add it to repos . . . got the first set of responses. I tried to “sudo flatpak install firefox” and it errored out. Then I remembered the “session must be restarted” so I rebooted and tried again, got the second paste . . . did not install. Checking the regular Repos does not show “flatpak” listed??

Then I tried to post back to the forum here and Chromium doesn’t have any of my many passwords, had to zypper in MozillaFirefox to post back here. Checking how video is playing in new zypper Firefox . . . “worse” than it was . . . . : - )))

So, how am I to know if “flatpak” is added into repos, or how to get that done??

deep@MacPro:~> sudo flatpak --user remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
error: Refusing to operate under sudo with --user. Omit sudo to operate on the user installation, or use a root shell to operate on the root user's installation.
deep@MacPro:~> flatpak --user remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

Note that the directories

'/var/lib/flatpak/exports/share'
'/home/deep-mind/.local/share/flatpak/exports/share'

are not in the search path set by the XDG_DATA_DIRS environment variable, so
applications installed by Flatpak may not appear on your desktop until the
session is restarted.


deep@MacPro:~> sudo flatpak install firefox
[sudo] password for root: 
Looking for matches…
error: No remote refs found for ‘firefox’
deep@MacPro:~> sudo flatpak install MozillaFirefox
Looking for matches…
error: No remote refs found for ‘MozillaFirefox’

deep@MacPro:~> sudo zypper in MozillaFirefox

@non_space no sudo needed, it’s all done as your user…

1 Like

@malcolmlewis

?? Well, you can see that I did run it w/o sudo below the first run where I did, and it brought back the comments about the two directories . . . “not appearing on desktop until restart” . . . .

And had searched --help to find out that flatpak wants “install” spelled out to install something, but . . . “no remote refs found”??? for “MozillaFirefox” etc.

So something appears to not have been done??

# ls /home/deep/.local/share/flatpak
.changed  db  repo

Got it now . . . have the “new” “stable” version of FF installed . . . checking for video play in a minute.

Once I figured out the “sudo not needed” that gave me 5 choices of flatpak firefox to install, I chose “stable” . . . .

Just checked IG and the Twitter and video playback is “stable.”

Thanks for the assist and to Malcolm for the details . . . .

1 Like

For security sake, I agree.

@Android_Gynous

So, in using the flatpak version of Firefox in Leap, in Yahoo Mail and on FB fonts appear to be rendered roughly . . . ??? The font looks blurry and squiggly . . . but here in this forum they are fine. I tried to check in the FF settings . . . didn’t see anything there to mess with, I set “minimum font” to 9? Didn’t make a difference, then I went into Leap and changed “hinting” to medium . . . “enable anti-aliasing” is checked on . . . .

Any thoughts about how to tidy up the fonts in some web sites and not others??

Also, another solution if you want to keep using the FF distributed with OpenSuse, you can install the package “opi” and then execute “opi ffmpeg” and select ffmpeg-6 from the list. Installing it solves the problem. Regards.

1 Like

Might be something to try . . . I have already changed over to the flatpak version . . . . I guess if the font rendering problem drives me nuts I could try this method . . . ??

I’m not sure if the font will get fixed, if you have normal font in the stock firefox then for sure it will also work if the codecs fix your video issues. With the flatpak version i cant be of much help, at most i can suggest checking the flatpak settings for Firefox and check if all what’s needed is enabled, or also try switching wayland/x11. Cheers.

1 Like