Video & other problems

Hi, everybody SUSE community!

I am trying to work under suse64 11.1.
I understand nothing how do fix problems after normal installing DVD SUSE x86_64/x86_32 v.11.1.
And just my first steps I have many problems on both computers (notebook & desktop).

  1. My HD 4550 driver x64 does not work probebly, always slowly redraw screen, it does after updates on ATI Catalist driver 9.1(?).
  2. There are not possibility to view/play mp3/mp4 files & others (i do not understand which, but i saw/played it under windows without problems).

I do understand that many peaple use another systems without problem, why there are such here?

I can not read and search solution of problems in my mother language. It’s so very pity :(.

So, I have following problems:

  • ATI HD 4550 x64 does not work
  • WLan (intel i2200) x32 (on notebook) has not been installed and does not work.
  • Multimedia x64 & x32 do not work (gnome on desktop and kde4.1 on notebook).

What can I fix the problems?

I have tryed to use SUSE 2 years ago, just after first problems simply remove it and forget about it. Is it the same situation with SUSE? The time of SUSE is not coming?

I will so very kind of you, who can help me.

Thanks & regards,
sam12

Multi-media and Restricted Format Installation Guide - openSUSE Forums

Thanks, vlc works now. Problem with slowly window drawing still exists.

Did you install the ATI driver
ATI - openSUSE

yes, i did. catalist 9.10. from ati.
I try again by your link.

now catalist works more corectly, but problem (slowly drawing) has not been resolved.
mp3 is not also played.

Please post the result of these 2 commands:

cat /etc/X11/xorg.conf
zypper lr -d

catalist from desktop computer:

~> cat /etc/X11/xorg.conf

/…/

SaX generated X11 config file

Created on: 2009-11-07T21:56:11+0100.

Version: 8.1

Contact: Marcus Schaefer <sax@suse.de>, 2005

Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>

Automatically generated by [ISaX] (8.1)

PLEASE DO NOT EDIT THIS FILE!

Section “ServerLayout”
Identifier “Layout[all]”
Screen “Screen[0]” 0 0
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
Option “Clone” “off”
Option “Xinerama” “off”
EndSection

Section “Files”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
EndSection

Section “Module”
Load “dbe”
Load “freetype”
Load “extmod”
Load “glx”
Load “dri”
EndSection

Section “ServerFlags”
Option “AIGLX” “on”
Option “AllowMouseOpenFail” “on”
Option “IgnoreABI” “on”
Option “ZapWarning” “on”
Option “Xinerama” “off”
EndSection

Section “InputDevice”
Identifier “Keyboard[0]”
Driver “kbd”
Option “Protocol” “Standard”
Option “XkbLayout” “us,ru”
Option “XkbModel” “microsoftpro”
Option “XkbOptions” “grp:ctrl_shift_toggle,grp_led:scroll”
Option “XkbRules” “xfree86”
Option “XkbVariant” “,winkeys”
EndSection

Section “InputDevice”
Identifier “Mouse[1]”
Driver “mouse”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “Name” “Chicony Electronics Chicony wired mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “Modes”
Identifier “Modes[0]”
EndSection

Section “Monitor”
Identifier “Monitor[0]”
VendorName “ENC”
ModelName “EIZO MONITOR”
UseModes “Modes[0]”
DisplaySize 340 270
HorizSync 30.0 - 88.0
VertRefresh 43.0 - 85.0
Option “CalcAlgorithm” “XServerPool”
Option “DPMS”
Option “PreferredMode” “1920x1440”
EndSection

Section “Device”
Identifier “Device[0]”
Driver “fglrx”
VendorName “ATI”
BoardName “RV710 (RV710 9540)”
Option “XAANoOffscreenPixmaps” “true”
Option “Capabilities” “0x00000000”
Option “OpenGLOverlay” “off”
Option “FSAAScale” “0”
Option “FSAAEnable” “off”
Option “VideoOverlay” “on”
EndSection

Section “Screen”
Identifier “Screen[0]”
Device “Device[0]”
Monitor “Monitor[0]”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1920x1440” “1920x1200” “1900x1200” “1920x1080” “1600x1200” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 16
Modes “1920x1440” “1920x1200” “1900x1200” “1920x1080” “1600x1200” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 24
Modes “1920x1440” “1920x1200” “1900x1200” “1920x1080” “1600x1200” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 8
Modes “1920x1440” “1920x1200” “1900x1200” “1920x1080” “1600x1200” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
EndSection

Section “DRI”
Group “video”
Mode 0660
EndSection

Section “Extensions”
Option “Composite” “on”
EndSection

zypper lr -d

—±------------------------------±------------------------------±--------±-----------±----------±-------±----------------------------------------------------------------±------
1 | 11.1 | 11.1 | Да | Да | 99 | rpm-md | Index of /update/11.1 |
2 | 11.1_1 | 11.1 | Да | Да | 99 | rpm-md | Index of /packman/suse/11.1 |
3 | 11.1_2 | 11.1 | Да | Да | 99 | rpm-md | Index of /pub/vlc/SuSE/11.1/ |
4 | ATI Repository | ATI Repository | Да | Да | 99 | rpm-md | http://www2.ati.com/suse/11.1 |
5 | Libdvdcss repository | Libdvdcss repository | Да | Да | 99 | rpm-md | http://suse.linuxin.dk/repo/11.1/ |
6 | Packman Repository | Packman Repository | Да | Да | 99 | rpm-md | Index of /pub/packman/suse/11.1 |
7 | openSUSE 11.1-0 | openSUSE 11.1-0 | Да | Нет | 99 | yast2 | cd:///?devices=/dev/sr0 |
8 | openSUSE-11.1-Updates | openSUSE-11.1-Updates | Да | Да | 99 | rpm-md | Index of /update/11.1 |
9 | openSUSE-NonOSS-Add-on_11.1-0 | openSUSE-NonOSS-Add-on 11.1-0 | Да | Да | 99 | yast2 | Index of /distribution/11.1/repo/non-oss |
10 | openSUSE_11.1-0 | openSUSE 11.1-0 | Да | Да | 99 | yast2 | Index of /distribution/11.1/repo/oss |
11 | repo-debug | openSUSE-11.1-Debug | Да | Да | 100 | yast2 | Index of /debug/distribution/11.1/repo/oss |
12 | repo-non-oss | openSUSE-11.1-Non-Oss | Да | Да | 100 | yast2 | Index of /distribution/11.1/repo/non-oss |
13 | repo-oss | openSUSE-11.1-Oss | Да | Да | 100 | yast2 | Index of /distribution/11.1/repo/oss |
14 | repo-source | openSUSE-11.1-Source | Да | Да | 100 | yast2 | Index of /source/distribution/11.1/repo/oss |
15 | repo-update | openSUSE-11.1-Update | Да | Да | 20 | rpm-md | Index of /update/11.1 |

Notebook (video ATI PCIe x700) works correct with installed from SUSE-DVD driver MESA(?), without Catalist.
I need Catalist on desktop-computer because of without it i can not set the screen-resolution.

I see you have both videolan and packman repositories enabled.

caf4926 sent you to this guide:
Multi-media and Restricted Format Installation Guide - openSUSE Forums

where it clearly states:

For what ever reason you did not follow that, and hence IMHO there is a good possibility that is MOST likely caused your problem. Caf4926 is pretty good at this, and when he recommends an approach, if you decide to deviate from it, IMHO it is a good idea to first ask if there may be some complications.

If my assessment is correct (that you have inappropriately left videolan in your repos, and hence mostly likely inappropriately mixed videolan and packman packaged multimedia applications) then this is going to be a bit painful to fix.

Your best bet now may be to identify the offending videolan applications, per RedDwarf’s guide:
Check your multimedia problem in ten steps - openSUSE Forums

Caf is right. The phenomena described typically arise when mixing packages from packman en videolan.

Fixing it is not too painful:
Start Software Installer, go Configuration-Repos
Remove the Videolan repo.

Now select the repo view and tick the Packman repo.
In the package list, right click, choose All packages - Update all uncondifionally. If the software installer throws dependency conflicts at it, tell it that switching to the Packman packages is OK. Accept and run the package install. Done.

By now all packages should be the Packman versions, and audio and video trouble should be solved.

Many thanks for the help.

After some updates suse was killed :(. And I have installed again SUSE from DVD, then multimedia from your link.
Some packages were not found (libavcodec52 and etc.), but most video viewers work now.

Now i can see avi-files per VLC, SMPlayer, xine, and can not in Totem.

I have not installed AMD drivers, but window redrawing is OK.
Without ATI driver I can not change frequence for my CRT-monitor and set correct screen resolution.

If I install ATI drivers, do I get the slowly-redrawing (by scrolling or window moving) problem again?

How can I save this state of system, that I try to load ATI drivers?

Please post result of this:

rpm -q libavcodec52

and then

zypper lr -d

if it says not installed, do this from a su terminal

zypper in libavcodec52

we’ll deal with the rest later

here is it:

linux-2460:~> rpm -q libavcodec52
libavcodec52-0.5.20358svn-1.pm.4.1

–±----------------±----------------------±--------±-----------±----------±-------±----------------------------------------------------------------±------
1 | Packman-RPMs | Packman-RPMs | Да | Да | 90 | rpm-md | Index of /packman/suse/11.1 |
2 | openSUSE 11.1-0 | openSUSE 11.1-0 | Да | Нет | 99 | yast2 | cd:///?devices=/dev/sr0 |
3 | repo-debug | openSUSE-11.1-Debug | Нет | Да | 120 | NONE | Index of /debug/distribution/11.1/repo/oss |
4 | repo-non-oss | openSUSE-11.1-Non-Oss | Да | Да | 120 | yast2 | Index of /distribution/11.1/repo/non-oss |
5 | repo-oss | openSUSE-11.1-Oss | Да | Да | 120 | yast2 | Index of /distribution/11.1/repo/oss |
6 | repo-source | openSUSE-11.1-Source | Нет | Да | 120 | NONE | Index of /source/distribution/11.1/repo/oss |
7 | repo-update | openSUSE-11.1-Update | Да | Да | 99 | rpm-md | Index of /update/11.1 |

what do with ATI driver?

Good, so it’s installed.

ATI?
Umm… You have recollections of issues unwanted don’t you?
Really, it shouldn’t be a problem - just a click away:
ATI - openSUSE

or
You get it manually from ATI
Graphics Drivers & Software

I’ve just installed ATI drivers from ATI - openSUSE, and have got the old problem again: slow scroll in window & redraw by window move.

I have both “X11/xorg.conf” before & after ATI driver installation.

What can/should I change there that the problem to fix?

So do I, just as in how_to said.

ATI driver works OK, except very slow window redraw, match more slowly when was it before ATI installation.

I don’t have time to walk you thru it now, I’m off the bed, so have a look here
ATI/Troubleshooting - openSUSE

You might want to post the result of this for other who can help

cat /etc/X11/xorg.conf

I thing it is the same as previous

/…/

SaX generated X11 config file

Created on: 2009-11-08T21:42:47+0100.

Version: 8.1

Contact: Marcus Schaefer <sax@suse.de>, 2005

Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>

Automatically generated by [ISaX] (8.1)

PLEASE DO NOT EDIT THIS FILE!

Section “Files”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”
EndSection

Section “ServerFlags”
Option “AIGLX” “on”
Option “AllowMouseOpenFail” “on”
Option “IgnoreABI” “on”
Option “ZapWarning” “on”
EndSection

Section “Module”
Load “dbe”
Load “freetype”
Load “extmod”
Load “glx”
Load “dri”
EndSection

Section “InputDevice”
Driver “kbd”
Identifier “Keyboard[0]”
Option “Protocol” “Standard”
Option “XkbLayout” “us,ru”
Option “XkbModel” “microsoftpro”
Option “XkbOptions” “grp:ctrl_shift_toggle,grp_led:scroll”
Option “XkbRules” “xfree86”
Option “XkbVariant” “,winkeys”
EndSection

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[1]”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “Name” “Chicony Electronics Chicony wired mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “Monitor”
Option “CalcAlgorithm” “XServerPool”
DisplaySize 340 270
HorizSync 30-88
Identifier “Monitor[0]”
ModelName “EIZO MONITOR”
Option “DPMS”
Option “PreferredMode” “1920x1440”
VendorName “ENC”
VertRefresh 50-85
UseModes “Modes[0]”
EndSection

Section “Modes”
Identifier “Modes[0]”
EndSection

Section “Screen”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1920x1440” “1920x1200” “1900x1200” “1920x1080” “1600x1200” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 16
Modes “1920x1440” “1920x1200” “1900x1200” “1920x1080” “1600x1200” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 24
Modes “1920x1440” “1920x1200” “1900x1200” “1920x1080” “1600x1200” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 8
Modes “1920x1440” “1920x1200” “1900x1200” “1920x1080” “1600x1200” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”
EndSection

Section “Device”
BoardName “RV710 (RV710 9540)”
Driver “fglrx”
Identifier “Device[0]”
Option “XAANoOffscreenPixmaps” “0xe5aa10”
Option “Capabilities” “0xe56f60”
Option “OpenGLOverlay” “0xe59430”
Option “FSAAScale” “0xe5acf0”
Option “FSAAEnable” “0xe595d0”
Option “VideoOverlay” “0xe5a6d0”
VendorName “ATI”
EndSection

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”
EndSection

Section “DRI”
Group “video”
Mode 0660
EndSection

Section “Extensions”
Option “Composite” “on”
EndSection

Thanks a lot for your try to help.

I’m not sure, I don’t use ATI.
I always install my nvidia manually

ATI here: ATI Catalyst™ Proprietary Display Driver

Look up the instructions. You need to remove or disable the current ATI repo if you do a manual install.