vga=0x314 is deprecated

When I boot (and this has been going on for quite a while now, but I just got the energy to actually look into this) I get the following between grub2’s menu and plymouth starting.

  Booting 'openSUSE 13.1'

Loading Linux 3.11.10-17-desktop ...
vga=0x314 is deprecated, Use set gfxpayload=800x60016,800x600 before linux
command instead.
Loading initial ramdisk ...

Where do I add/replace “set gfxpayload=800x60016,800x600”? In /boot/grub2/grub.cfg? If so, at what line (not sure how to properly word that)?

I have


in “/etc/default/grub”, which is supposed to allow the software to make those decisions.

Edit /etc/default/grub, then run

grub2-mkconfig -o /boot/grub2/grub.cfg

to update the changes accordingly. When you reboot the changes will take effect.

This might be relevant to you.

For most of us, the default graphics settings in /etc/default/grub work perfectly.

Interesting read. Thanks to all that answered. nrickert, that did the job. Consider this post answered and closed.

another way,

YaST2 -Boot Loader --Boot Loader Options,

set ‘Vga Mode’ from the pull down list to ‘Unspecified’