Very slow updates

Helo!
Does anyone know how I can use a mirror faster?
The internet connection is good, but the update downloads don’t reach 100 bits… Previously it was around 2.5 mibs.
Thanks

Today, I was seeing somewhere around 900 kb/s. It is usually faster than that.

I think it depends on how many people are updating at around the same time. At present there might be a lot of traffic with people updating Leap, which uses some of the same mirrors.

My experience was similar when I updated last night. Slow as molasses. It was somewhat better today. I’m sure it will return to its normal peppy speed. It happens.

Thanks for answering.
Today I tried to update at a different time, but it wasn’t worth the experience.
I went through gnome-software before, and refrech before opening a terminal window, and giving a # zypper dup…
To my surprise all packages were already cached, I think it was the refrech I gave… tomorrow I will try again sooner.

Hi, I am still experiencing very slow updates, but maybe in a different way than what the OP was experiencing.
What I see is that after issuing a “zypper dup”, the “downloading repository metadata” is very very slow (it can sometimes take tens of minutes), but usually only on download.opensuse.org.
Then, when it starts downloading the actual updated packages, speed is fast as usual.
Anybody else seeing this?
Is there someone that can suggest what may be causing this? I cannot think of any reason for such a behavior.

Thank you in advance
Cris

Hi
Mirrors are still syncing for the update released 27 minutes ago… I would suggest to wait an hour or so and try again…

Thank you Malcolm for your reply.
However, I’m not talking about a momentary problem. I have been having this problem for about 10 days now.

Cris

Hi
Both systems? Could be sent to a slow mirror in your locale. If you go to the download site and browse to a file of a few megabytes to download and look at the ‘details’ link to the right and pick a mirror to download from and see how the speed is…

For example: http://download.opensuse.org/tumbleweed/repo/oss/x86_64/ade-devel-0.1.1f-1.10.x86_64.rpm.mirrorlist

Add some verbosity to you dup command to see whats happening;


zypper -vvv dup

This is one example: this evening refreshing the games repository metadata is taking ages…
https://susepaste.org/view/raw/11634623

Is there a way I can force zypper to use a mirror of my choice?

Cris

Just tried to see the mirror list of one of the metadata files of the games repo, as per your suggestion Malcolm.
Here is what I get. Is it normal that it says “no mirror was found”? Is this the source of my problem?
https://susepaste.org/view/raw/6519021

Hi
Most definitely the issue… Try forcing a refresh and see if that helps;


zypper ref -f

Not sure why there isn’t a mirror, might be worth creating a progress ticket about this, email admin {at} opensuse {dot} org

Show your repos:

3400G:~ # zypper lr -uEP
#  | Alias                            | Name                                         | Enabled | GPG Check | Refresh | Priority | URI
---+----------------------------------+----------------------------------------------+---------+-----------+---------+----------+------------------------------------------------------------------------
21 | packman                          | packman                                      | Yes     | (r ) Yes  | Yes     |   90     | http://ftp.fau.de/packman/suse/openSUSE_Tumbleweed/
 8 | download.opensuse.org-non-oss    | Haupt-Repository (NON-OSS)                   | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/tumbleweed/repo/non-oss/
 9 | download.opensuse.org-oss        | Haupt-Repository (OSS)                       | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/tumbleweed/repo/oss/
10 | download.opensuse.org-tumbleweed | Hauptaktualisierungs-Repository              | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/tumbleweed/
12 | google-chrome                    | google-chrome                                | Yes     | (r ) Yes  | Yes     |   99     | http://dl.google.com/linux/chrome/rpm/stable/x86_64
18 | mozilla                          | Mozilla based projects (openSUSE_Tumbleweed) | Yes     | (r ) Yes  | Yes     |   99     | https://download.opensuse.org/repositories/mozilla/openSUSE_Tumbleweed/
 2 | BellSoft                         | BellSoft Repository                          | Yes     | (r ) Yes  | Yes     |  100     | https://yum.bell-sw.com/
3400G:~ # 

download.opensuse.org can be slow. Try the following mirrors instead:

Hi karlmistelberger, sorry for the late reply.

That could be an option, but it would mean editing all the repos that point to download.opensuse.org.
It’s not a big deal, but it would disable the automatic mechanism that connects (or at least tries) you to the best mirror when you use download.opensuse.org.
This could then give me problems in future.

Well, I guess I should try and create a ticket as malcolmlewis suggested.

Thank you
Cris