Version 11.1 errors during install process

Problems that I have been having with the OpenSuSE ISO files are related to this error message:

>>> Linxurc 3.3.2Z (Kernel <<<
cd:/content: Invalid signature. Installation aborted

For some unknown reason the installation process cannot find the correct signature for this directory or file and errors out consistently no matter what form of installation process I have used. The error always occurs just past the welcome screen and after you choose installation and the kernel loads in. The next screen is the one that has the OpenSuSE logo with a progress bar and the error occurs just when the progress bar passes the ‘n’ and ends up with a error message displayed on a blue background in a pop up box in red with yellow letters. This is where my problems always start – I cannot get the installation to go further than the welcome screen.

The following processes were employed to download the ISO:

BTW- If you attempt to download from HTTP use FireFox or non-IE based Browser as IE has issues with files that are over 4gb in size.

  1. HTTP, Torrent, Network install disk, and FTP.
  2. The ISO files all passed the checksum tests, including the torrent.
  3. Downloads were performed thru IE and Firefox, and uTorrent
  4. Two different DVD burners used
  5. Three different media types used
  6. Three different computers attempted to install
  7. All target computers are in good working order and use hardware that is compatible with SUSE Linux via the HCL.

Each time I have attempted to install from ISO, online with NET install or torrent ISO it constantly comes up with the same error – always pointing to cd;/content as having an invalid signature. If anyone can figure this out I would certainly appreciate it.

What happens if you choose to check the media instead of installing right away?

Also, might be a a silly question, did you burn the CD or DVD in image mode?

Not a silly question – I have been diligent on burning as ISO image with Nero and ImageBurn also created an DVD from Imageburn with a Torrent download, all on DVD +R media. The process completes without errors and is also verified before I take it out of the drive.

Media loads into the computer DVD and reads successfully but will not install. Media Check hangs about a third of the way into the DVD, but also completes after about 4 hours. The “Small Network CD” passes the media check but you get the same error when you try to obtain files from the online repository.

Correct me if I am wrong – but in my mind this points to an issue with the Depository files rather than what is happening with the DVD and CD’s on my end. >:)

Incidentally ALL my downloaded files (DVD and CD ISO’s) are passing the MD5 checksum with no errors found. The file that I have is complete – even the torrent was fine. :frowning:

NEW / Additional Info:
Further testing with different mirrors produces the same result. All attempts to install OpenSuSE 11.1 are coming back with the same “cd:/content has invalid signature” error and aborts installation.

This is the same error that has been found all thru the 10 and 11 versions according to the Bugzilla listings. This would show proof that something continues to be messed up in the repository of the distribution.

Would someone please contact the build team and tell them to get with it?

No, this is not normal. The media check should complete within a few minutes. Have you tried with DVD-R media? Older DVD drives have problems with DVD+R media, as this format is more recent. Do you have a friend you can give the DVD to and ask them to run a self-check on it? This to see if you are having drive problems. Yes, all three of them.

Correct me if I am wrong – but in my mind this points to an issue with the Depository files rather than what is happening with the DVD and CD’s on my end. >:)

Incidentally ALL my downloaded files (DVD and CD ISO’s) are passing the MD5 checksum with no errors found. The file that I have is complete – even the torrent was fine. :frowning:

Then again, thousands of people, including me, must have downloaded the ISO image and had no problems installing. So unfortunately the evidence is against your theory. And no, the ISO image doesn’t change with every bugfix. It remains the same, and any patches are installed on top of it.

Contrary to what you are saying about this being an issue with my equipment rather than the distro I have in fact spent several hours looking into this on Bugzilla and it does appear to be a prevalent and persistent issue that crops up from time to time. Looking at the individual reports and the ‘answers’ to the issues from the development team - usually some minor addition or file update to the distro breaks the ISO and invalidates the signature. The usual solution to this is usually an “update” to the ISO file and it returns to normal in a few days.

Part II of this issue:

I have used the same equipment to burn DVD and CD media successfully and use them on this and other target computers to install other Linux distributions and software without problems like this or other related issues. I am not a newcomer to Linux nor am I inept in burning DVD or CD media.

Perhaps you could explain how I can successfully download ISO images from Ubuntu, Fedora, Mandriva and even Microsoft using this same equipment that OpenSuSE 11.1 ISO and Net install fails to work with? BTW I have successfully ran OpenSuSE 10 on this same machine without errors.

Also - If the online repositories are giving up the same related error message during a network install which points to the same content that is in the ISO would that also logically point to an issue with the files rather than the media or the hardware?


I have just done three network installations, versions 11.0 with KDE, 11.1 with Gnome and now x86_64 version of 11.1 with KDE.
None of the problems above reported and in truth I was rather impressed by the network installation.

What is odd is the slight differences between the two 11.1 versions. Different monitors listed for example (I use IBM 22" CRT and there was no file for it in the x86_64 version but there was in the x86 version.

Also some icons have not appeared on desktop but just a rectangle with a ? in the middle.

If somebody could tell me what has happened here and advise how to restore the icons I would be grateful. The ones missing are trash, printer and on line help.


Have you attempted to configure the desktop using the GUI? I usually have good luck with that option to refresh the icons if they become lost or screwy.

The other thing would be to look into the right xconfig for your monitor. Generic size and refresh settings may be possible fits for your monitor as well. Google the specs and then look for a close match that carries the same specs and give that a shot.

OK… I have narrowed down some potential ideas that may lead to an answer on the install issues.

  1. Make sure the system date and time are current and correct.
  2. Do not use a “pre-formatted” HDD.
  3. uTorrent the download over HTTP or FTP as it has built in error checking and you can more easily rebuild the ISO.
  4. Read the bugzilla bug reports closely or search of keywords if you have issues. They have good intel if you look hard enough.

I have been able to get the NETWORK Mini CD to work but it is still having trouble getting packag information and files from the servers. May be related to high download traffic.

My system date was off by 1 hour (daylight savings time) and that contributed to the signature issues, but has not alleviated the installation issues by using DVD. Still working on that issue.


No, you are mistaken there. The ISO images are not changed whenever there is a bugfix. Instead, update packages are provided separately to patch the affected packages. The MD5SUMs have not changed since the ISOs were released. It not possible (vanishingly small probability) to change the contents of the ISO without changing the MD5SUM. (And there is no wish to, MD5SUM collisions have to be deliberately engineered.) I have the original MD5SUM files from the first release and they have not changed.

Remastering the ISO (a respin) is a step that is only taken in extraordinary circumstances, when say the distro is so flawed that it must be remastered, or so many patches have evolved that it’s worthwhile creating a new distro. It’s normal for a distro to collect lots of bugs on bugzilla. With the number of packages in a distro, it is certain that many of them will have security bugs to fix from time to time. Not to mention the non-security fixes.

As for your problems they’re just as puzzling to me as they are to you. It could be that you are very unlucky to have this particular distro fail on all your machines. But that doesn’t mean that it is flawed for everybody. Lots of people have successfully installed from the ISO images provided.

I do understand and realize that it may be a certain issue with hardware and Version 11.1 of the distro. What is confounding is that I am now writing this from the same computer running 11.0 just fine. Trying to update or upgrade has the same effect.

Listing the hardware:
MSI K7 TurboII Motherboard
AMD Athlon XP 2400+
512mb of SDRAM PC133
ATI 9550SE w/128 AGP Video Adapter
Seagate 40gb 7200rpm IDE HDD on Primary
Sony DVD-Rom (16x) IDE Secondary Master
MSI CD-RW 48x24x48x IDE Secondary Slave
Linksys Ethernet II (PCI) Lan Card
Onboard Sound

For some unknown reason this machine will not work with 11.1 install under the current media.

From what I have read on the Bugzillia reports (too many to individually list) this can be from the Machine’s Date/Time being off, the HDD not formated before install and / or some of the files in the repository that did not have the right KEY attached.

I will keep trying (they call me a Pit Bull for a reason :))


I think the fact that the self-check of the DVD was so slow points to some issue with the installer kernel and the DVD drive.

You could try to find out boot options or driver blacklisting might avoid the problem.

Another way would be to install without using the DVD, say by booting the NET installer and getting the distro over the Internet, or over the LAN, from a donor machine with the DVD mounted. Then you would have to immediately upgrade to a kernel with the bug (whatever it is) fixed, after the install so that you can use the DVD drive.

You could also stick with 11.0, it isn’t that much older than 11.1 and has quite a bit of support life left, until hopefully 11.2 fixes the problem.

Ok, the problem was solved in another threat:

A better failure message could be:
‘invalid system time’. An update of the system time had solved the problem.

I try to inslall 11.1 too and get the same error. But independent if I install from DVD or net.

The failure occures on the same file. So I thing it isn’t a problem of the DVD but rather a problem of the installation itselv.

Has anybody another idea?