Veracrypt - No official package - Experimental or Community?

Hi there,

Noticed there is no official package for veracrypt.
Is it better to go with the experimental package filed in “security”, or one of the many community packages (preferably from a known and trusted packager)?

Kind regards. Jbt

There is a “gostcrypt” package in the packman repo. I have no experience and make no recommendation about it.

Here, I use LUKS disk encryption, because that is natively supported in linux.

Looks like Veracrypt themselves built an openSUSE 15 package, I haven’t tried it but it looks like a good bet.

In certain situations like recent exploits discovered that attack hardware based encryption, encryption that stores keys on the disk may be advisable.


cheers, both.

would an .rpm rolled for suse15 work on a recent tumbleweed?

Reading the build requirements (if one was to build from source) from the Veracrypt github source,
I could speculate that there shouldn’t be a problem running the RPM targeting 15 on a TW only because I don’t notice any red flags, but that’s purely guessing.

If the RPM doesn’t work, it also looks pretty easy to compile from source, and if you go down this path, it’s one way to ensure support and use of the encryption installed in your system.

I’m hesitant to fully endorse using an RPM built for 15 to be used on TW for disk encryption generally… and particularly if you intend to implement full disk encryption, you might end up one day unable to boot. Of course, to a certain extent you’d always have that risk to some degree by just implementing full disk encryption so in any case you should have full, regular backups made anyway. If you only intended to encrypt a portion of your disk like your /home, then I’d consider your risk considerably less (because you should be able to boot even without a /home) and have a decent chance of troubleshooting if you were otherwise locked out.


Do NOT install Leap 15.x packages on TW. The versioning of f.e. deps and libs are way apart. If it works today, it may not tomorrow… which in cases like this leads to huge problems.

Took the liberty to update veracrypt in the Security repository to the latest released version, once accepted, suggested you grab from there.

Update ref:

Very nice, Malcolm.
Veracrypt is an important method of encryption, perhaps one of “the” recommended encryption methods for those who don’t trust TPM because of recently discovered flaws.

I took a little time to test the RPM from the Veracrypt website in a TW…
Although I won’t recommend it when Malcolm’s build incorporates a desirable hotfix and targets all current openSUSE versions(except ARM which is pending as of this post), I found no problems at the moment running the package intended for “openSUSE 15” installed on TW…

I found that there is no worry about an unbootable system…
Veracrypt does not support encrypting any Linux system partition.
I therefor ran a little test creating a Veracrypt encrypted volume within a file in my User’s Documents directory, mounted and did stuff in it without a problem.


cheers, all.

I intend it just for mounting containers of data.
veracrypt is valuable for me, as it keeps data portable across OS’es, and easy to backup once dismounted.

thank you, Malcolm.

The update has been accepted into the security repository, enjoy :slight_smile:

Hi there,

I had just logged into the suse forums to say I’d spotted it being installed and to offer my thanks.

Kind regards. Jbt

Looks like veracrypt has disappeared again:✓&baseproject=openSUSE%3AFactory&q=veracrypt

Has it disappeared because it ceased to build in response to factory changes?

It was never included in factory/Tumbleweed and package still exists (and is built for factory) in the same repository as 2 years ago and the last change is from yesterday.

You need to get it from the ‘Security’ repository, seems it was fixed earlier today…

cheers, both.

has there been a change in the “opensuse search” behaviour with regards to non-factory packages?
i swear i just used to search for the package now (as linked above).

Yes. The attempt to bring openSUSE and SLE closer together has resulted in problems for software search. I think it is being worked on.

smashing, makes sense.