not sure if it is the correct section …

I have the issue that I am unable to use any virtual console.

Looking at

systemctl --full status systemd-vconsole-setup
● systemd-vconsole-setup.service - Setup Virtual Console    Loaded: loaded (/usr/lib/systemd/system/systemd-vconsole-setup.service; static; vendor preset: disabled)    Active: inactive (dead) since Wed 2018-08-29 09:55:41 CEST; 17min ago      Docs: man:systemd-vconsole-setup.service(8)            man:vconsole.conf(5)  Main PID: 984 (code=exited, status=0/SUCCESS) 
.. systemd[1]: Starting Setup Virtual Console... .. systemd[1]: Started Setup Virtual Console.

The service appears to be “vendor preset: disabled” – Why is that?
… and most important, when I try to enable it I can “start” the service systemd-vconsole-setup but not enable it.

The service cannot be enabled/disabled because it has no "install" section in the description file

Using Ctrl+Alt+F2 to FX… does nothing. So it is not working.


chvt 1

opens a new console … What is the problem?

Because the systemd developers (the vendor) have delivered the service with the preset set to “disabled” …

A “static” systemd unit is simply a unit without an “install” section; which means that, it can neither be enabled nor disabled.
Don’t worry, if something needs (depends on) a static unit then, it’ll be started by systemd at the appropriate point in time …

  • Performing a case-insensitive recursive ‘grep’ for “vconsole” in ‘/usr/lib/systemd/system/’ reveals that the plymouth-start.service “wants” the ‘vconsole-setup’ service.
  1. Is it correct to assume that, tty1 is accessible and usable?
  2. Does /dev/ contain any character special tty devices apart from tty1?

I’ll check the behaviour on this system without a Display Manager running – there are some other issues around X11 on AMD hardware which mean I’ll have to shutdown this session. Back in a minute or two.

Back again.
Logging into tty2 <Ctrl-Alt-F2> and then issuing ‘chvt 3’; ‘chvt 7’ (landed on the X11/sddm Display Manager login screen); ‘chvt 1’, all functioned as expected and, from each “changed to VT”, <Ctrl-Alt-F2> dropped me back into my login on tty2. ‘chvt 0’ (tty0 – used by Braille keyboards) raised an error as expected.

From your original post, it seems that only tty1 is present on your system – in ‘/etc/sysconfig/keyboard’ is ‘KBD_TTY’ set to anything other than “” ?

Assuming that, since the last system boot tty2, tty6 and tty3 have been used, if you tab-tab on ‘systemctl status getty’ is something like “ getty@tty2.service getty@tty6.service getty@tty1.service getty@tty3.service getty@tty7.service” offered as possibilities?

By default, the Linux kernel activates tty0 through tty63: have you built your own kernel?

no I have not build my own kernel …

You can ignore the message, it won’t harm. There’s patch for it. but … my recent Leap Live image doesn’t show the message, so it may have been fixed. Is your system up to date?