/var/tmp making / full

I finally did the upgrade from Leap 15.3 to Leap 15.4. (I need to wait for a break in work.)

I did the "edit all the repositories 15.3 references to 15.4, zypper dup download in advance " method. This has worked well in the past and it worked this time too.

Usually the included NVIDIA driver version in the distro causes problems with my particular setup, so I uninstall it and compile/install the “hard way” (though not really “hard” at all). This is when the troubles began…

I have 50 GB for /, plenty, yes? Well, for some reason, it was on the brink of full, so running the NVIDIA script would fail unpacking. A quick df -k revealed the disk space issue. I needed to free up space, stat!

I followed this doc:

And cleaned up old snap versions too… and removed one big application from /opt.

This worked and I was able to install the NVIDIA driver. I was still very close to running out of / space, however, and the space kept getting eaten up by something…

A couple of hours ago, there was an update to the distro NVIDIA driver, which I forgot to mark as taboo, never to install (as I was doing the “hard way”). It was quicker to accept the install and do a removal later.

After restarting to init 3, I did “zypper remove nvidia-driver-G06-kmp”. zypper identified 7 packages to be removed and said it’ll save 1.1 GB. In the course of removing the packages, / ran out of disk space! And sure enough, df -k reported / had about 1k. What was consuming the space?!?

Well, from the subject, you can tell I discovered it was /var/tmp. I had a ton of zypp.XXXXXX directories that were pretty old… 11 GB’s worth! It seems that the zypper remove failure was due to zypper filling up /var/tmp!

Maybe the SDB:Cleanup_system webpage should include looking at /var/tmp? And cleaning up zypp.XXXXXX directories?

How should we know? Show output of

btrfs filesystem usage -T /
btrfs qgroup show /
btrfs subvolume list /
snapper list

Sorry, that was a rhetorical question, as that was what I was wondering at the time.

/var/tmp was filled with zypper.XXXXXX directories, which used up 11 GB of /.

I’m suggesting that SDB:Cleanup_system webpage include information on cleaning /var/tmp.

Mine haven’t been touched in quite some time, and consume relatively trivial space:

# inxi -Sz
  Kernel: 5.14.21-150400.24.33-default arch: x86_64 bits: 64 Desktop: KDE v: 3
    Distro: openSUSE Leap 15.4
# ls -Gghd zypp.*
drwx------ 5 4.0K May 31  2019 zypp.1ZngrK
drwx------ 5 4.0K Aug  7  2019 zypp.4w6OUh
drwx------ 5 4.0K Aug  7  2019 zypp.816avm
drwx------ 5 4.0K Feb 28  2019 zypp.8OwOIk
drwx------ 5 4.0K Nov 26  2019 zypp.VzOdWc
drwx------ 4 4.0K Feb 29  2016 zypp.wctIbT
drwx------ 4 4.0K Feb 29  2016 zypp.WYWiKF
drwx------ 4 4.0K Feb 29  2016 zypp.YHF32U
# du -s zypp.*
64      zypp.1ZngrK
60      zypp.4w6OUh
60      zypp.816avm
44      zypp.8OwOIk
56      zypp.VzOdWc
32      zypp.wctIbT
32      zypp.WYWiKF
32      zypp.YHF32U

I’ve now removed them all.

1 Like