UUID does not exist


I installed an update last night, but it won’t boot. This is normal since I started using bcache, in a couple of days there’ll be another update and it’ll be fine. I just boot from a previous snapshot in the meantime

The previous snapshot starts the boot process, I get the tumbleweed logo for a bit, but then I get a “UUID does not exist” error and won’t boot. Initially I thought maybe a drive had failed or had become disconnected but they all seem to be detected. (Also surely it wouldn’t get this far if that were the case?) I tried to probe the disks in recovery mode and I didn’t see any issues, but I couldn’t see most of the information because I couldn’t work out how to scroll up in tty.

I checked in YaST via install media and got “Probing file system with UUID XXXXXX failed”. If I ignore and go through the process as if I were installing tumbleweed again all of the drives and LVMs are visible when I go through with “start with existing proposal”, but bcache itself is not showing up under the bcache header, but I don’t know if it’s supposed to at this stage.

I found this thread: YAST Bootloader error: Probing filesystem failed which suggests that it’s a snapper issue (which would track) but ngl I can’t make head nor tail of the proposed workaround which is to invoke “LIBSTORAGE_BTRFS_SNAPSHOT_RELATIONS=no” uh somehow. Someone else in the comments of that bug report asked where exactly to put that and didn’t get a response. I tried pressing E in the grub screen and typing it next to the bit about CPU mitigations etc but it didn’t do anything that I could tell.

Is anyone able to offer any advice? Every day is a school day



Very few agree advantages outweigh disadvantages.

1 Like

Almost three years ago the maintainer for the kernel’s scrollback function quit, and no one took it over, so after 5.7.11, kernel scrollback literally became history.

You can have scrollback in a vtty if you can first load the screen command before your important screen content disappears (IOW, load it before doing anything else after logging in, if it’s available), and can figure out how to make screen’s scrollback functionality work. The dracut emergency shell in openSUSE apparently excludes it by default:

# lsinitrd /boot/initrd | grep creen

This is a fact of using a rolling release like tumbleweed, not of using bcache in and of itself. My other machine uses Nvidia hybrid graphics: I have to roll that one back far more often

(sorry for the double post, I couldn’t find any edit button. Maybe because I’m on mobile?)

But if I attempt to boot regardless the command line advises me to regenerate initramfs. This seems sensible – just remove the reference to the snapshot that no longer exists, however I’m not sure how I can do this from emergency mode?

A bit of an update: I’ve tried hitting E in GRUB, deleting the “root=[bad UUID]” line, typed “LIBSTORAGE_BTRFS_SNAPSHOT_RELATIONS=no yast2 bootloader” there, hit ctrl+X to boot but my edits are not committing. It’s just giving me the same message that the previous snapshot’s root SSID doesn’t exist. Is there something I’m missing? How do I get grub to boot with the parameters I type?