Using Wine for NAS synchronisation

I think the question is: Do I need to configure Wine for SAMBA? How? Also, how is the application installed under Wine? Using the .msi file?

You should not need wine. SMB is built in but you do need to configure But it may be better to use NAS. SMB is more Windowsy

Dos you mean that I can use the .exe (Windows) without needing to installl Wine? Otherwise, I’m not sure I understand what you mean. My problem is that Synology no longer provides a .rpm application for synchronisation of the OpenSUSE client data with itts NAS. There are now only exe, dmg, or deb packages, whereas previously an rpm package was availlable that had been compatible with Leap 15.2.

You should not need to rely on the desktop client software. It should be possible to ‘automate’ backups from the NAS itself. This article may be of value to you…

Yes, you are right. I already backup my (NAS) files automatically from the NAS itself. But that is NOT my problem. The function I am talking about is the automatic synchronisation of my client (desktop, laptop, cell phone) files with the NAS. This feature gives me access to all files I choose to synchronise practically instantaneously from any of my client. In other words, it is a local cloud, that requires an app on each client and the NAS,

(Those synchronised files are automatically backed up to a USB volume on the NAS at regular intervals.)

However, on looking at the article (many thanks for the tip!), I am wondering if the configuration reported there will give me a similar solution.

Lots of backup options over the network.Can use any supported network protocol ie SMB or NFS. SMB and NFS are network protocols and have nothing to do with backups persay.

Backups can be scheduled in many ways such as backintime or other backup programs there are a bunch or even scripts set to run under some conditions or times.

If you want a GUI tool for synchronizing files, consider Grsync

For the NAS, make sure that SSH is enabled…

It describes what needs to be done on the Synolgoy device, as well a using rsync on Linux hosts, but if you prefer a GUI then Grsync is your friend.

Great! This sounds like the solution I’m looking for. :)What would I have to do to ensure that the synchronisation is started automatically at (client) boot?

I assume that you’re just backing up a user’s files? In that case perhaps you could have it autostart upon login to the desktop environment and synchronize. Let’s see what others suggest here.

BTW, here’s a Unixmen guide where they show how to automate synchronization by creating a session for it and then implementing with a cron job…

Another guide that may be of interest…
https://ostechnix.com/grsync-a-simple-graphical-frontend-for-rsync/

I started testing with a one-shot file sync. It worked well. Unfortunately, there were about fifty files and/or folders that were not transferred. I confirmed that many (if not all) were rejected because their names contained special characters such as “:” or “?”. (The Synology sync had handled these well. Such file names had obviously not been rejected originally by my client file system . For example, an email reply ‘mbox’ file name (from Evolution) includes “Re:” or the email name subject may include a “?”).

Is there any way to configure ‘rsync’ to accept such file names?

Are you sure it is rsync that rejects those file names? Isn’t it the accepeting file system that can not cope with them? You did not mention what file system type is on the NAS, but I get the strong idea that the whole NAS is MS based.

It’s a Linux based system. But I’m not sure how to find out the file system

In fact w e have only your saying "Unfortunately, there were about fifty files and/or folders that were not transferred. I confirmed that many (if not all) were rejected because their names contained special characters such as “:” or “?”. But you posted nothing of those “rejected” messages or whatever told you that some files were not copied. So I guess not many people here can try to analyse what happened.

I seem to have no problems with files with names having Unicode characters outside the ASCII range. This is from my backup system, where all files have been created using rsync from my working system:

backup:/backups/backup.0/boven.henm.xs4all.nl/home/henk/test/unicode # l
total 12
drwxr-xr-x  3 1000 1000 4096 May 24 12:35 ./
drwxr-xr-x  4 1000 1000 4096 May 24 14:16 ../
-rw-r--r-- 10 1000 1000    0 May  5  2020 alles goed?
-rw-r--r-- 10 1000 1000    0 Jan 11  2016 hello
drwxr-xr-x  2 1000 1000 4096 Mar 31  2014 öäüßÖÄÜ/
-rw-r--r-- 10 1000 1000    0 Feb 22  2016 Œé⁶
-rw-r--r-- 10 1000 1000    0 Jan 11  2016 Χαίρετε
-rw-r--r-- 10 1000 1000    0 Jan 11  2016 Здравствуйте
-rw-r--r-- 10 1000 1000    0 Jun 20  2016 Лшадсщ
-rw-r--r-- 10 1000 1000    0 Jan 11  2016 أهلا
-rw-r--r-- 10 1000 1000    0 Jan 11  2016 नमस्ते
backup:/backups/backup.0/boven.henm.xs4all.nl/home/henk/test/unicode #

There is even a ? there (by incident).

I have tried transferring some of the suspect files/folders from my client to the NAS ‘by hand’.
I am logged in to the NAS using Nautilus using SMB/CIFS.

Results are as follows:
Files and folders containing “|” or “?” fail to transfer with “Invalid argument”
Folders (but not files) containing “:” fail to transfer with “Invalid argument”

Obviously, these are selected examples there may be more.

Could I use a different protocol?

This is limitation of SMB/CIFS protocol. It restricts characters that are allowed in file names.

Ha, all things connected to Microsoft. >:)

But he uses rsync. Is he doing that over SMB? The world is full of strange things.

In any case, you agree with me that blaming rsync is incorrect.

No SSH is used for that.

So should we conclude that the NAS file system is Windows based? Let’s see what Synology says.

I have no idea. I was just a suggestion after you blamed rsync for not accepting those file names (of which you STILL posted no prove in the form of an error message or whatever).

Not that rsync will complain when you blame it falsely, but searching for the cause of this with rsync (by e.g. asking for an option to rsync) is pure loss of time.