Any success installing the Synology Active Backup Agent?


Since I use my Tumbleweed box in an environment with lot’s of services provided by a Synology Server I like to integrate these like I have done with the other boxes (most of them running WIndows obviously…).

I managed to install the synology-drive-client (for cloud access) which I downloaded as *.deb file, transformed wit alien to rpm and installed by ignoring a “not provided” (I am pretty sure it’s on my system!). - Turns out the cloud synchronsiation works just fine!

More important though I wanted to install the “Active Backup for Business Agent” as the server conveniently pulls daily backups of all other machines to administer in a centralized pool.

There is a client package labeled as rpm for linux but it’s delivered via a “” script. Sadly the script fails:

install failed, this installer is for linux distribution that uses yum/rpm as package management

I cecked the script and couldn’t find any reference to a rpm file tat’s supposed to be downloaded… also tried downloading the deb installer but it’s also a script and it also fails.

Any ideas how to solve this?

Is there an alternative software source for te Synology packages?
Couldn’t find any current ones in the OBS…

Does anyone else here integrate wit a Synology server?

Tanks for reading,

Your description lacks all terminal output to follow your description. It is better to paste full command/output than only pasting a part…Did you try to install it as described on the Synology page?

The installer file of the agent is a .zip file. 1. Make sure that you download the correct installer for your Linux physical server.
deb: Ubuntu and Debian distributions
rpm: CentOS, RHEL, and Fedora distributions
After extracting the downloaded file, follow the steps in the README file and execute sudo ./ to install the snapshot driver and agent on your Linux device.


I tought I mentioned that I ran “”.

So the command has been “sh” - does that help?

My question here is whether there is a way to force install it.

As I mentioned the RPMs for other service provided by Synology (as actual RPM files and not as run scripts) do not support OpenSUSE either but can be installed and do run without problems.

Do you assume I do not read the official documentation though managing (as mentioned) a whole array of boxes running the ABfB agent? I sure do before hitting support and forums…

For context:

On Arch I use the rsync client integrated into active backup to backup file servers as a workaround…

On openSUSE though when the rsync process starts syncing files (Synology pullling the files from the openSUSE box) - the openSUSE system crashes and restarts - that’s why I am so eager on getting the “normal” agent running.

Anyway… Do you have a suggestion on how to do that?


FWIW, some threads that may be of interest:

Haven’t been able to get it running yet, but I use the synology drive client to coninously my home directory. A bbit of tinkering but it does the job…

Still no good solution to have a simple desaster recovery for the whole system - probly backintime will do the trick. I just haven’t found the time yet to set it up…

Best regards,