Using Slim as login manager

I was trying to set up my Xfce desktop on a fresh install.

I personally dislike Xdm, which is given as the default login manager, and would prefer to use Slim instead.
It is possible to install it using the Package Search feature (it’s listed under the Contrib repository), but I haven’t been able to set it as the default login manager (I wasn’t able to find such a setting in /etc/sysconfig).

Any help is appreciated, thanks in advance :slight_smile:

You do not mean* /etc/sysconfig/displaymanager*> That is where YaST > System > etc/sysconfig editor says the value DISAPLAYMANAGER is stored (and it also says it can be set to

kdm, kdm3, kdm4, xdm, gdm, wdm, console or any value

Last time I checked, entering “slim” didn’t work - i.e. Xdm was starting regardless.
Is there perchance a new version of some package I am not aware of?
I am going to try again on a fresh install anyway.
I’ll let you know, thanks a lot for now.

It worked… feeling a little dumb. :shame:
Don’t really understand why didn’t it work in the past.

Slightly off-topic, I opted for the non-automatic system configuration on install, but I was denied the luxury of setting things up. Namely, after the installation was complete, the system rebooted and I was prompted to login, without entering Yast.
As a matter of fact, I could only enter as root, as there was no user set-up for me. I fixed everything “manually” after logging in. Is this a known issue? :sarcastic:

Thanks again!

!) Congrats with having working what you wanted. You will grow over the fact that you do not know why it didn’t in your first try with the years lol!

  1. I normaly do a configure yourself install. I always get a change to create users during the installation (and to configure my network and my partitioning). Thus I answer your question “Is this a known issue?” with: Not to me.