Using eric in Leap 15

I am a student wanting to learn python. I have been told that the eric IDE is a good one. I have tried installing eric5 from the repositories and eric6 from and neither work. eric6 gives me a brief splash screen and that’s all. In the console I get the following messages:

garry@neo:~> eric6
Warning: translation file 'qt_en_AU’could not be loaded.
Using default.
Warning: translation file 'qscintilla_en_AU’could not be loaded.
Using default.
BackgroundService listening on: 35447
Segmentation fault (core dumped)

I have tried looking for the files mentioned but I cannot find them anywhere. Any help is welcome.


Hello and welcome here.

Can you please be a bot more precise.

Which repositories, and how? And what was the result of the “trial to install”.

There is no found on the internet.

And as last something you could not know:
There is an important, but not easy to find feature on the forums.

Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.


Never heard of it. I guess you will be better of with PyCharm or VS Code. VS Code might not be available in the repositories.

I do belie the OP is referring to
it’s available for TW in the main and devel:/languages:/python repo’s
unfortunately it’s not in any official LEAP repo’s there are a few user build repo’s but those are experimental
the OP can open a bug report at opensuse’s bugzilla and maybe one of the maintainers will release a LEAP build
@OP where did you install eric from tell us your repo list

zypper lr -d

did you open port 35447 in the opensuse firewall it’s quite possible that port is being blocked try opening that port

sudo firewall-cmd --permanent --add-port=35447/tcp
sudo firewall-cmd --permanent --add-port=35447/udp
sudo systemctl restart firewalld.service

AFAIK the following Developer Forum thread is still relevant. The thread is about installing on Tumbleweed, but with some minor repo URI adjustments, the instructions should be fully applicable for LEAP. If you have problems making the instructions work, post again and I’ll post a LEAP version of instructions(or, someone else can beat me to it).

Bottom line…
Although eric5 is still in the repos, it hasn’t been maintained by the eric project for a very long time now.
Install and use eric6 instead.
Install the prerequisites as described in the Forum thread, then install eric6.


Thanks TSU
I will give that a try. Meanwhile I did try installing pyCharm as advised above and it works like a charm (pun intended :))
So you can close this thread as I am now working ok with pyCharm.

Thank you everyone.
PS you are right, I did mean, sorry for that.