USB wifi stick

Hi all,

I am having trouble with understanding how to install the drivers for my linksys wusb100 ver2 wifi card.

What I have found so far is that the usb stick uses a ralink driver (rt2870)

I have read that I may need to compile the driver on my system but I am not sure how.

any help appreciated (or recommends on alternate hardware that will provide me with wifi access via a usb port would be fine too)

Thanks,
Brian

Please post the results of this command here, with the USB stick plugged in :

lsusb

Best regards,
Greg

As su -

zypper in kernel-firmware

It holds the required driver for your device

On 01/11/2011 02:36 AM, caf4926 wrote:
>
> As su -
>
>
> Code:
> --------------------
> zypper in kernel-firmware
> --------------------
>
>
> It holds the required driver for your device

Please watch usage. A driver is not firmware, and firmware is not a driver.

Yes
That’s obvious, just look at the package name.
But my usage was levelled at being informative to the uninitiated - albeit lacking in technical accuracy :smiley:

Hi guys,
here are the results of running the code you posted:

I am not sure if this means it is installed now or not

I am running a live cd install of openSuSe 11.3

linux-2zss:/home/brihno # zypper in kernel-firmware
Loading repository data…
Reading installed packages…
Resolving package dependencies…

Nothing to do.
linux-2zss:/home/brihno # lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 1737:0078 Linksys
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Hang on
A live CD. You mean this is not a real installation!

On 01/11/2011 10:36 AM, brihno wrote:
>
> Hi guys,
> here are the results of running the code you posted:
>
> I am not sure if this means it is installed now or not
>
> I am running a live cd install of openSuSe 11.3
>
>
> linux-2zss:/home/brihno # zypper in kernel-firmware
> Loading repository data…
> Reading installed packages…
> Resolving package dependencies…
>
> Nothing to do.
> linux-2zss:/home/brihno # lsusb
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 001 Device 002: ID 1737:0078 Linksys
> Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

From what I read at http://ubuntuforums.org/archive/index.php/t-1236955.html,
the rt2870sta driver does support your version, but the kernel still does not
recognize that ID, even though the thread is 18 months old. Apparently, no one a
Ubuntu told the upstream developers about the new ID.

We can see if they are right with the following commands:


su -
/sbin/modprobe -v rt2870sta
echo "1737 0078" > /sys/bus/usb/drivers/rt2870/new_id
exit

At this point, your kernel should have recognized the device. Look at the end of
the dmesg command for some indication. Next, look at the output of

/usr/sbin/iwconfig

Does it see a wireless device?

Once we determine that it works with these IDs, I will personally push the patch
upstream.

sorry for the confusion; I am not running off the live CD I just used the live cd version to install.

The OS is running off the Hard Disk

Just take up @lwfingers assist, he is a wireless genius.

here is the output of the code you suggested (along with the code itself):

linux-2zss:/home/brihno # /sbin/modprobe -v rt2870sta
insmod /lib/modules/2.6.34.7-0.7-default/kernel/lib/crc-ccitt.ko
insmod /lib/modules/2.6.34.7-0.7-default/kernel/drivers/staging/rt2870/rt2870sta.ko
linux-2zss:/home/brihno # echo “1737 0078” > /sys/bus/usb/drivers/rt2870/new_id
linux-2zss:/home/brihno # exit
exit
brihno@linux-2zss:~> /usr/sbin/iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 Ralink STA ESSID:"" Nickname:“RT2870STA”
Mode:Auto Frequency=2.412 GHz Access Point: Not-Associated
Bit Rate:1 Mb/s
RTS thr:off Fragment thr:off
Link Quality=10/100 Signal level:0 dBm Noise level:-115 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

I also just noticed the get you wireless working post in the wireless forum, so just to be thorough: There is no Wireless Lan entry in the hardware information.

there is no UDI entry in the list that I can see, but the device seems to know what kernel driver it needs and finds it as rt2870sta.

It also lists the driver as rt2870.

If more info is needed let me know.

On 01/11/2011 01:06 PM, brihno wrote:
>
> I also just noticed the get you wireless working post in the wireless
> forum, so just to be thorough: There is no Wireless Lan entry in the
> hardware information.
>
> there is no UDI entry in the list that I can see, but the device seems
> to know what kernel driver it needs and finds it as rt2870sta.

Not exactly. Those two commands from the last post FORCED it to use rt2870sta.
We still need to know if that is a good fit. It seems to be in that you got a
wlan0 created.

> It also lists the driver as rt2870.

Of course - that also was forced.

> If more info is needed let me know.

OK, the driver got loaded with the modprobe command and the new_id change. Note:
Those two commands will be needed with every reboot until the kernel is updated
with the new ID.

Please issue the dmesg command and investigate the details from the point that
the rt2870 driver was loaded. If there is anything that you don’t understand,
post that part. The whole output is too big for the list.

If the dmesg output looks clean, you should use YaST => Network Devices =>
Network Settings to use NetworkManager as the method for controlling the
network. At that point, log off and back in. You should now see an applet for
the network in the lower-right hand corner of the screen. From it do the
configuration. As you did not say KDE or Gnome, I cannot be more specific.

I will do this when I get home tonight. I am off to an asp.net lab and work which will keep me busy until 7:30 pm PST.

cool it’s now recognized and working. Now I just have to get it connected! I think i can get it figured out thanks all!

@Larry

I already had a little conversation with GKH regarding this ID (and another one from linksys, 1737:0079 to be precise).

However, as I happened to get a “guinea pig” only for 1737:0079 and the results for that device were not really promising (looks like there are problems with firmware loading) I did not submit that patch.

It is quite interesting that most threads found for 1737:0078 and especially 1737:0079 are a little older and from a time, where firmware was compiled into the drivers directly.

This has been changed some time after 2.6.31 and maybe this broke at least 1737:0079.

So it would be interesting to see the output of the kernel (dmesg or /var/log/messages) directly after forcing rt2870sta to be used for the device.

Another point to be made, the firmware images in linux-firmware have a size of 4K and inside the code this size seems to be hardcoded as max-size.

ls -l /lib/firmware/rt{2870*,307*}
-rw-r--r-- 1 root root 4096  1. Mai 2010  /lib/firmware/rt2870.bin
-rw-r--r-- 1 root root 4096  1. Mai 2010  /lib/firmware/rt3070.bin
-rw-r--r-- 1 root root 4096  1. Mai 2010  /lib/firmware/rt3071.bin

while the latest firmware image from Ralink -which is labelled as a firmware suitable for all draft-N chipsets- has an 8K size.

When using that firmware image, my “guinea pig” reported that the in-kernel driver seemed to support his device (1737:0079) but without supporting the 5G band.

The rt3572sta vendor-driver (yes, another one, Ralink seems to always expand their rt2870-code for new chipsets but instead of merging it into rt2870 they create a new driver with a new name) supported that device with 5G (although one had also to add the USB-ID manually).

So maybe things are a little more complicated.

On 01/12/2011 06:06 AM, Akoellh wrote:
>
> @Larry
>
> I already had a little conversation with GKH regarding this ID (and
> another one from linksys, 1737:0079 to be precise).
>
> However, as I happened to get a “guinea pig” only for 1737:0079 and the
> results for that device were not really promising (looks like there are
> problems with firmware loading) I did not submit that patch.
>
> It is quite interesting that most threads found for 1737:0078 and
> especially 1737:0079 are a little older and from a time, where firmware
> was compiled into the drivers directly.
>
> This has been changed some time after 2.6.31 and maybe this broke at
> least 1737:0079.
>
> So it would be interesting to see the output of the kernel (dmesg or
> /var/log/messages) directly after forcing rt2870sta to be used for the
> device.

@brihno: Once you get it actually working with the forcing commands, please post
the output of dmesg at one of the pastebin or equivalent sites and post the
link. In addition, please send me a private message with your name and email
address.

> Another point to be made, the firmware images in linux-firmware have a
> size of 4K and inside the code this size seems to be hardcoded as
> max-size.

Yes, the source sets the maximum size for USB (rt2870) firmware at 0x1000 (4096)
and PCI (rt2860) firmware at 0x2000.

–snip–

> So maybe things are a little more complicated.

Always, but it appears that we can get 1737:0078 into the kernel without
complications.

will do when I get home at 7 PM PST

brihno@linux-2zss:~> dmesg [ 0.000000] Initial - Brihno’s dmesg

here is the pastebin link

On 01/12/2011 10:06 PM, brihno wrote:
>
> ‘brihno@linux-2zss:~> dmesg 0.000000] Initial - Brihno’s dmesg’
> (http://pastebin.com/JVmZ7Svk)
>
> here is the pastebin link

That all looks normal and I see the results of scans in the

===>rt_ioctl_giwscan. 3(3) BSS returned, data->length = 410

messages. You have 3 APs in range.

I will push the new ID upstream with a copy to you. Thanks.