USB WiFI Adapter no regocnized after reboot

Today a ran into a problem. OpenSuSE 15.3 fully updated, I rebooted the system due to new kernel update.

NetworkManager did not show any WiFi Adapters. I tested around with Modemmanager, other USB WiFi-Adapter, nothing worked.
The Adapter was shown in lsusb, but ModemManager did not show up anything.
First I thought that is is related to kernel, udev or dbus, but that is not the case

After hours of research, I found the solution here:

Results that the latest update activated that unsupported modules (not flagged as supported by SuSE), will not be loaded unless
you allow unsupported modules.

You may test journalctl -f, the plug in the Adapter, and look again. If it tells you that there is an unsupported module, the above link does the work.
set ‘allow_unsupported_modules 1’ in /etc/modprobe.d/unsupported-modules

After that change, NetworkManager could see the adapter and everything works again.

I applied that kernel update on Monday. When I rebooted, I had no network (I am using “wicked”).

I tried

systemctl restart network

That did not help.

So I rebooted. My intention was to boot the previous kernel. But, due to a slip of the finger, I rebooted the same (newest) kernel. And this time, I had a running network.

I’m not sure what went wrong. I will be watching closely for the next few reboots. My next planned reboot is tomorrow.

Hi, I tried previos kernel too, no efect.
And I tried also change to wicked, but USB-WiFi where not recognized.

Did you try to enable unsupported modules ?

Is that just a reference to kernel-default-extra? I do have that installed.

No, I had kernel-default-extra and kernel-default-optional installed before this issue

Dell ProLiant, Intel Xeon processor, 32Gb Ram.

Installation of kernel-default-extra automatically enables loading of unsupported modules, you do not need to do anything.

This is what I did from Opensuse 15.2 a few weeks ago:

zypper --releasever=15.3 ref
zypper --releasever=15.3 dup --download-in-advance

Update was working excelent, no problems, everything worked well, also USB-network.

About one week there have been no problem, everything worked well.

But, updating from kernel 5.3.18-59.16-default to 5.3.18-59.19-default, and then rebooting, unsupported modules got disabled without doing nothing.

Don’t know why it happened, the required packages all where installed before, I should have worked.

I use Linux since Suse 5.3, but I have no idea why this happened.