*INFO: *
OpenSUSE 11.2
x64, Intel Pentium Quad Core
ext4 file system

I have a USB sound recording device and I use it as my main Sound output for Windows and will use it for OpenSuSE Linux:

The problem is, I can’t add the device through the “Sound” in YAST.

Here is the following method I use:

  1. Opened YAST
  2. Clicked Sound
    under Hardware 1. Clicked Add
    to add device 1. Chose Tascam
    and US122/224/428 1. Chose Quick Automatic Setup
  3. Then notification comes up if I want to permanently remove existing sound cards, I choose NO
    (this is the built in sound card of the mother board) 1. Then Hardware setup shows as error with the following message, "The Kernel Module snd-usx2y for sound support could not be loaded. This can be caused by incorrect module parameters, including invalid IO or IRQ parameters.

I am thinking that it failed because I’m using an internal sound card instaler instead of a USB device installer.

Is there a Manual solution to this? Instead of using the Quick Automatic Setup on step 5?

Additional notes:
When I click Hardware Information in YAST, the device is being listed on the USB devices.

I’m trying to recall that menu. Are there not 3 choices and “quick” is the choice at the top ? I typically go for the choice in the middle (I can’t recall the name) which IMHO works better.

Hi there,

It looks like your particular device needs a kernel module you do not have loaded. This might me a very easy fix.

First, let’s see if that module is really loaded with:

lsmod | grep snd_usb_usx2y

If not, simply try to load the module (as root) with:

#modprobe snd_usb_usx2y

If that does not work, see if your kernel was compiled to include this, perhaps with:

user@Desktop:~> grep -i snd_usb_usx2y /boot/config-uname -r

If you can load the module, then try installing the sound card again.

Lews Therin

Thats a good point. I think snd_usb_usx2y comes with alsa-firmware. The op should ensure they have the rpm alsa-firmware installed.

yes, there are 3 options, the Quick Automatic, Normal, and Advanced. The Quick and Normal did not work, unfortunately. I’m curious with the Advanced setup as it does allow you to enter commands… I just don’t know what commands should I put in so it’ll make the device work.

Unfortunately, I checked config-x.xx.x-desktop and it has *CONFIG_SND_USB_USX2Y=m *on the line; it also has CONFIG_SND_US122 on a following line. I’ll try a different method – instead of using the proper vendor and product name, I’ll choose **Generic USB audio **from the sound card configuration in YAST. If that doesn’t work I’ll test the USB audio during the OS installation; this device was plugged in after the OS installation, and most devices are working when they are detected during installation (I.E. video cards).