USB Sound Card

Hi there.
New OpenSUSE user, just installed version 12.1.

All looking nice with KDE, but I can’t get my external USB soundcard to work. It is a TAPCO Link. I tried adding a generic USB soundcard through yast. But that came up with an error.

Is anyone able to assist Me in getting this going?


On Tue, 29 May 2012 07:26:03 +0000, Shawn76 wrote:

> But that came up with an error.

What was the error?


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at

Hmm. Maybe not to worry. I came home from work and tried to boot it up but the OS appears to have eaten itself! The disc was borrowed so don’t have it to reinstall atm, so going to try Fedora & Mint next (Ubuntu died gloriously as well rotfl! )

Shame, as I really liked OpenSUSE… will perhaps come back to it.

So I run Fedora from a live CD. Looks good and it works off the bat with my interface. So I install it. When it reboots BAM! Up comes OpenSUSE instead. :sarcastic:
MY PC doesn’t want to boot into CD’s anymore, just straight into SUSE!
Anyway this time around it can see my Tapco card, but still no sound. I’ve found a trouble shooter online which I’ll try before bothering you guys too much. Thanks for the response though sir. I may be back :wink:

Give thought to installing the application ‘pavucontrol’ and use that to configure your USB device. I provided some pavucontrol guidance in a blog post here: Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

I that fails, some more information would be helpful. With your PC connected to the internet and USB sound card plugged in, as a regular user run the diagnostic script in a terminal:


and select the SHARE/UPLOAD option and when script is complete, copy the web-address/URL it gives you and paste the URL here. We can then look at that and perhaps see the problem (and maybe give advice).

Thank you OldCPU. The guide I checked out suggested pavucontrol which seemed to fix it. I notice pulseaudio takes up 50% CPU though which I find excessive. Only problem I need to sort now is Iplayer glitchyness, which I’ll start a new thread for. Then I think my system is happy.
Thank you for the support.

I have the same problem. Skype doesnt see my cards.

thanks a lot.


I can not understand why your problem is the same problem . I can not see where the 1st user mentioned Skype not seeing their cards . Yet you say it is the same problem. What am I missing here ? Please, can you help me and point out where your problem is the same ? :frowning:

Not having that information, I recommend you go here for guidance wrt Skype and pulse audio:

Also, how did you install Skype ? What method did you follow /

Im sorry OLDCPU for my poor description. I installed Skype from website official. I had 2 card, 1 onboard 2 usb (i use this with Skype). Skype doesnt see my usb card. My question is:

How can i use usb card with skype and the same time to setup internal card with rest of applications (browser,music,etc) ? If you need more information or execute any command, plz let me know.

Thanks for your time and patience. :wink:

Typically, one needs to do more than just install Skype from the official website. The version of Skype packaged there for openSUSE, if installed direct, does not nominally pull in enough dependencies in order for Skype to work properly. At least that is the case for a 64-bit openSUSE and may be true (to a lessor extent) for a 32-bit openSUSE.

Please follow the Guide here: Skype - openSUSE Wiki

In your case, since your PC is a 32-bit openSUSE-12.3 , that may mean you will need some more packages before installing skype. On openSUSE-12.3 the skype package from will depend on these and its not clear to me they will be installed automatically .You can install the packages by sending in a terminal (with regular user permissions) the command:

su -c 'zypper install libqt4 libqt4-x11 libqt4-dbus-1 libsigc++2 libpng12-0'

and enter root password when prompted for your password.

Thanks a lot, i am going to try this.