USB flash drive won't show up anymore!

When I plug my USB stick in, it no longer registers. If I type: “lshal -m” and then plug it in, nothing shows up. What can I do to fix this? What could the problem be?

Is this kde or gnome?

If you open a su terminal and do

fdisk -l

Does it show?


When I type: /sbin/fdisk -l I get:

/dev/sda1               1         121      971901   82  Linux swap / Solaris
/dev/sda2   *         122        1856    13936387+  83  Linux
/dev/sda3            1857        4427    20651557+  83  Linux

I believe that’s my swap, home and root drives, right?

Have tried other usb devices to see if they are picked up?

Yep, and they load fine. I think it might be toast.

I tried: cat /proc/partitions (before and after plugging it in) and it doesn’t show.

If you have a Parted magic CD. Boot it, with the USB drive plugged in. See if the partitioner (parted) picks it up. If it does. Format it.

Is that the same as “parted” which is available in the repositories (and once loaded is /usr/sbin/parted)? If so, I have that and when I issue the command “print” with it, it only shows the swap, root and home. It doesn’t show even the USB drive that does work.

If not, where do I get parted magic? Can I just install it directly on the HD or do I need it booted from a CD?

Better try this live cd, download and burn
Downloads - Parted Magic

This happens to me occasionally. I power down, take the drive off, swear about american bankers 5 times, execute a circle, power up, reinsert the drive and it comes back open in Nautilus (I’m a Gnomer).

Unless it’s NTFS, then the ritual is different.

But of course, yours might not have the same problem as mine.

I can’t get it to read on windows or linux anymore. I think it’s dead. :frowning:

It’s dead.:silly: