USB Controller Not Working With Steam Link

I have a Steam Link box set up to stream games in my house. Previously it worked wonderously with Leap 42.1 and a Logitech F310 USB controller.

I upgraded to Leap 42.2 and whilst the USB controller still works when directly plugged into the desktop, it no longer works when plugged into Steam Link and connecting to the oS computer (it does still work in Steam Link menu when you can select what computer to connect to).

I have tested whether it is openSUSE or Steam Link by loading up Steam on Windows 10 and confirmed that if I do this, then the USB controller still works so it seems like the origin of the error is openSUSE (or Linux… I don’t have another distro installed to test).

Any thoughts on what could be a solution or how to begin to diagnose this? Reinstall Steam on oS?

Try reinstalling steam. There may be a last drastic way to start re-initiation, but it is reported a re-install will work.

I’ve tried removing and reinstalling Steam but the issue still persists.

I actually don’t think I ever tried it on Leap 42.1, previously I have always streamed from Windows. The odd thing is that I have a wireless keyboard plugged into my Steam Link and that works when connecting to Leap 42.2, it just seems the USB controller isn’t working.

Not sure how to proceed with this. Maybe removing Steam did not remove all associated files?

I don’t think you have to uninstall see this thread

But if it just that the control does not work that is a horse of another colour

First check for other threads having a similar problem with the particular hardware

Also do a lsusb and see if the hardware is seen by the system

The controller works if plugged directly into the desktop that is running Steam, no issues there. But it seems that when it is plugged into Steam Link, oS is not recognizing the signal being sent across the network for the controller - maybe something to do with emulation? I don’t really know, I’m well out of my depth on this one.

As another test, I eventually installed Ubuntu 16.04.1 on a separate partition and it works with no issues so that rules out any difference between Linux/Windows. Perhaps it’s a permissions issue (I feel like oS by default is a bit tighter on requiring permissions than Ubuntu for some tasks).

I’ll do some more research, but in the meantime if anyone has any bright ideas please let me know!

I wouldn’t think it’s a permissions problem. Unfortunately as far as I know steam is officially supported only on Ubuntu and SteamOS. The only recommendation I have is to check steam logs in real time for Ubuntu and openSUSE install and see what is different there. I never used steam much but I think you can see the logs as console output if you run the steam command from the console.

Good idea, I’ll start Steam via the konsole and see if it kicks anything out that might help.

Ok so I reinstalled Leap 42.2 and still have the same issue. However, I get this input in the Konsole when running Steam and trying ti use the controller from the Steam Box:

CLIENT: Attaching controller Logitech F310 Gamepad (XInput) with ID 0

Couldn’t initialize virtual gamepad: Couldn’t open /dev/uinput for writing

Setting uinput to chmod +666 worked as per another forum post. Just need to find a way to make it persistent now…

Found a permanent solution here: rotfl!

Nice one :slight_smile: thank you for the information. So it really was a permissions problem in the end.

Yeah, a few posts relating to Debian show the same issue.

It worked without problems on Ubuntu though, and my feeling is that Ubuntu is quite loose with giving out permissions compared to say, openSUSE (writing to uinput, mounting volumes as executable by default, etc.).