usabip on opensuse 12.3

I can get network manager to connect to my usb server, but from then on in I just cannot get the system to recognise its existence. list -l does not show it up, and none of the others work just keeps on giving me the correct syntax for the command line. I have tried always to get this work (works well under Windows 7 on its own program). None of the howto seem to relate to my version, they quote something about -common.ko and all I have is host and one other. All the modules are loaded using insmod.

Can anybody point me to a relevant howto please.
Many thanks.

Sorry, but I don’t understand your help request.

  1. What is “usabip”
  2. What is a “usb server”
  3. What does the command “list -l” supposed to do?
  4. What is working well in “Windows 7”
  5. What does the kernel module “-common.ko” do?
  6. All modules, includes what kernel modules?
  7. You mention Network Manager, are you using this with Wireless or a Wired network connection.
  8. What desktop are you using?
  9. Is this a 32 or 64 bit install?
  10. What kind of computer is this problem being found on?

Thank You,

In answer to your questions.

  1. I am talking about usbip, it is a typo on the title.
  2. This is a networking usb server, operated over a wired network between my computer a Toshiba Satellite c660-220. It provides network access to usb devices such as printers, webcams, memory sticks etc. If there is more than one computer in the home then all the computers have access to these devices. Usbip is supposed to make it happen. I want to use it over a wired network to supplement the lack of usb and other ports on my computer. I have no expansion slot.
  3. It is a 64bit install.
  4. the reference to the use of window indicates that it is not a hardware problem but a software problem in terms of either opensuse12.3 or usbip
  5. what I am referring to are details in relation to the program usbip, which is a command-line program. The kernel modules are the ones relating to usbip: usbip-core.ko, usbip-host.ko, and vhci-hcd.ko. These kernel modules have to be loaded before the program works.

In essence what I am saying is that the kernel modules have been loaded lsmod shows that, the network is connecting to the usb networking server, the problem lies in that usbip is recognising the remote server (or host) and all but the command “list” just says in effect “error in the command-line”. I have tried all ways to find what the fault is and cannot find it. The man page details and procedures are just rejected as invalid.

I trust this explains it all.